Subject: [core] Featurecast - group communication service for WSN

From: Michał Król <[email-masked]>
Date: Mon, 17 Nov 2014 14:23:15 +0100

Dear all,

We have designed a group communication service suitable for Wireless Sensor
Networks. It addresses the requirements specified in the Group
Communication for CoAP (draft-ietf-core-groupcomm-25) and presents several
interesting aspects comparing to the use of IP Multicast. A paper on
Featurecast (Featurecast: Lightweight Data-Centric
Communications for Wireless Sensor Networks) has been accepted for
publication at EWSN'2015.

We have prepared a draft to spawn a discussion around the issues and get
your opinion on the proposed approach. Any feedback is welcome.

Thanks in advance,

Michał Król
PhD  student
Grenoble INP

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 25 Nov 2014 07:35:35 +0000

Hi Michal,

Thanks for the very interesting draft.  Some initial feedback:

·         Editorial: You should submit your draft to the IETF tool with the word “core” in the document title so that it shows up on the CORE document list

o   E.g: draft-krol-core-featurecast

o   You can see other examples of naming in https://datatracker.ietf.org/wg/core/documents/

·         As you know, one key feature from Group Communication ( http://datatracker.ietf.org/doc/rfc7390/ ) is that utilizes standard IP Multicast protocols (e.g. PIM-SM or RPL) for the underlying group message distribution.  What I understood from reading your draft is that you are proposing to change that such that:

§  “To create routing tables, every node in the network defines a set of its features and advertise them in the network.”

·         The question I have is that what happens if the members of the group are in widely separated geographical IP subnets (e.g. Controller nodes on a nation-wide smart grid).  Can this type of Featurecast routing tables still be constructed?  We know PIM-SM would still work but would your proposed Featurecast work?

Best Regards,

Akbar

From: core [mailto:[email-masked]] On Behalf Of Michal Król
Sent: Monday, November 17, 2014 8:23 AM
To: [email-masked]
Subject: [core] Featurecast - group communication service for WSN

Dear all,

We have designed a group communication service suitable for Wireless Sensor Networks. It addresses the requirements specified in the Group Communication for CoAP (draft-ietf-core-groupcomm-25) and presents several interesting aspects comparing to the use of IP Multicast. A paper on Featurecast (Featurecast: Lightweight Data-Centric
Communications for Wireless Sensor Networks) has been accepted for publication at EWSN'2015.

We have prepared a draft to spawn a discussion around the issues and get your opinion on the proposed approach. Any feedback is welcome.

Thanks in advance,

Michał Król
PhD  student
Grenoble INP

---

From: Michał Król <[email-masked]>
Date: Tue, 25 Nov 2014 15:51:16 +0100

Hi Akbar,

thanks for your answer. Featurecast in its current version is designed to
work in local networks. However I think it shall be pretty straightforward
to modify it allowing communication between different subnets.
The simplest solution will be to use a prefix in the destination address.A
packet can be routed in the global network as a traditional multicast
packet and the filter with the features will be decoded in subnets where
the data shall be delivered. In such case we do not need to modify all
routers, but only those in local subnets and use well known protocols
(PIM-SM).

I uploaded our paper, which contains some additional information, our
simulation results and a comparison with IP multicast:
http://lig-membres.imag.fr/krol/wp-content/uploads/sites/174/2014/11/feature-routing-long1.pdf

Regards,
Michał Król

2014-11-25 8:35 GMT+01:00 Rahman, Akbar <[email-masked]>:

> ·         Editorial: You should submit your draft to the IETF tool with
> the word “core” in the document title so that it shows up on the CORE
> document list
>
> o   You can see other examples of naming in
> https://datatracker.ietf.org/wg/core/documents/
>
>
>
> ·         As you know, one key feature from Group Communication (
> http://datatracker.ietf.org/doc/rfc7390/ ) is that utilizes standard IP
> Multicast protocols (e.g. PIM-SM or RPL) for the underlying group message
> distribution.  What I understood from reading your draft is that you are
> proposing to change that such that:
>
> §  “To create routing tables, every node in the network defines a set of
> its features and advertise them in the network.”
>
> ·         The question I have is that what happens if the members of the
> group are in widely separated geographical IP subnets (e.g. Controller
> nodes on a nation-wide smart grid).  Can this type of Featurecast routing
> tables still be constructed?  We know PIM-SM would still work but would
> your proposed Featurecast work?
>
>
>
>
>
> Best Regards,
>
>
>
>
>
> Akbar
>
>
>
>
>
>
>
> *From:* core [mailto:[email-masked]] *On Behalf Of *Michal Król
> *Sent:* Monday, November 17, 2014 8:23 AM
> *To:* [email-masked]
> *Subject:* [core] Featurecast - group communication service for WSN
>
>
>
> Dear all,
>
> We have designed a group communication service suitable for Wireless
> Sensor Networks. It addresses the requirements specified in the Group
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>
>