Subject: Re: [core] CoAP No-Response: use with NON only?

From: Abhijan Bhattacharyya <[email-masked]>
Date: Wed, 4 Feb 2015 15:33:55 +0530

Hi Esko, Carsten,
Sorry to respond late on this. 
Indeed, request/response layer and messaging layer functionalities should 
be separated. We shall remove the constraint regarding dependency on 
NON/CON. But as a note we shall keep the discussions that we had in the 
mailing list regarding why using this option with NON may be an obvious 
sane approach. 
Hope, that should be fine.

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.   IT Services
                        Business Solutions
                        Consulting
____________________________________________

From:   Carsten Bormann <[email-masked]>
To:     "Dijk, Esko" <[email-masked]>, Abhijan Bhattacharyya 
<[email-masked]>, "[email-masked]" <[email-masked]>
Date:   01/28/2015 01:44 PM
Subject:        Re: [core] CoAP No-Response: use with NON only?

> “primarily intended to be used with non-confirmable update requests
> (e.g., PUT) and should have no effect if used with a CON  request.”

Hmm, I'm not sure we should make option semantics depend on a detail
(CON vs. NON) at the message layer.

"This appears to be more useful with NON" is sage advice, but the
request/response layer shouldn't have to react differently based on
message layer proceedings.

Grüße, Carsten

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: "Dijk, Esko" <[email-masked]>
Date: Wed, 4 Feb 2015 18:48:35 +0000

That sounds to me like the best approach! Agreed,

Esko

From: Abhijan Bhattacharyya [mailto:[email-masked]]
Sent: Wednesday, February 04, 2015 11:04
To: Carsten Bormann; Dijk, Esko
Cc: [email-masked]
Subject: Re: [core] CoAP No-Response: use with NON only?

Hi Esko, Carsten,
Sorry to respond late on this.
Indeed, request/response layer and messaging layer functionalities should be separated. We shall remove the constraint regarding dependency on NON/CON. But as a note we shall keep the discussions that we had in the mailing list regarding why using this option with NON may be an obvious sane approach.
Hope, that should be fine.

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services
Mailto: [email-masked]<mailto:[email-masked]>
Website: http://www.tcs.com<http://www.tcs.com/>
____________________________________________
Experience certainty.        IT Services
                       Business Solutions
                       Consulting
____________________________________________

From:        Carsten Bormann <[email-masked]<mailto:[email-masked]>>
To:        "Dijk, Esko" <[email-masked]<mailto:[email-masked]>>, Abhijan Bhattacharyya <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date:        01/28/2015 01:44 PM
Subject:        Re: [core] CoAP No-Response: use with NON only?
________________________________

Grüße, Carsten

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.