Subject: [core] Multiple Resource Observation Attributes in draft-ietf-core-interfaces

From: "Kovatsch Matthias" <[email-masked]>
Date: Mon, 9 Feb 2015 01:41:23 +0000

Hi all

draft-ietf-core-interfaces-02 does not define how to handle the lt and gt attributes. There is currently a similar problem for OMA LWM2M. There are basically two problems:

Conjunction: Since they are defined in a query, I would expect AND. This only allows for notifications within an interval, though. Hence, it should be AND for (gt < lt) and OR for (lt < gt).

Triggering: There should also be text on when exactly notifications are triggered. In addition to values above/below the specified thresholds, there should also be one notification after crossing the threshold. Otherwise the application cannot decide if the value is still in the "alarm range" and has not changed more than step or if the value is back to normal.

Ciao
Matthias

PS: Thanks to Michael Koster, who provided this input! :)

---

From: Michael Koster <[email-masked]>
Date: Sun, 8 Feb 2015 19:32:31 -0800

Hi all,

Thanks Matthias for bringing this up.

I have been interpreting the ‘&’ character as simply a separator, not implying a logical ‘and’ operation. 

As for the triggering, I believe there should be a notification each time either lt or gt is crossed, either direction. I interpret lt and gt as defining 3 bands, the normal band, high alarm, and low alarm, with notification any time the measurement crosses from one band into another. This way the client application can track the signal state. Additionally there might be more frequent notifications while the measurement is in an alarm condition.

Cheers,

Michael

On Feb 8, 2015, at 5:41 PM, Kovatsch Matthias <[email-masked]> wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core