Subject: [core] #383 (resource-directory): HTTP response codes missing for function set definitions

From: "core issue tracker" <[email-masked]>
Date: Fri, 03 Jul 2015 07:55:27 -0000

#383: HTTP response codes missing for function set definitions

 The HTTP response codes should be formally defined for all function sets
 in addition to the CoAP response codes. Reason: the HTTP response codes
 are needed when implementing RD with HTTP interfaces. And the HTTP code is
 not always the "same as CoAP code with dot removed".

-- 
----------------------------------+----------------------------------------
 Reporter:                        |      Owner:  [email-masked]
  [email-masked]           |     Status:  new
     Type:  protocol defect       |  Milestone:
 Priority:  major                 |    Version:
Component:  resource-directory    |   Keywords:
 Severity:  -                     |
----------------------------------+----------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/383>
core <http://tools.ietf.org/core/>

---

From: "weigengyu" <[email-masked]>
Date: Fri, 3 Jul 2015 16:19:06 +0800

Hi,

I have a problem.
Whether DNS protocol or HTTP is required when doing RD operations in 
INTERNET.

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: core issue tracker
Sent: Friday, July 03, 2015 3:55 PM
To: [email-masked] ; [email-masked]
Cc: [email-masked]
Subject: [core] #383 (resource-directory): HTTP response codes missing for 
function set definitions

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "Dijk, Esko" <[email-masked]>
Date: Fri, 3 Jul 2015 08:30:42 +0000

Hello,

Both CoAP and HTTP interfaces can be used for operations over the Internet.
Whether DNS is required depends on your use case / situation, maybe good to describe the problem in some more detail if you think we can be of help.

I think DNS could be required for HTTP nodes, for CoAP nodes, for none, or for both. Depending on the situation/application.

Regards
Esko

-----Original Message-----
From: weigengyu [mailto:[email-masked]]
Sent: Friday, July 03, 2015 10:19
To: Dijk, Esko
Cc: [email-masked]
Subject: Re: [core] #383 (resource-directory): HTTP response codes missing for function set definitions

Hi,

I have a problem.
Whether DNS protocol or HTTP is required when doing RD operations in INTERNET.

Regards,

Gengyu WEI
-----原始邮件-----
From: core issue tracker
Sent: Friday, July 03, 2015 3:55 PM
To: [email-masked] ; [email-masked]
Cc: [email-masked]
Subject: [core] #383 (resource-directory): HTTP response codes missing for function set definitions

The HTTP response codes should be formally defined for all function sets in addition to the CoAP response codes. Reason: the HTTP response codes are needed when implementing RD with HTTP interfaces. And the HTTP code is not always the "same as CoAP code with dot removed".

--
----------------------------------+-------------------------------------
----------------------------------+---
Reporter:                        |      Owner:  [email-masked]
  [email-masked]           |     Status:  new
     Type:  protocol defect       |  Milestone:
Priority:  major                 |    Version:
Component:  resource-directory    |   Keywords:
Severity:  -                     |
----------------------------------+-------------------------------------
----------------------------------+---

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.