Subject: Re: [core] draft-ietf-core-resource-directory-03

From: "Dijk, Esko" <[email-masked]>
Date: Wed, 1 Jul 2015 10:15:45 +0000

Hello,

>> c) Could RD used with protocols other than CoAP, such as HTTP?

>Absolutely, see above.

There may be some minor fixes in the current RD draft needed to make it fully HTTP compliant. For example the response codes need to be specified in CoAP as well as HTTP codes to be complete.
If the authors want to take this on that would be perfect.  Otherwise I could suggest some text (already asked Peter if he could do this or delegate to me if needed).

Esko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Tuesday, June 30, 2015 16:45
To: Hannes Tschofenig
Cc: [email-masked] WG
Subject: Re: [core] draft-ietf-core-resource-directory-03

Hi Hannes,

> Remark: What was the reason the document title "CORE Resource Directory"?
> CORE is the name of the working group. Nobody outside the IETF knows
> what CORE is and the lifetime of working groups is limited.

The same reason the well-known link is called /.well-known/core and not something with CoAP in it:
This can be used with any of the three REST transfer protocols, not just with CoAP.

CoRE = COnstrained RESTful Environments

> a) Why are you using the DNS in the lighting example (from Section
> 12.1)? Does it gain you any advantage?

Using DNS is one deployment option that has often been requested.

> b) The use of DNS-SD also appears a bit artificial since RD and DNS-SD
> provide overlapping functionality.

Exactly, so the objective is to show how they can not only overlap, but actually interwork.

> c) Could RD used with protocols other than CoAP, such as HTTP?

Absolutely, see above.

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: "weigengyu" <[email-masked]>
Date: Fri, 3 Jul 2015 14:55:18 +0800

Hi，

Related to RD and DNS-SD,

> 9. DNS-SD Mapping
> CoRE Resource Discovery is intended to support fine-grained discovery
> of hosted resources, their attributes, and possibly other resource
> relations [RFC6690]. In contrast, service discovery generally refers
> to a coarse-grained resolution of an endpoint’s IP address, port number, 
> and protocol.

> Resource and service discovery are complementary in the case of large
> networks, where the latter can facilitate scaling. This document
> defines a mapping between CoRE Link Format attributes and DNS-Based
> Service Discovery [RFC6763] fields that permits discovery of CoAP
> services by either means.

The problem is raised because RD operations are associcated with DNS and 
DNS-SD operations.
When doing Domain Name or DNS-SD resolution in INTERNET, it is  the DNS 
prototocol instead of HTTP to be used.
So, could RD server be accessed by DNS protocol, or by HTTP in INTERNET?

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: Dijk, Esko
Sent: Wednesday, July 01, 2015 6:15 PM
To: Carsten Bormann ; Hannes Tschofenig
Cc: [email-masked] WG
Subject: Re: [core] draft-ietf-core-resource-directory-03

Hello,

>Absolutely, see above.

There may be some minor fixes in the current RD draft needed to make it 
fully HTTP compliant. For example the response codes need to be specified in 
CoAP as well as HTTP codes to be complete.
If the authors want to take this on that would be perfect.  Otherwise I 
could suggest some text (already asked Peter if he could do this or delegate 
to me if needed).

Esko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Tuesday, June 30, 2015 16:45
To: Hannes Tschofenig
Cc: [email-masked] WG
Subject: Re: [core] draft-ietf-core-resource-directory-03

Hi Hannes,

> what CORE is and the lifetime of working groups is limited.

The same reason the well-known link is called /.well-known/core and not 
something with CoAP in it:
This can be used with any of the three REST transfer protocols, not just 
with CoAP.

> provide overlapping functionality.

Exactly, so the objective is to show how they can not only overlap, but 
actually interwork.

Absolutely, see above.

Grüße, Carsten

________________________________
The information contained in this message may be confidential and legally 
protected under applicable law. The message is intended solely for the 
addressee(s). If you are not the intended recipient, you are hereby notified 
that any use, forwarding, dissemination, or reproduction of this message is 
strictly prohibited and may be unlawful. If you are not the intended 
recipient, please contact the sender by return e-mail and destroy all copies 
of the original message.
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core