Subject: [core] Block-wise with non-confimable message ?

From: William Bertier <[email-masked]>
Date: Thu, 23 Jul 2015 14:49:08 +0200 (CEST)

Hello, 
A transmission Block-wise, must use confirmable messages? 
You confirm me, for Block1 with response code 2.31 (continue) is obligatory. 
But it is also not obligatory for Block2 ? 

I did not find anything in draft-ietf-core-block-17 about it. 

Thank You 
William Bertier

---

From: William Bertier <[email-masked]>
Date: Fri, 24 Jul 2015 14:37:49 +0200 (CEST)

Hello, 

Can anyone answer my question? 
We are free to use confirmable or non-confimable message for blockwise transfer ? 

Thanks 
William Bertier 

----- Mail original -----

> De: "William Bertier" <[email-masked]>
> À: "core" <[email-masked]>
> Envoyé: Jeudi 23 Juillet 2015 14:49:08
> Objet: [core] Block-wise with non-confimable message ?

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2015 05:53:10 +0200

Hi William,

sorry for not answering earlier -- during the IETF meeting, the amount
of mail can be overwhelming.

Indeed, the -block draft does not have a normative statement whether you
should be using confirmable or non-confirmable messages for your
requests.  Either will work.  Still, non-confirmable is probably not
such a great idea, since the chances for messages losses add up (really:
the delivery probabilities multiply) and you are more likely to end up
with an incomplete representation than you are losing a message during a
single request-response pair.

Grüße, Carsten

William Bertier wrote:
> ------------------------------------------------------------------------
> 
>     *De: *"William Bertier" <[email-masked]>
>     *À: *"core" <[email-masked]>
>     *Envoyé: *Jeudi 23 Juillet 2015 14:49:08
>     *Objet: *[core] Block-wise with non-confimable message ?
> 
>     Hello,

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sun, 26 Jul 2015 12:54:32 +0000

Carsten,

Just an FYI - The way the block draft is written now; many people will indeed interpret that the only supported unreliable message is CON; I noted this in the list of items we will need to clarify.

BR,
Tim

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Saturday, July 25, 2015 5:53 AM
To: William Bertier
Cc: core
Subject: Re: [core] Block-wise with non-confimable message ?

Hi William,

sorry for not answering earlier -- during the IETF meeting, the amount of mail can be overwhelming.

Indeed, the -block draft does not have a normative statement whether you should be using confirmable or non-confirmable messages for your requests.  Either will work.  Still, non-confirmable is probably not such a great idea, since the chances for messages losses add up (really:
the delivery probabilities multiply) and you are more likely to end up with an incomplete representation than you are losing a message during a single request-response pair.

Grüße, Carsten

---

From: William Bertier <[email-masked]>
Date: Mon, 27 Jul 2015 08:51:55 +0200 (CEST)

Ok. I knew it was strongly recommended to use confirmable messages.
But I used the server vs0.inf.ethz.ch with block1 transmission with non-confirmable messages,
The server sent me no reply so I wonder if it was obligatory.

Thank you for your response
William Bertier

----- Mail original -----
> De: "Carsten Bormann" <[email-masked]>
> À: "William Bertier" <[email-masked]>
> Cc: "core" <[email-masked]>
> Envoyé: Samedi 25 Juillet 2015 05:53:10
> Objet: Re: [core] Block-wise with non-confimable message ?
> 
> Hi William,
>