Subject: [core] Search catch for interoperability tests

From: William Bertier <[email-masked]>
Date: Fri, 10 Jul 2015 16:14:34 +0200 (CEST)

Hello, 

I am in intership at INRIA research laboratory of Rennes (France). 

I'm in a team that developed in 2013 a software that carries out interoperability testing. 
With a wireshark catch (.pcap, .dump), the software checks the compliance of exchanges. 

My goal is to update the software with the RFC7252 , draft-ietf-core-observe-16 and draft-ietf-core-block-17 . 
The description of the software : 
http://www.irisa.fr/tipi/wiki/doku.php/passive_validation_tool_for_coap 
To use the software, it is online: 
http://senslab2.irisa.fr/coap/ 

I am currently developing new test but I can unfortunately not tested due to lack of wireshark catch. 
I am contacting you because I would like catch (.pcap, .dump), mainly catch that uses the functions observe and block. 

This would allow you to test your implementation and me to test my new tests. 

If you provide me catch I assure you that they will be used for my tests and will be deleted afterwards. 
You can also provide me implementations, I am currently trying https://github.com/openwsn-berkeley/coap 

Thank you 
William Bertier

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 10 Jul 2015 18:59:26 +0200

William,

If you want to see block transfer "live", point your Firefox CoPPER
extension to http://vs0.inf.ethz.ch/.

You might be interested in http://coap.me/ which provides similar
functionality to what you describe

The OpenWSN CoAP library does not implement observe (see
https://openwsn.atlassian.net/wiki/display/OW/CoAP+Python+Library for a
list of what it does/does not implement). You're more than welcome to add
it. You might also enjoy the test infrastrcture

Thomas

Thomas

On Fri, Jul 10, 2015 at 4:14 PM, William Bertier <[email-masked]>
wrote:

> My goal is to update the software with the RFC7252
> <http://tools.ietf.org/html/rfc7252>, draft-ietf-core-observe-16
> <http://tools.ietf.org/html/draft-ietf-core-observe-16> and
> draft-ietf-core-block-17
> <http://tools.ietf.org/html/draft-ietf-core-block-17>.
> The description of the software:
> I am contacting you because I would like catch (.pcap, .dump), mainly
> catch that uses the functions observe and block.
>
> *This would allow you to test your implementation and me to test my new
> tests.*
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>
>

---

From: William Bertier <[email-masked]>
Date: Wed, 15 Jul 2015 09:24:00 +0200 (CEST)

Thomas, 

Thank you for your reply 

I was also advised to use californium , I'll try it. 

ETSI testing ( coap.me ), it was done with our team in 2012. It therefore has the same tests. 

I have a little less than a month internship and I still have much to do. I do not know if I'll have time to implement Observe. This is why the wireshark catch, would be perfect for me. 

William 

----- Mail original -----

> De: "Thomas Watteyne" <[email-masked]>
> À: "William Bertier" <[email-masked]>
> Cc: "core" <[email-masked]>
> Envoyé: Vendredi 10 Juillet 2015 18:59:26
> Objet: Re: [core] Search catch for interoperability tests

> If you want to see block transfer "live", point your Firefox CoPPER extension
> to http://vs0.inf.ethz.ch/ .

> https://openwsn.atlassian.net/wiki/display/OW/CoAP+Python+Library for a list
> of what it does/does not implement). You're more than welcome to add it. You
> might also enjoy the test infrastrcture

> On Fri, Jul 10, 2015 at 4:14 PM, William Bertier < [email-masked] >
> wrote:

> > With a wireshark catch (.pcap, .dump), the software checks the compliance
> > of
> > exchanges.
> 

> > My goal is to update the software with the RFC7252 ,
> > draft-ietf-core-observe-16 and draft-ietf-core-block-17 .
> 

> > I am currently developing new test but I can unfortunately not tested due
> > to
> > lack of wireshark catch.
> 
> > I am contacting you because I would like catch (.pcap, .dump), mainly catch
> > that uses the functions observe and block.
> 

> > If you provide me catch I assure you that they will be used for my tests
> > and
> > will be deleted afterwards.
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Jul 2015 09:29:12 +0200

> ETSI testing (coap.me), it was done with our team in 2012. It therefore
> has the same tests.

Actually, the test specs have changed, and also there were some spec
changes since 2012 that will impact trace captures.  The most recent
ETSI CoAP plugtest was in London, March 2014.  So I would recommend
testing again against coap.me (please ask me if there is any problem
with that).  By the way, coap.me can also be used to decode (and thus
check) packet captures in pcap format.

Grüße, Carsten

---

From: William Bertier <[email-masked]>
Date: Wed, 15 Jul 2015 09:46:01 +0200 (CEST)

Yes indeed, the objective of my internship is to update the tests already present and add new tests

----- Mail original -----
> De: "Carsten Bormann" <[email-masked]>
> Cc: "Thomas Watteyne" <[email-masked]>, "core" <[email-masked]>
> Envoyé: Mercredi 15 Juillet 2015 09:29:12

---

From: William Bertier <[email-masked]>
Date: Tue, 21 Jul 2015 12:08:42 +0200 (CEST)

Hello 

Thank you Thomas, as you have advised me, I use copper and vs0.inf.ethz.ch server, I run my capture wireshark than done. 

I had problems with the internal network ports filter and admin rights with wireshark but now it's perfect 

Soon you can use http://senslab2.irisa.fr/coap/ with new tests ( yes, this is equivalent to coap.me) 

Thank you 
William Bertier

---

From: William Bertier <[email-masked]>
Date: Tue, 28 Jul 2015 09:47:24 +0200 (CEST)

Hello,

Is it possible to have access to the specification of tests of London 2014 ?
My document dates back to 2012 (ETSI CTI Plugtests Guide Draft V0.0.13 (2012-11)) 

William Bertier

----- Mail original -----
> De: "William Bertier" <[email-masked]>
> À: "Carsten Bormann" <[email-masked]>
> Envoyé: Mercredi 15 Juillet 2015 09:46:01

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Jul 2015 10:49:37 +0200

> Is it possible to have access to the specification of tests of London 2014 ?

Certainly!
They are up at

https://github.com/cabo/td-coap4/

Grüße, Carsten