Subject: [core] core-interfaces section 5.2: "toggle" action prescribed for Batch?

From: "Dijk, Esko" <[email-masked]>
Date: Thu, 27 Aug 2015 13:31:40 +0000

Dear all, authors of core-interfaces,

I was surprised reading in section 5.2 that a POST on a Batch resource would always be interpreted as a "toggle" action on all its sub-resources. Is this intended?
Rather I would vote for a POST being translated to the same POST executed on all sub-resources that support it - which would for actuator resources translate into a toggle action. But for other resource types (which may be defined in the future, or may be standard-specific, etc.) the POST could take on a different meaning.

I can create a ticket for this.

Regards
Esko

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Michael Koster <[email-masked]>
Date: Fri, 28 Aug 2015 15:01:55 -0700

Yes, agreed. POST should be defined as having the expected action on all resources, and should not be defined as toggle in all cases. Thanks for making the ticket.

Best regards,

Michael

On Aug 27, 2015, at 6:31 AM, Dijk, Esko <[email-masked]> wrote:

> I was surprised reading in section 5.2 that a POST on a Batch resource would always be interpreted as a “toggle” action on all its sub-resources. Is this intended?
> Rather I would vote for a POST being translated to the same POST executed on all sub-resources that support it – which would for actuator resources translate into a toggle action. But for other resource types (which may be defined in the future, or may be standard-specific, etc.) the POST could take on a different meaning.
>