Subject: Re: [core] Kathleen Moriarty's Discuss on draft-ietf-core-etch-03: (with DISCUSS)

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Nov 2016 10:23:24 +0900

Hi Kathleen,

as you can see from https://www.ietf.org/rfcdiff?url2=draft-ietf-core-etch-04 we took this as an opportunity to clean up the security considerations section, and I think it is indeed better now.
I hope the added detail answers your call for more specific information and that you can clear the DISCUSS.

One point that we maybe can take home from this discussion is that the word PATCH means different things to different people — this specific draft has no specific relationship to software updates, and it is actually less likely that a PATCH method with be used to deliver a software update “patch” than PUT (as in the LWM2M firmware update mechanism) or POST.  The name PATCH is therefore probably unfortunate, but we want to stick to it as it is also used for the equivalent method on the HTTP side of REST.

Grüße, Carsten

---

From: Kathleen Moriarty <[email-masked]>
Date: Sun, 13 Nov 2016 21:12:12 -0500

Hi Carsten,

Thanks the text is better and I'll clear.  It doesn't cover the case of
data being altered on the patch where it is stored, but covers other
considerations now.

Thanks,
Kathleen

On Sun, Nov 13, 2016 at 8:23 PM, Carsten Bormann <[email-masked]> wrote:

> Hi Kathleen,
>
> as you can see from https://www.ietf.org/rfcdiff?
> url2=draft-ietf-core-etch-04 we took this as an opportunity to clean up
> the security considerations section, and I think it is indeed better now.
> One point that we maybe can take home from this discussion is that the
> word PATCH means different things to different people — this specific draft
> has no specific relationship to software updates, and it is actually less
> likely that a PATCH method with be used to deliver a software update
> “patch” than PUT (as in the LWM2M firmware update mechanism) or POST.  The
> name PATCH is therefore probably unfortunate, but we want to stick to it as
> it is also used for the equivalent method on the HTTP side of REST.
>
> Grüße, Carsten
>
>

-- 

Best regards,
Kathleen