Subject: [core] SenML FETCH/PATCH (draft-ietf-core-senml-etch) update

From: Ari Keränen <[email-masked]>
Date: Wed, 6 Feb 2019 13:20:52 +0000

Hi all,

I'm planning to update the SenML FETCH/PATCH draft to address the IETF 103 conclusion of using separate media types. Here's the PR:
https://github.com/core-wg/senml-etch/pull/1/files

This version also keeps the "delete with PATCH null value" method as discussed in the meeting. We had another look at this and didn't see any reason why this would not work well enough.

Comments welcome!

Based on the discussions at the IETF 103 there did not seem to be any other major issues so this could move forward towards publication.

One minor issues for media type registration: Do we need fragment IDs? I don't see strong need, but we could simply re-use the SenML fragment ID handling also here.

Cheers,
Ari

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Feb 2019 16:39:28 +0100

> One minor issues for media type registration: Do we need fragment IDs? I don't see strong need, but we could simply re-use the SenML fragment ID handling also here.

Fragment IDs for patches boggles my mind.

Any use for fragment IDs I can imagine would be about addressing results of the patch process, not about addressing parts of the patch.  But maybe this is proof by lack of imagination.

Grüße, Carsten

---

From: Ari Keränen <[email-masked]>
Date: Tue, 12 Feb 2019 21:22:48 +0000

> Any use for fragment IDs I can imagine would be about addressing results of the patch process, not about addressing parts of the patch.  But maybe this is proof by lack of imagination.

I don't have any proper use case for this either, so perhaps safest bet 
is to have that as "N/A". I updated the PR, merged it, and will submit a 
new draft version now.

Cheers,
Ari