Subject: [core] Mirja Kühlewind's No Objection on draft-ietf-core-multipart-ct-03: (with COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Mon, 29 Apr 2019 06:44:53 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-core-multipart-ct-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-multipart-ct/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

One minor question: I don't fully understand why the new content format is
called "application/multipart-core". Does "core" stand for the core working
group? Shouldn't it rather be "application/multipart-coap"? Also why
"multipart" and not e.g. "multicontent"? I guess it doesn't matter that much
but was mainly wondering where the naming came from...

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 29 Apr 2019 16:21:38 +0200

Hi Mirja,

> but was mainly wondering where the naming came from…

Originally, I had proposed to call it “multipart/core” and then Alexey pointed out that a multipart media type has to fulfill certain formal requirements that we didn’t need.  So it became “application/multipart-core”.

Now why core?  We have been using CoRE, “Constrained RESTful Environments”(*) as an abbreviation for using the representational state transfer (REST) architectural style in the constrained environments that multipart-core is designed for.  An early example is the title of RFC 6690: CoRE Link Format.  The media type will not only be used with CoAP, but in other contexts that employ media types as well.  For shortcuts for the embedded media types, it does employ the Content-Format registry that is part of the “CoRE parameters” IANA registry (CoRE, again) for CoAP and other applications.

((*) That probably should have been REST-style, or REST-based, as RESTful is one of these “essentially contested concepts” [1].)

Grüße, Carsten

[1]: https://en.wikipedia.org/wiki/Essentially_contested_concept

---

From: Thomas Fossati <[email-masked]>
Date: Mon, 29 Apr 2019 14:22:12 +0000

Hi Mirja, thanks for the comments!

On 29/04/2019, 14:44, "Mirja Kühlewind via Datatracker" <[email-masked]> wrote:
> I don't fully understand why the new content format is called "application/multipart-core". Does "core" stand for the core working group?

Yes.

> Shouldn't it rather be "application/multipart-coap"?

s/core/coap/ would be slightly more precise since the things we are mixing here are CoAP Content-Formats, so yes you're probably right.  At the same time this is layer 6 object which is not limited to the CoAP transport, so maybe using a name identifying a wider scope is not a terrible idea.

> Also why "multipart" and not e.g. "multicontent"?

Maybe multiformat? :-).  Jokes aside, "multipart" is a nod to the honourable MIME multipart content type, which provided the inspiration for this.

I guess if we could go back in time it'd be worth spending a few more cycles trying to pick a better name, but at this stage it seems to me that this is the handle that folks in CoRE and ANIMA have got used to and changing it would create a bit of unnecessary confusion?

Cheers, thanks
t

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 29 Apr 2019 16:51:44 +0200

Hi Thomas,

See below.

> On 29. Apr 2019, at 16:22, Thomas Fossati <[email-masked]> wrote:
> 

Yes, if that’s already in use and implemented, it probably doesn’t make sense to change it. I was just wondering…

Mirja

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 29 Apr 2019 16:52:52 +0200

Hi Carsten,

Thanks for the explanation. I was just wondering. So I guess the naming is fine.

Mirja

> On 29. Apr 2019, at 16:21, Carsten Bormann <[email-masked]> wrote:
> 
> Hi Mirja,
>