Subject: [core] Adam Roach's No Objection on draft-ietf-core-multipart-ct-03: (with COMMENT)

From: Adam Roach via Datatracker <[email-masked]>
Date: Mon, 29 Apr 2019 23:31:18 -0700

Adam Roach has entered the following ballot position for
draft-ietf-core-multipart-ct-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-multipart-ct/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for the work everyone put in on this document.

The "Usage Examples" section seems a bit odd, since it only describes the use of
this new content type for sending a response prior to the response body becoming
available. The introduction does not give the impression that this is the
primary use case -- it implies that this new format is primarily intended to
be used in a similar fashion as the traditional multipart/* media types.
Perhaps there should be some additional examples in section 3 that outline these
more common cases?

Alternately, if I have misunderstood the primary use case for this mechanism,
then I would humbly offer that the introduction needs substantial revision.

---

From: Thomas Fossati <[email-masked]>
Date: Tue, 30 Apr 2019 13:57:23 +0000

Hi Adam, thanks for the comments.

On 30/04/2019, 07:31, "Adam Roach via Datatracker" <[email-masked]> wrote:
    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------

Yes, it is correct to say that this is not the primary use case, and yes, section 3.1 looks a bit lonesome...

I think we ended up like that as we felt like this was the only use case that needed some kind of "visual" -- all the others being pretty straightforward to grasp without any particular aid.

How about we add a bit of text at the top of sec 3 that articulates the above rationale?

Cheers!

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.