Subject: Re: [core] Alissa Cooper's No Objection on draft-ietf-core-multipart-ct-03: (with COMMENT)

From: Carsten Bormann <[email-masked]>
Date: Thu, 2 May 2019 07:05:11 +0200

Hi Alissa,

thank you for your comments.
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Please respond to the Gen-ART review.

It seems the response e-mail describing how we acted on it got stuck in processing.  Will send later today.

> = Section 2 =
> 
> "The second, fourth, sixth, etc. element is a
>   byte string containing a representation, or the value "null" if an
>   optional part is indicated as not given.  The first, third, fifth,
>   etc. element is an unsigned integer specifying the content format ID
>   of the representation following it."
> 
> I think it would be more precise to refer to the "even-numbered elements" and
> the "odd-numbered elements" rather than enumerating the elements and saying
> “etc."

The problem with “even-numbered” and “odd-numbered” is that it isn’t explicit about counting from zero (which is how I would read it, so first/third/fifth would be “even-numbered”!) or counting from one (which also would be natural for some people).  Using the actual ordinals removes that ambiguity, as ordinals count from one.  With the rest of the text, the example, and the CDDL, I believe this is a quite unambiguous way to introduce the sequence.

Grüße, Carsten

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 2 May 2019 00:08:52 -0500

> The problem with “even-numbered” and “odd-numbered” is that it isn’t explicit about counting from zero (which is how I would read it, so first/third/fifth would be “even-numbered”!) or counting fro…

FWIW, the current text managed to confuse me, as I kept looking for what
the zeroth element was and why it was different from everything else.
So maybe we can't make everyone happy.

-Ben

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 2 May 2019 07:23:22 +0200

> On May 2, 2019, at 07:08, Benjamin Kaduk <[email-masked]> wrote:
> 
> So maybe we can’t make everyone happy.

Interesting.  Yes, some people do use ordinals starting from zero.

So how about:

Counting from zero, the odd-numbered elements are a byte string containing
a representation, or the value `null` if an optional part is indicated
as not given.
The (even-numbered) element preceding each of these is an unsigned integer
specifying the content format ID of the representation following it.

Sigh.  The CDDL is so much clearer :-)

Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Thu, 2 May 2019 09:31:25 -0400

> >> The problem with “even-numbered” and “odd-numbered” is that it isn’t
> >> explicit about counting from zero (which is how I would read it, so
> >> first/third/fifth would be “even-numbered”!) or counting from one
> >> (which also would be natural for some people). Using the actual
> >> ordinals removes that ambiguity, as ordinals count from one.  With
> >> the rest of the text, the example, and the CDDL, I believe this is a
> >> quite unambiguous way to introduce the sequence.
> >

OOOOH, no, that's *horrible*.  It will *never* work to call the 2nd
and 4th elements "odd-numbered".  You can't say that "counting from
zero, zero is element one."

You can have it both ways like this:

NEW
   Each even-numbered element (second, fourth, sixth, etc.) is a
   byte string containing a representation, or the value "null" if an
   optional part is indicated as not given.  Each odd-numbered
   element (first, third, fifth, etc.) is an unsigned integer specifying
   the content format ID of the representation following it.
END

Replacing "the" with "each" also makes it clearer.

Barry