Subject: Re: [core] 🔔 WG Last Call of draft-ietf-core-senml-etch-03.txt

From: Carsten Bormann <[email-masked]>
Date: Wed, 12 Jun 2019 15:10:20 +0200

It seems we have received no (zero, nada) responses to this.
We do need a few voices from people who have read it.  
Please speak up if you did!

It’s a short document, so you can read it right now as well:
https://tools.ietf.org/html/draft-ietf-core-senml-etch-03

Grüße, Carsten

> On Mar 11, 2019, at 23:40, Carsten Bormann <[email-masked]> wrote:
> 
> On Mar 6, 2019, at 00:40, Ari Keränen <[email-masked]> wrote:
>> 
>> If there are no further comments on these, I could merge the PR and 
>> submit a new version.
> 
> … which the authors did (see below).
> 
> This starts a working group last call for draft-ietf-core-senml-etch-03.txt,
> ending on
> 
> 	24:00 CET on Monday, March 25, 2019.
> 
> Please start a new email thread for each major issue that will need
> discussion and make sure the subject line includes the draft name and
> some sort of name for the issue.  (Minor issues such as typos can also
> be sent to the authors.)
> 
> If you read the draft and think it looks fine, please send a one line 
> email to the list or to the chairs letting us know that so we can get 
> a feel of how broad the review has been.
> 
> (To reviewers and authors:)  If you are aware of any patent claims that
> might apply to systems that implement these drafts, please review BCP 78
> and BCP 79 and make any appropriate IPR declaration before the last-call
> ends. If you are not sure whether you need to make a declaration or not, 
> please talk to the chairs and we will help.
> 
> Grüße, Carsten
> 
>> 
>> Cheers,
>> Ari
>> 
>> On 20/02/2019 17.00, Carsten Bormann wrote:
>>> In preparation for the impending working-group last call, I have
>>> reviewed draft-ietf-core-senml-etch-02.txt.  Substantive comments are
>>> below; a set of small editorial comments is going to the authors in
>>> parallel.
>>> 
>>> # Minor
>>> 
>>> 1. The text of the draft does not contain an argument that the
>>>   application of Patch Packs is idempotent.  It probably should.
>>> 
>>> 2. The text sometimes says "iPATCH" where it probably should be saying
>>>   "PATCH and iPATCH".  This should be checked throughout.
>>> 
>>> 3. The term "resource" is sometimes used in lieu of "subset of SenML
>>>   records that, when resolved, match a given name".
>>> 
>>> Grüße, Carsten
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> core mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/core
>>> 
>> 
>> 
>> 
> 
> 
>

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 12 Jun 2019 15:39:11 +0200

Hello Carsten,

> Please speak up if you did!

I've read the latest version now. My concerns of -01 have been either
resolved in full or discussed to the point where I'm happy to accept the
decision taken on them.

+1 on going forward.

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 24 Jun 2019 13:21:31 +0200

I have performed a quick review of draft-ietf-core-senml-etch-03:

3.2. "For example, the following document could be given as (i)PATCH
payload to change/set values of two SenML Records for the example in
Section 1:" -- It would be nice if the example from section 1 was
duplicated here and the removal of a record was shown.

5.1 "All IDs are assigned from the "IETF Review or IESG Approval"
range." -- Remove this sentence.

5.1 "Table 1: CoAP Content-Format IDs" -- This table is missing the
"Content-Coding" (f.k.a. "Encoding") column.

General questions:

* It seems the new data formats are supersets of the existing data
formats. Also, it seems the same data format is used for fetching and
patching data. Is this what we, as CoRE WG, recommend (1 media type
for data, 1 media type for fetching and patching)? CoRAL is doing it
differently at the moment [1].

Klaus

[1] https://tools.ietf.org/html/draft-hartke-t2trg-coral-08#section-6.7

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 26 Jun 2019 15:29:59 +0200

On Mon, Jun 24, 2019 at 01:21:31PM +0200, Klaus Hartke wrote:
> differently at the moment.

I'd view this not as a general recommendation but as a way to go if for
some reason the "descriptive" format can not be extended within its own
constraints. In CoRAL, I don't see a need for separate media types.
Applications mint their own dictionaries anyway.

An application can make restrictions like in [1] for some operations
(eg. "an Information Provider must only use dictionary I on resource
representations returned from GET, and may accept dictionary F for
FETCH-like operations if supported").

Best regards
Christian

[1]: https://tools.ietf.org/html/draft-hartke-t2trg-coral-08#section-6.1.3

---

From: Ari Keränen <[email-masked]>
Date: Wed, 26 Jun 2019 14:43:27 +0000

Thanks Klaus! See inline.

> On 24 Jun 2019, at 14.22, Klaus Hartke <[email-masked]> wrote:
> 

Makes sense, will add example to the next revision.

> range." -- Remove this sentence.

SenML RFC (and others) have used such sentence to indicate the desired range, but I’m fine leaving it out too.

> "Content-Coding" (f.k.a. "Encoding") column.

Good catch; will add. I suppose it will be simply ”-” for both.

> [1] https://tools.ietf.org/html/draft-hartke-t2trg-coral-08#section-6.7

Christian made some good observations on this already. I would not view this as a general guideline either. But let’s continue on that thread (and in the call today).

Cheers,
Ari

---

From: Ari Keränen <[email-masked]>
Date: Wed, 26 Jun 2019 18:47:00 +0000

Hi,

Here’s now a PR that addresses all these comments:
https://github.com/core-wg/senml-etch/pull/5/files

Michael R also pointed out a bug in the references, that revealed also a bug in the examples. This PR fixes both issues: https://github.com/core-wg/senml-etch/pull/6/files

Cheers,
Ari

> On 26 Jun 2019, at 17.44, Ari Keränen <[email-masked]> wrote:
>