Subject: [core] exp parameter in rd-dns-sd

From: Peter van der Stok <[email-masked]>
Date: Wed, 24 Jul 2019 08:39:31 -0400

During the meeting it was remarked that the presence of the exp
parameter implies the existence of the st parameter
and vice-versa.
The exp parameter is meant for filtering on the presence of exp, as
shown in the displayed examples.
However, I realize that filtering on st=* is as effective.
The document will change accordingly.

Peter 
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 24 Jul 2019 08:58:07 -0400

> parameter implies the existence of the st parameter

There was the idea around years ago that exp would also be considered by
"other export mechanisms" that take data from the RD. If other export
mechanisms ever show up, they can define their own st= equivalent, or
describe a more generic "may export mechanism". (So far none have shown
up).

I agree exp can just be removed from RD-DNS-SD.

BR
c

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom