Subject: [core] MULTIPART-CT: Nested multiparts

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Jul 2019 16:20:05 +0000

Hi,

Can a multipart contain another multipart?

Whatever the answer is, I think it would be useful to have some text about it.

Regards,

Christer

---

From: Jim Schaad <[email-masked]>
Date: Tue, 23 Jul 2019 14:07:25 -0400

The answer is yes, and there is a note in the security considerations that this needs to be done carefully.

jim

From: core <[email-masked]> On Behalf Of Christer Holmberg
Sent: Tuesday, July 23, 2019 12:20 PM
To: [email-masked]
Subject: [core] MULTIPART-CT: Nested multiparts

Hi,

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Jul 2019 18:22:55 +0000

Hi,

>The answer is yes, and there is a note in the security considerations that this needs to be done carefully.

Thanks, I had missed that part.

However, I think there needs to be procedural text on it too. An example would be good too.

Regards,

Christer

From: core <[email-masked]<mailto:[email-masked]>> On Behalf Of Christer Holmberg
Sent: Tuesday, July 23, 2019 12:20 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [core] MULTIPART-CT: Nested multiparts

Hi,

Regards,

Christer

---

From: Peter van der Stok <[email-masked]>
Date: Tue, 23 Jul 2019 14:31:26 -0400

actually, in the anima-join-proxy draft embedded multipart-ct will
happen

Peter
Christer Holmberg schreef op 2019-07-23 14:22:

> FROM: core <[email-masked]> ON BEHALF OF Christer Holmberg
> SENT: Tuesday, July 23, 2019 12:20 PM
> TO: [email-masked]
> SUBJECT: [core] MULTIPART-CT: Nested multiparts 
> 
> Hi, 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Jul 2019 18:35:53 +0000

Hi,

>actually, in the anima-join-proxy draft embedded multipart-ct will happen

Cool 😊

Then there is an even bigger reason to properly describe how to do it in multipart-ct 😊

Regards,

Christer

Regards,

Christer

Hi,

Regards,

Christer

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

---

From: Michael Richardson <[email-masked]>
Date: Tue, 23 Jul 2019 19:32:09 -0400

> actually, in the anima-join-proxy draft embedded multipart-ct will happen

You mentioned that, and maybe you are thinking about the returned voucher.

But the multipart that I have in the constrained voucher document is
HTTPS/MIME multipart from MASA->JRC.  It's not CoAP there, it's HTTPS.   It
contains a PKIX certificate and a constrained voucher.

It's multipart rather than putting the validation chain in the unprotected
COSE bucket, so that the Registar can use the certificate, but otherwise
strip that off so that the large certificate chain can be passed back to the
pledge.

We have discussed the question of whether we need to return the certificate
chain to the pledge (which should have the entire certificate chain built in
to firmware) or not.  I supposed we could use multipart again there... but
let's discuss. 

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-