Subject: [core] 🔔 CoRE Working Group Adoption call for draft-hartke-t2trg-coral-09 and draft-hartke-t2trg-ciri-03

From: Carsten Bormann <[email-masked]>
Date: Tue, 16 Jul 2019 21:11:36 +0200

In Prague, we said we were going to adopt the two base CoRAL specifications (which are currently marked as T2TRG drafts) as CoRE working group items.  We didn’t do the validation on the mailing list yet, which this working group adoption call is about.

Among other things, the adoption of these drafts is intended to fill the hole left when we put draft-ietf-core-links-json on hold.  So if you want to comment on the WG adoption, please also keep this aspect in mind, even if it could also be handled in a more orthogonal way (which you could recommend).

This starts a one-week working group adoption call.
(Normally we wouldn’t run a WG call that partially overlaps an IETF, but this time there is plenty of opportunity to think about CoRAL during the IETF, including the hackathon and the side meeting on core applications before the first of our two WG meetings.)

This is a formal call for adoption of draft-hartke-t2trg-coral-09 and draft-hartke-t2trg-ciri-03 as WG documents of the CoRE WG.
If you have read the drafts and support adopting them, please say so.
If you see a problem with adopting them as a WG document, please tell us.
For both, remember that WG adoption does not mean that we already have consensus on all the details(*), just that this is the right working document to address the issue (and that we should address the issue in the first place); you are encouraged to mention any issues that you already know.
Please respond to [email-masked], or exceptionally to [email-masked] (for off-list comments).

This formal WG adoption call runs until the end of July 23rd so we can pick up the results at the CoRE meeting on July 25th.

Grüße, Carsten

(*) the most bikeshed issue (also relevant for the new draft name) appears to be whether CIRIs, which aren’t really IRIs that much, should rather be called CoRIs or maybe CRIs or even something completely different.  Please comment on this most important branding issue under https://github.com/ektrah/coral/issues/18 if you care.

---

From: Jim Schaad <[email-masked]>
Date: Tue, 16 Jul 2019 13:31:42 -0700

Big +1 - These documents make a lot of sense.

-----Original Message-----
From: core <[email-masked]> On Behalf Of Carsten Bormann
Sent: Tuesday, July 16, 2019 12:12 PM
To: core <[email-masked]>
Subject: [core] 🔔 CoRE Working Group Adoption call for draft-hartke-t2trg-coral-09 and draft-hartke-t2trg-ciri-03

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Christian Amsüss <[email-masked]>
Date: Wed, 17 Jul 2019 08:45:34 +0200

On Tue, Jul 16, 2019 at 09:11:36PM +0200, Carsten Bormann wrote:
> This is a formal call for adoption of draft-hartke-t2trg-coral-09 and
> draft-hartke-t2trg-ciri-03 as WG documents of the CoRE WG.

I've read and implemented earlier versions of both drafts, and fully
support WG adoption.

Christian

-- 
A beginning is the time for taking the most delicate care that the
balances are correct.
  -- Princess Irulan, Manual of Muad'Dib

---

From: Ari Keränen <[email-masked]>
Date: Wed, 17 Jul 2019 08:00:55 +0000

I have read both drafts in detail and fully support adopting them. 

Cheers,
Ari

> On 16 Jul 2019, at 22.12, Carsten Bormann <[email-masked]> wrote:
> 
> (*) the most bikeshed issue (also relevant for the new draft name) appears to be whether CIRIs, which aren’t really IRIs that much, should rather be called CoRIs or maybe CRIs or even something completely different.  Please comment on this most important branding issue under https://protect2.fireeye.com/url?k=580aff0b-04def502-580abf90-86740465fc08-e4c236255ccab7e3&q=1&u=https%3A%2F%2Fgithub.com%2Fektrah%2Fcoral%2Fissues%2F18 if you care.
>

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 17 Jul 2019 15:33:04 +0200

Dear all,

I have reviewed the two documents and support their adoption.

Regards,
Alexander

On Wed, Jul 17, 2019 at 10:01 AM Ari Keränen <[email-masked]>
wrote:

> > In Prague, we said we were going to adopt the two base CoRAL
> specifications (which are currently marked as T2TRG drafts) as CoRE working
> group items.  We didn’t do the validation on the mailing list yet, which
> this working group adoption call is about.
> >
> > Among other things, the adoption of these drafts is intended to fill the
> hole left when we put draft-ietf-core-links-json on hold.  So if you want
> to comment on the WG adoption, please also keep this aspect in mind, even
> if it could also be handled in a more orthogonal way (which you could
> recommend).
> >
> > (Normally we wouldn’t run a WG call that partially overlaps an IETF, but
> this time there is plenty of opportunity to think about CoRAL during the
> IETF, including the hackathon and the side meeting on core applications
> before the first of our two WG meetings.)
> >
> > For both, remember that WG adoption does not mean that we already have
> consensus on all the details(*), just that this is the right working
> document to address the issue (and that we should address the issue in the
> first place); you are encouraged to mention any issues that you already
> know.
> > Please respond to [email-masked], or exceptionally to
> [email-masked] (for off-list comments).
> >
> > This formal WG adoption call runs until the end of July 23rd so we can
> pick up the results at the CoRE meeting on July 25th.
> >
> > Grüße, Carsten
> >
> > (*) the most bikeshed issue (also relevant for the new draft name)
> appears to be whether CIRIs, which aren’t really IRIs that much, should
> rather be called CoRIs or maybe CRIs or even something completely
> different.  Please comment on this most important branding issue under
> https://protect2.fireeye.com/url?k=580aff0b-04def502-580abf90-86740465fc08-e4c236255ccab7e3&q=1&u=https%3A%2F%2Fgithub.com%2Fektrah%2Fcoral%2Fissues%2F18
> if you care.
> >

---

From: ivaylo petrov <[email-masked]>
Date: Sat, 20 Jul 2019 15:14:58 -0400

Dear all,

I have reviewed the two documents and I support adopting them.

Best regards,
Ivaylo

On Wed, Jul 17, 2019 at 9:33 AM Alexander Pelov <[email-masked]> wrote:

> On Wed, Jul 17, 2019 at 10:01 AM Ari Keränen <ari.keranen@ericsson..com
> <[email-masked]>> wrote:
>
>> > Among other things, the adoption of these drafts is intended to fill
>> the hole left when we put draft-ietf-core-links-json on hold.  So if you
>> want to comment on the WG adoption, please also keep this aspect in mind,
>> even if it could also be handled in a more orthogonal way (which you could
>> recommend).
>> >
>> > (Normally we wouldn’t run a WG call that partially overlaps an IETF,
>> but this time there is plenty of opportunity to think about CoRAL during
>> the IETF, including the hackathon and the side meeting on core applications