Subject: [core] draft-tschofenig-core-senml-lbn-00

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 9 Jul 2019 09:13:10 +0000

Hi all,

Mid June I submitted a draft that introduces the concept of a local basename to SenML.

Here is the draft:
https://tools.ietf.org/html/draft-tschofenig-core-senml-lbn-00

In the work on LwM2M we make use of SenML but only recently we noticed that there is a mismatch between the examples in the LwM2M specification and the published SenML draft.
We just didn't realize that the authors of SenML had the expectation that each sensor reading would be globally identifiable. While this feature may be useful in certain contexts it is a problem in the LwM2M context where we actually care about smaller payload sizes.

>From an over-the-wire optimization potential this simple extension is just fantastic. Even with a small number of sensor readings sent by IoT devices you can gain huge benefits.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Jul 2019 15:17:46 +0200

Hi Hannes,

Will you be at the CoRE WG interim in 102 minutes?  We probably could spare 10 minutes to discuss this.

Grüße, Carsten

> On Jul 9, 2019, at 11:13, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all, 
>  
> We just didn’t realize that the authors of SenML had the expectation that each sensor reading would be globally identifiable. While this feature may be useful in certain contexts it is a problem in the LwM2M context where we actually care about smaller payload sizes.
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 10 Jul 2019 18:23:07 +0000

I unfortunately had a conflicting meeting. Happy to discuss this topic at the joint IETF/IRTF-OMA meeting next week

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Sent: Mittwoch, 10. Juli 2019 15:18
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked] WG <[email-masked]>
Subject: Re: [core] draft-tschofenig-core-senml-lbn-00

Hi Hannes,

Grüße, Carsten