Subject: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

From: Jaime Jiménez <[email-masked]>
Date: Wed, 21 Aug 2019 11:22:34 +0300

Dear Core WG,

We would like to start the call for adoption on
draft-bormann-senml-more-units-03.
>From the minutes I see there was interest in the room during IETF 105.

The draft registers some additional basic unit types for SenML (e.g.
Byte, etc). It also proposes a secondary registry of derived units 
(e.g. milisecond, minute, etc)  with different scales and
offset that better adjust to their "common uses".

At a general level the need for this secondary registry has been
discussed in other SDOs and they too found it would be useful to have.
In order to encourage interoperability the main unit registry would be
more restricted.

BR,
-- Jaime Jiménez

---

From: Jaime Jiménez <[email-masked]>
Date: Wed, 21 Aug 2019 11:25:55 +0300

Forgot to add that the call will last a couple of weeks and will end the 
4th of September.

On Wed, Aug 21, 2019 at 11:22:34AM +0300, Jaime Jiménez wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Ari Keränen <[email-masked]>
Date: Wed, 21 Aug 2019 08:33:17 +0000

I support adopting this document. 

The new registry and units are important for OMA SpecWorks’ IPSO models use of SenML and also very useful for SenML at large. 

Cheers,
Ari

> On 21 Aug 2019, at 11.26, Jaime Jiménez <[email-masked]> wrote:
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Aug 2019 16:28:31 +0200

Hi Jaime,

I’m going on vacation on Sep 4, so sticking with the usual 1-week WGA call (instead of two weeks, despite the holiday period) might allow us to go forward faster.

To the WGA call itself:  

I’m also in favor of moving this to a WG document and then completing the work in an expedient way.

One question that does come up on the hallway is how IETF suddenly became the world authority on measurement units.  The answer is that this is not the intention.  Units are made by other entities (e.g., ISO and IEC in ISO/IEC 80000, IEEE in IEEE 1459, etc.).  The idea of the SenML units registry is to have an agreed ASCII name for a unit that is relevant to IoT and can be used in SenML and other interoperability specifications.  It turns out that doing this once in a central place is beneficial to semantic interoperability in the IoT.  In the SenML work, we found that other attempts at defining such registries are very useful as input (e.g., UCUM), but do not directly fulfill the specific requirements that SenML and other interoperability standards have.  Since, it also has turned out that SenML and other standards in this space have different requirements on the use of legacy unit identifiers, while still able to share a namespace in an unambiguous way.  Hence the update that is now being proposed.

Grüße, Carsten

> On Aug 21, 2019, at 10:25, Jaime Jiménez <[email-masked]> wrote:
> 
>

---

From: "Gillmore, Matthew" <[email-masked]>
Date: Mon, 26 Aug 2019 01:08:21 +0000

+1

I am the chair of the OMA IPSO working group and fully support adopting this document.   SENML units are the standard for smart objects in OMA.

-----Original Message-----
From: core <[email-masked]> On Behalf Of Ari Keränen
Sent: Wednesday, August 21, 2019 4:33 AM
To: Jaime Jiménez <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

Cheers,
Ari

> Forgot to add that the call will last a couple of weeks and will end 
> the 4th of September.
> 
>> (e.g. milisecond, minute, etc)  with different scales and offset that 
>> better adjust to their "common uses".
>> 
>> In order to encourage interoperability the main unit registry would 
>> be more restricted.
>> 
>> BR,
>> -- Jaime Jiménez
>>

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 26 Aug 2019 10:31:28 +0300

Dear all,

as there seems to be some timing issues with the deadline of the WGA, 
I'd like to move it ahead few days to the 1st of September. 

I hope this does not create problems to potential reviewers as there is
still this week to provide feedback.

BR,
-- Jaime Jiménez

---

From: Joaquin Prado <[email-masked]>
Date: Mon, 26 Aug 2019 09:14:40 +0000

+1
I am the administrator of the OMA LwM2M registry and I fully support draft-bormann-senml-more-units-03.

We need the implementation of the secondary registry of derived units.  Currently, we have Objects that are failing the validation because some of these units are missing from SenML registry. 
Our LwM2M tools are reading directly the units from the SenML registry.

Regards
Joaquin Prado

On 8/26/19, 2:08 AM, "core on behalf of Gillmore, Matthew" <[email-masked] on behalf of [email-masked]> wrote:

    +1

    -----Original Message-----
    From: core <[email-masked]> On Behalf Of Ari Keränen
    Sent: Wednesday, August 21, 2019 4:33 AM
    To: Jaime Jiménez <[email-masked]>; [email-masked]
    Subject: [EXTERNAL] Re: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

    Cheers,
    Ari

---

From: Hytonen Harri <[email-masked]>
Date: Mon, 26 Aug 2019 10:04:31 +0000

I'm not sure if I have the right to vote here, but as an employee of a global weather and environment sensor manufacturer, I strongly suggest that the following units are added into the secondary unit registry:

1. mm/h (millimeters per hour, scale 1/3600000): This is a standard unit for rain intensity. The primary unit m/s is very awkward to use and results a very small floating point number.
2. ppm (parts per million, scale 1/10000 of %): Standard unit for mass fraction e.g. CO2 concentration in air  
3. hPa (hecto Pascal, scale 100 of Pa): Standard unit for air pressure.
4. mm (millimeter, scale 1/1000 of m): Standard unit for rain accumulation.

Br,
Harri Hytönen
Systems Architect
Vaisala 

-----Original Message-----
From: core <[email-masked]> On Behalf Of Joaquin Prado
Sent: Monday, 26 August, 2019 12:15
To: Gillmore, Matthew <[email-masked]>; Ari Keränen <[email-masked]>; Jaime Jiménez <[email-masked]>; [email-masked]
Subject: Re: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

+1

Regards
Joaquin Prado

    +1

    -----Original Message-----
    From: core <[email-masked]> On Behalf Of Ari Keränen
    Sent: Wednesday, August 21, 2019 4:33 AM
    To: Jaime Jiménez <[email-masked]>; [email-masked]
    Subject: [EXTERNAL] Re: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

    Cheers,
    Ari

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 26 Aug 2019 13:18:24 +0300

Hi Harri,

> I'm not sure if I have the right to vote here,

As far as adopting this document goes, all opinions count.

> but as an employee of a global weather and environment sensor manufacturer, I strongly suggest that the following units are added into the secondary unit registry:
> 

this is good feedback for the authors, and I take it that then the
subregistry is needed. IMO the authors can probably add those units after the
document is adopted and before submitting the WG document version.

> Vaisala 

Thanks!
-- Jaime Jiménez