Subject: [core] Barry Leiba's Yes on draft-ietf-core-senml-more-units-05: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Wed, 19 Feb 2020 14:14:02 -0800

Barry Leiba has entered the following ballot position for
draft-ietf-core-senml-more-units-05: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-senml-more-units/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

You have a typo in section 4: "obove", where "above" is meant.

 + + + + + + + + + + + + + + + + + + + +

The following are comments from Murray Kucherawy, incoming ART AD.  Murray is
getting an early start on doing reviews, and I’m including his comments into my
ballots during the overlap period before he’s officially an Area Director.

 - - - - - - - - - - - - - - - - - - - -

Section 2: Just out of curiosity, why are some of the newly registered "VA"s
all-caps and some all-lowercase?

Section 4: I'm a bit uneasy about saying the rules for this new registry are
the same as for that older registry, with exceptions.  That means if the rules
for the old registry change, someone needs to remember to consider whether the
rules for the new registry should change in parallel, or whether something else
should happen.  But if there's precedent for doing that, or the result is
unambiguous, then we're probably fine.

Also, "six columns" followed by five bullets... I think I'd rather coax the
scale/offset line apart.

Seems to me that Section 2 and all but the last two paragraphs of Section 4
should be in Section 7.  I've never seen an "IANA Considerations" section be a
complete indirection like that.  But if we allow that, then OK.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 20 Feb 2020 02:10:22 +0100

Hi Barry,

Thanks for relaying Murray’s input.

Fixed in https://github.com/core-wg/senml-more-units/commit/b31940f791e4a6da5e05d8d92e6eeea842820209 (now in -05).

I don’t really know the history of the “var” moniker, but “VA” is just the product of “V” and “A” — the same coherent unit as “W”, but not meant as real power transfer ("active power"), but as “apparent power”.  V is for volt and A for ampere, two units that have been named after humans and therefore are always written in uppercase according to SI unit naming logic. 

“var” is an acronym/shorthand for “VA reactive”, i.e. the imaginary part of the apparent power if viewed as a complex number (“complex power”), and since it’s not named after a real person (Hal Varian? :-), it is in lower case, as are other artificial unit names such as meter (m), liter (l (*)), etc.  IEEE 1459 is the definitive document here, and IEC 80000-6 has legitimized this under item 6-60.b (in turn pointing to IEC 60050-131, which I don’t have).

> unambiguous, then we're probably fine.

I don’t know about precedent, but I agree that any future updates to the rules for the primary registry should be considered for potential inclusion (or not) to an update to the rules for the secondary registry.  Since both are subregistries of the same top level registry, this will be hard to miss.

> Also, "six columns" followed by five bullets... I think I'd rather coax the

I think any potential confusion is alleviated by the table that immediately follows and really has six columns.

> complete indirection like that.  But if we allow that, then OK.

Since the whole document is about creating registries and registering items, completely avoiding indirections would put everything into the IANA considerations section.
I’ll leave it to IANA to say whether the instructions are clear the way they are…
(We definitely have precedent with Security Considerations sections saying that a document is entirely about security.)

Grüße, Carsten

(*) I hit on the reluctantly granted exception here: according to some, but not other sources, liter may exceptionally also be abbreviated as “L” to make it typographically more different from “1”.

> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core