Subject: [core] Suresh Krishnan's No Objection on draft-ietf-core-senml-more-units-04: (with COMMENT)

From: Suresh Krishnan via Datatracker <[email-masked]>
Date: Tue, 18 Feb 2020 20:31:05 -0800

Suresh Krishnan has entered the following ballot position for
draft-ietf-core-senml-more-units-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-senml-more-units/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I could not read the normative references to IEC-80000-6 and 13 as I do not
have access . I trust the sponsoring AD to have gone through them and verified
that the item number references are correct.

Also the following text in Section 3 seems very handwavy and not particularly
helpful. Is this necessary?

"    It is not presently known to this author how
      the upcoming revision of IEC 80000-6 will update this, but it has
      became clear that there is strong interest in using this unit
      specifically for the imaginary content of complex power, reactive
      power [IEEE-1459]"

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Feb 2020 16:05:02 +0100

Hi Suresh,

it is somewhat unfortunate that we are only in the middle of the transition from closed to more openly available standards in the SI/ISQ space.  I wish I had a better answer about the IEC ones, ISO is one step ahead (at least with the recent versions).

One of the few advantages of being associated with a university is that we have a library.
So I can pretend I got my copies from there...

>      specifically for the imaginary content of complex power, reactive

I would like to keep the reference to IEEE 1459 (which is almost reasonably accessible), but I agree that the lamenting about IEC is not needed.

Now in
https://github.com/core-wg/senml-more-units/commit/d3ceb1bde39307c74f81b1a50724c05f2db49c8d

Thank you!

Grüße, Carsten

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 19 Feb 2020 16:44:22 +0000

Hi Carsten,

> On Feb 19, 2020, at 10:05 AM, Carsten Bormann <[email-masked]> wrote:
> 
> Hi Suresh,
> 

No worries. I would have been more worried if this was more than a reference to just terminology but this is not a big issue for me.

> So I can pretend I got my copies from there...

:-)

> https://github.com/core-wg/senml-more-units/commit/d3ceb1bde39307c74f81b1a50724c05f2db49c8d

Thanks. Looks good to me.

Regards
Suresh