Subject: Re: [core] [rfc-i] abbreviation SID

From: Michael Richardson <[email-masked]>
Date: Thu, 16 Apr 2020 19:02:10 -0400

tom petch <[email-masked]> wrote:
    > SID already has many meanings of which Segment Routing Identifier is
    > probably the most widely used.

okay, but this is also a new meaning to our industry with SR.

    > SID is now going to mean Schema IDentifier in the context of YANG and
    > OAM in general as defined by draft-core-sid which will doubtless be on
    > its way to the RFC Editor before too long.

CORE/YANG/CBOR could change the abreviation used.
It's in WGLC now, or maybe it's just passed.

* SchemaID.
* SchemaKey, or SK or SCK
* CSID, CSI, CSiD
* YSID, YSI
* YangID, YID

tom petch <[email-masked]> wrote:
    > I believe that an update is needed to the list of well known abbreviations,

    > SID already has many meanings of which Segment Routing Identifier is probably the most widely used.

    > SID is now going to mean Schema IDentifier in the context of YANG and OAM in general as defined by draft-core-sid which will doubtless be on its way to the RFC Editor before too long.

    > So I think that the different possibilities for SID need updating sooner rather than later.

    > Doubtless this will be a source of confusion for years to come but it might be possible to diminish that a little.

    > ---
    > New Outlook Express and Windows Live Mail replacement - get it here:
    > https://www.oeclassic.com/

    > Tom Petch
    > _______________________________________________
    > rfc-interest mailing list
    > [email-masked]
    > https://www.rfc-editor.org/mailman/listinfo/rfc-interest

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Andy Bierman <[email-masked]>
Date: Thu, 16 Apr 2020 16:25:42 -0700

Hi,

I do not think three can be much expectation of uniqueness for an acronym
like SID.
Also doubt its use in YANG could be confused with Segment Routing. But...
How about a full name "YANG SID" and OK to use a short name "SID" when the
context is clear.

Andy

On Thu, Apr 16, 2020 at 4:02 PM Michael Richardson <[email-masked]>
wrote:

>     > SID is now going to mean Schema IDentifier in the context of YANG
> and OAM in general as defined by draft-core-sid which will doubtless be on
>     > Doubtless this will be a source of confusion for years to come but
> it might be possible to diminish that a little.
>
>     > ---
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: "tom petch" <[email-masked]>
Date: Fri, 17 Apr 2020 12:43:06 +0100

----- Original Message -----
From: Andy Bierman [email-masked]
Sent: 17/04/2020 00:25:42

Hi,

I do not think three can be much expectation of uniqueness for an acronym like SID.
Also doubt its use in YANG could be confused with Segment Routing. But...
How about a full name "YANG SID" and OK to use a short name "SID" when the context is clear.

<tp>
Andy,
The RFC Editor recently expanded POP, in a routing context, to Post Office Protocol (which is one of the three options listed) so my view of the scope for confusion may be greater than yours!  SID is currently listed as having six possibilities, none of which is Schema ID, so I think this needs expanding to seven, sooner rather than later (

---

even if Segment routing has its tanks on the lawn), 
Tom Petch

Andy

On Thu, Apr 16, 2020 at 4:02 PM Michael Richardson <[email-masked]> wrote:

* SchemaID.

---

From: Andy Bierman <[email-masked]>
Date: Fri, 17 Apr 2020 11:49:51 -0700

On Fri, Apr 17, 2020 at 4:43 AM tom petch <[email-masked]> wrote:

> The RFC Editor recently expanded POP, in a routing context, to Post Office
> Protocol (which is one of the three options listed) so my view of the scope
> for confusion may be greater than yours!  SID is currently listed as having
> six possibilities, none of which is Schema ID, so I think this needs
> expanding to seven, sooner rather than later (
>

In some of our code SID means Session ID.
I guess it is too generic.
I like YSID (short for YANG Schema Identifier) as a replacement.

Andy