Subject: [Crypto-panel] Requests for review: draft-krovetz-ocb-wideblock and draft-krovetz-rc6-rc5-vectors

From: Alexey Melnikov <[email-masked]>
Date: Wed, 13 Mar 2019 18:32:40 +0000

Dear Crypto Panel members,

Independent Stream Editor asked for reviews of the following 2 documents:

https://datatracker.ietf.org/doc/draft-krovetz-ocb-wideblock/
....and...
https://datatracker.ietf.org/doc/draft-krovetz-rc6-rc5-vectors/

....in the Independent Stream.

These are both currently in expired state, but available in the archive.

If you can do a high level review first, that would be great. ISE is looking for one of the following responses:

1) this is a good idea and should be taken by CFRG
2) this is a good idea and should be published in the Independent Stream
3) this is a good idea, but needs some fixes
4) this is not a good idea and should not be published.

(If you don't know the practical difference between 1) and 2), that is Ok.)

Thank you,
Alexey

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 13 Mar 2019 22:26:50 +0200

I can take them, though it will be hard to be heard above the noise.

On 13/03/2019 20:32, Alexey Melnikov wrote:
> .....and...
> .....in the Independent Stream.
> 
> If you can do a high level review first, that would be great. ISE is 
> looking for one of the following responses:
> 
> _______________________________________________
> Crypto-panel mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/crypto-panel

---

From: Russ Housley <[email-masked]>
Date: Thu, 14 Mar 2019 02:08:18 -0400

Alexey:

There has been considerable discussion of IPR-related topics for OCB mode.  I think that the IRSG or the GFRG Chairs need to give the crypto panel guidance on this topic before a review of that document takes place.

Russ

> On Mar 13, 2019, at 2:32 PM, Alexey Melnikov <[email-masked]> wrote:
>

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 14 Mar 2019 08:44:01 +0200

Hi Russ,

The base OCB has already been published as an RFC, for better or worse, 
and quite recently. So I don't see what we stand to gain by a further 
IPR discussion, especially since such discussions are rarely conclusive. 
I don't think there's anyone claiming that the IPR situation for 
wideblock OCB is different than the baseline OCB.

Thanks,
	Yaron

---

From: Russ Housley <[email-masked]>
Date: Thu, 14 Mar 2019 02:46:25 -0400

Yaron:

I understand that bit of history.  I still think we deserve the guidance from the leadership.

Russ

> On Mar 14, 2019, at 2:44 AM, Yaron Sheffer <[email-masked]> wrote:
> 
> Hi Russ,
> 
> The base OCB has already been published as an RFC, for better or worse, and quite recently. So I don't see what we stand to gain by a further IPR discussion, especially since such discussions are rarely conclusive. I don't think there's anyone claiming that the IPR situation for wideblock OCB is different than the baseline OCB.
> 
> Thanks,
> 	Yaron
>

---

From: "Paterson, Kenny" <[email-masked]>
Date: Thu, 14 Mar 2019 09:46:14 +0000

Hi Russ, all,

Would it make sense for the review panel to focus only on the technical merits of these documents, setting aside IPR considerations? That could be flagged at the top of any review. An alternative would be to add a comment that the IPR situation appears complicated and that does speak against adoption (if the reviewer believes that to be so).

I think reviews that did this would still be very useful in answering ISE's question:

> ISE is looking for one of the following responses:

Comments?

Regards

Kenny

-----Original Message-----
From: Crypto-panel <[email-masked]> on behalf of Russ Housley <[email-masked]>
Date: Thursday, 14 March 2019 at 06:46
To: Yaron Sheffer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Alexey Melnikov <[email-masked]>, Adrian Farrel <[email-masked]>
Subject: Re: [Crypto-panel] Requests for review: draft-krovetz-ocb-wideblock and draft-krovetz-rc6-rc5-vectors

    Yaron:

    Russ

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 14 Mar 2019 17:16:14 +0200

This makes sense to me. I think there's enough material for a review 
even if the IPR situation remains open.

Thanks,
	Yaron