Subject: [Crypto-panel] Soliciting reviews of submitted PAKE algorithms

From: Alexey Melnikov <[email-masked]>
Date: Wed, 7 Aug 2019 18:58:01 +0100

Dear Crypto Review Panel members!

According to the plan, the most important parts of the PAKE selection 
process is done by the Crypto Review Panel members.
More precisely, the Crypto Review Panel members will need to do the 
following:
1) Crypto Review Panel members do the verification of security proofs of 
the candidates and overall security assessment by September 15th 2019.
2) Crypto Review Panel members review all gathered materials (including 
independent reviews). If additional explanations are needed, Crypto 
Review Panel members ask for them from the designers. Crypto Review 
Panel members write overall reviews for all candidate PAKEs, based on 
the materials that have been gathered and verified. This is to be done 
by October 30th 2019.

We have 8 nominated PAKEs: 4 balanced and 4 augmented.
Each member is asked to provide reviews for either all 4 balanced or all 
4 augmented PAKEs (or for all 8 PAKEs, if the member is happy to do that).

Please reply to this message and tell the CFRG chairs about your 
willingness to do this and, if yes, would you prefer to deal with 4 
balanced PAKEs or with 4 augmented PAKEs (or, maybe, with all 8 of them).

Best Regards,
Alexey (on behalf of CFRG chairs)

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 7 Aug 2019 21:12:50 +0300

Dear Alexey, I would be happy to do this.

I’d prefer to deal with the balanced ones.

I’ll do the verification of security proofs of the 4 balanced nominated
PAKEs by September, 15th, and I’ll be ready to do the following overall
reviews for them afterwards.

Kind regards,
Stanislav

ср, 7 авг. 2019 г. в 20:58, Alexey Melnikov <[email-masked]>:

> Review Panel members ask for them from the designers. Crypto Review Panel
> members write overall reviews for all candidate PAKEs, based on the
> materials that have been gathered and verified. This is to be done by
> October 30th 2019.
>
> Each member is asked to provide reviews for either all 4 balanced or all 4
> augmented PAKEs (or for all 8 PAKEs, if the member is happy to do that).
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Aug 2019 15:46:19 -0400

Alexey:

I am not the right person to review proofs.  I will review the other gathered material for the submissions, as needed.

Russ

> On Aug 7, 2019, at 1:58 PM, Alexey Melnikov <[email-masked]> wrote:
> 
> According to the plan, the most important parts of the PAKE selection process is done by the Crypto Review Panel members.
> More precisely, the Crypto Review Panel members will need to do the following:
> 1) Crypto Review Panel members do the verification of security proofs of the candidates and overall security assessment by September 15th 2019.
> 2) Crypto Review Panel members review all gathered materials (including independent reviews). If additional explanations are needed, Crypto Review Panel members ask for them from the designers. Crypto Review Panel members write overall reviews for all candidate PAKEs, based on the materials that have been gathered and verified. This is to be done by October 30th 2019.
> 
> Each member is asked to provide reviews for either all 4 balanced or all 4 augmented PAKEs (or for all 8 PAKEs, if the member is happy to do that).
> 
> Please reply to this message and tell the CFRG chairs about your willingness to do this and, if yes, would you prefer to deal with 4 balanced PAKEs or with 4 augmented PAKEs (or, maybe, with all 8 of them).
> 
> Best Regards,
> _______________________________________________
> Crypto-panel mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/crypto-panel

---

From: Bjoern Tackmann <[email-masked]>
Date: Wed, 7 Aug 2019 22:07:17 +0200

Dear Alex,

I shall be able to deal with the proofs of 4 schemes; I'll be fine
with either one of the two batches. I'll do the reviews until
September 15.

I'll also be happy to contribute to the second phase, although my
availability may vary a bit more during that time.

Cheers,
Björn

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 11 Aug 2019 20:28:39 +0300

Same as Russ, I am not a cryptographer and will not be able to review 
proofs. I will be happy to review the other material.

Thanks,
	Yaron

On 07/08/2019 22:46, Russ Housley wrote:
> Alexey:
> 
> I am not the right person to review proofs.  I will review the other 
> gathered material for the submissions, as needed.
> 
> Russ
> 
> 
>> On Aug 7, 2019, at 1:58 PM, Alexey Melnikov <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> 1) Crypto Review Panel members do the verification of security proofs 
>> of the candidates and overall security assessment by September 15th 2019.
>> 2) Crypto Review Panel members review all gathered materials 
>> (including independent reviews). If additional explanations are 
>> needed, Crypto Review Panel members ask for them from the designers. 
>> Crypto Review Panel members write overall reviews for all candidate 
>> PAKEs, based on the materials that have been gathered and verified. 
>> This is to be done by October 30th 2019.
>>
>> Each member is asked to provide reviews for either all 4 balanced or 
>> all 4 augmented PAKEs (or for all 8 PAKEs, if the member is happy to 
>> do that).
>>
>> [email-masked] <mailto:[email-masked]>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 13 Aug 2019 08:45:15 +0300

Currently, we've got only two crypto review panel members who will verify
the security proofs - Bjoern Tackmann and myself, each of us will review 4
PAKEs.

I sincerely hope that Scott Fluhrer, Pierre-Alain Fouque and Tibor Jager
will join us here and help with reviewing the security proofs.
*Scott*, *Pierre-Alain*, *Tibor*, will you be able to do this? If yes,
which of two batches (4 balanced PAKEs or 4 augmented PAKEs) will you
prefer?

Best regards,
Stanislav,
CFRG Secretary

---

From: Tibor Jager <[email-masked]>
Date: Tue, 13 Aug 2019 10:20:15 +0200

Dear Stanislav,

These reviews and the corresponding deadlines come at an unfortunate time for me, as I already told Alexey last week.

I am currently in the process of moving to a different university, my starting date there is September 1st. I am currently spending 110% of my time to make sure that all research funds and staff are transferred in due order, such that all students will remain funded, which is much less trivial than what I would have expected. I also have to organize lectures at my old and new university, make sure that students are taken care of, etc., and will soon have to start preparing new lectures.

Of course I will try to help as much as possible with the reviews, but it is currently very difficult for me to make any promises and binding commitments, given the rather tight reviewing deadlines.

Yours sincerely,

Tibor

Stanislav V. Smyshlyaev <[email-masked]> writes:

> Currently, we've got only two crypto review panel members who will verify the security proofs - Bjoern Tackmann and myself, each of us will review 4 PAKEs.
>
> I sincerely hope that Scott Fluhrer, Pierre-Alain Fouque and Tibor Jager will join us here and help with reviewing the security proofs.
> Scott, Pierre-Alain, Tibor, will you be able to do this? If yes, which of two batches (4 balanced PAKEs or 4 augmented PAKEs) will you prefer?
>
> Best regards,
> Stanislav,
> CFRG Secretary
>
>
> пн, 12 авг. 2019 г. в 10:29, Yaron Sheffer <[email-masked]<mailto:[email-masked]>>:
>>> On Aug 7, 2019, at 1:58 PM, Alexey Melnikov <[email-masked]<mailto:[email-masked]>
>>> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>>
>>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Tue, 13 Aug 2019 11:50:26 +0000

I’ll see what I can do.

I don’t personally have any preference – assigned whichever you want to me…

From: Stanislav V. Smyshlyaev <[email-masked]>
Sent: Tuesday, August 13, 2019 1:45 AM
To: Scott Fluhrer (sfluhrer) <[email-masked]>; Pierre-Alain Fouque <[email-masked]>; Tibor Jager <[email-masked]>; Tibor Jager <[email-masked]>
Cc: [email-masked]; [email-masked]; Alexey Melnikov <[email-masked]>
Subject: Re: [Crypto-panel] Soliciting reviews of submitted PAKE algorithms

Best regards,
Stanislav,
CFRG Secretary

Thanks,
        Yaron

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 13 Aug 2019 17:38:26 +0300

Great, many thanks!

вт, 13 авг. 2019 г. в 14:50, Scott Fluhrer (sfluhrer) <[email-masked]>:

> *From:* Stanislav V. Smyshlyaev <[email-masked]>
> *Sent:* Tuesday, August 13, 2019 1:45 AM
> *To:* Scott Fluhrer (sfluhrer) <[email-masked]>; Pierre-Alain Fouque <
> [email-masked]>; Tibor Jager <[email-masked]>; Tibor Jager <
> [email-masked]>
> *Cc:* [email-masked]; [email-masked]; Alexey Melnikov <
> [email-masked]>
> *Subject:* Re: [Crypto-panel] Soliciting reviews of submitted PAKE
> algorithms
>
>
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 14 Aug 2019 08:50:44 +0300

Dear Tibor,

Many thanks for your reply!
Would you be able to do a review if the deadline for this first stage
(verification of security assessments) will be moved from September, 15th,
to October, 15th?

Best regards,
Stanislav

вт, 13 авг. 2019 г. в 11:20, Tibor Jager <[email-masked]>:

> Dear Stanislav,
>
> These reviews and the corresponding deadlines come at an unfortunate time
> for me, as I already told Alexey last week.
>
> I am currently in the process of moving to a different university, my
> starting date there is September 1st. I am currently spending 110% of my
> time to make sure that all research funds and staff are transferred in due
> order, such that all students will remain funded, which is much less
> trivial than what I would have expected. I also have to organize lectures
> at my old and new university, make sure that students are taken care of,
> etc., and will soon have to start preparing new lectures.
>
> Of course I will try to help as much as possible with the reviews, but it
> is currently very difficult for me to make any promises and binding
> commitments, given the rather tight reviewing deadlines.
>
> Yours sincerely,
>
> Tibor
>
>
>
> > Currently, we've got only two crypto review panel members who will
> verify the security proofs - Bjoern Tackmann and myself, each of us will
> review 4 PAKEs.
> >
> > Scott, Pierre-Alain, Tibor, will you be able to do this? If yes, which
> of two batches (4 balanced PAKEs or 4 augmented PAKEs) will you prefer?
> >
> > Best regards,
> > Stanislav,
> > CFRG Secretary
> >
> >
> <mailto:[email-masked]>
> >>> [email-masked]<mailto:[email-masked]> <mailto:
> [email-masked]<mailto:[email-masked]>>

---

From: Tibor Jager <[email-masked]>
Date: Wed, 14 Aug 2019 08:10:45 +0200

Dear Stanislav,

Yes, this would make it much easier for me. Thank you.

I do not have a preference w.r.t. balanced / augmented PAKE, so please assign to me whatever makes most sense.

Cheers,
Tibor