Subject: [Crypto-panel] Reviews for 4 PAKEs (PAKE slection process)

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 11 Feb 2020 09:42:18 +0300

Dear Crypto Review Panel members,

Due to the plan of the second round of the PAKE selection process, we're
approaching Stage 4 of Round 2:

*Stage 4: February, 12th - March, 10th*
*Crypto Review Panel members prepare new overall reviews (for
all 4 remaining PAKEs) taking into account both the reviews obtained
on Round 1 and new information obtained during Round 2.*

Let me remind you, that we have 4 candidates passed to Round 2: CPace,
SPAKE2 (balanced) and AuCPace, OPAQUE (augmented).

The authors of the protocols have provided their answers to the additional
questions that were asked after IETF 106 meeting (see
https://github.com/cfrg/pake-selection/blob/master/README.md#questions-for-round-2
).

Their answers have been provided in the mailing list (see links at
https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2
).

The previous overall reviews by Bjoern Tackmann, myself, Russ Housley and
Yaron Sheffer are available at
https://github.com/cfrg/pake-selection/blob/master/README.md#overall-reviews-by-crypto-review-panel
. All other reviews are available here:
https://github.com/cfrg/pake-selection/blob/master/README.md#summary-of-reviews

So now we need reviews (each review should consider all 4 protocols -
otherwise it will be more difficult to compare) for the remaining
candidates. The reviews should be done before *March, 10th*.

First of all, it will be very important if *Bjoern, Russ *and *Yaron* could
do their new (or, better to say, updated) reviews, since they have done
them at the previous round. It will be great if Scott could participate,
since he provided very important reviews on certain issues.
Also since now we have *Chloe, Julia, Karthikeyan, Thomas, Jean-Philippe *and
*Jon *on board.
In this process we need as many good reviews as possible, so we ask all of
you to consider your participation.

Please let us know, whether you are ready to do this, before *February,
13th*.

Regards,
Stanislav (on behalf of the CFRG chairs)

---

From: Russ Housley <[email-masked]>
Date: Tue, 11 Feb 2020 12:47:40 -0500

Yes, I am prepared to update my review based on the updates.

Russ

> On Feb 11, 2020, at 1:42 AM, Stanislav V. Smyshlyaev <[email-masked]> wrote:
> 
> Due to the plan of the second round of the PAKE selection process, we're approaching Stage 4 of Round 2:
> 
> Stage 4: February, 12th - March, 10th
> Crypto Review Panel members prepare new overall reviews (for all 4 remaining PAKEs) taking into account both the reviews obtained on Round 1 and new information obtained during Round 2.
> 
> Let me remind you, that we have 4 candidates passed to Round 2: CPace, SPAKE2 (balanced) and AuCPace, OPAQUE (augmented).
> 
> The authors of the protocols have provided their answers to the additional questions that were asked after IETF 106 meeting (see https://github.com/cfrg/pake-selection/blob/master/README.md#questions-for-round-2 <https://github.com/cfrg/pake-selection/blob/master/README.md#questions-for-round-2>).
> 
> Their answers have been provided in the mailing list (see links at https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2 <https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2>).
> 
> The previous overall reviews by Bjoern Tackmann, myself, Russ Housley and Yaron Sheffer are available at https://github.com/cfrg/pake-selection/blob/master/README.md#overall-reviews-by-crypto-review-panel <https://github.com/cfrg/pake-selection/blob/master/README.md#overall-reviews-by-crypto-review-panel> . All other reviews are available here: https://github.com/cfrg/pake-selection/blob/master/README.md#summary-of-reviews <https://github.com/cfrg/pake-selection/blob/master/README.md#summary-of-reviews>
> 
> So now we need reviews (each review should consider all 4 protocols - otherwise it will be more difficult to compare) for the remaining candidates. The reviews should be done before March, 10th. 
> 
> First of all, it will be very important if Bjoern, Russ and Yaron could do their new (or, better to say, updated) reviews, since they have done them at the previous round. It will be great if Scott could participate, since he provided very important reviews on certain issues.
> Also since now we have Chloe, Julia, Karthikeyan, Thomas, Jean-Philippe and Jon on board.
> In this process we need as many good reviews as possible, so we ask all of you to consider your participation.
> 
> Please let us know, whether you are ready to do this, before February, 13th.
> 
> Regards,

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 11 Feb 2020 20:49:27 +0300

Great, many thanks, Russ!

Regards,
Stanislav

вт, 11 февр. 2020 г. в 20:47, Russ Housley <[email-masked]>:

> First of all, it will be very important if *Bjoern, Russ *and *Yaron*
> could do their new (or, better to say, updated) reviews, since they have
> done them at the previous round. It will be great if Scott could
> participate, since he provided very important reviews on certain issues.

---

From: Bjoern Tackmann <[email-masked]>
Date: Wed, 12 Feb 2020 21:11:12 +0100

Dear Stanislav,

sure, I’ll update my review, I’ll also adapt it to some insights I got through further discussions with Hugo and Stanislaw Jarecki. I’ll most likely get around to it only in March, though.

Cheers,
Björn

> On Feb 11, 2020, at 7:42 AM, Stanislav V. Smyshlyaev <[email-masked]> wrote:
> 
> The authors of the protocols have provided their answers to the additional questions that were asked after IETF 106 meeting (see https://github.com/cfrg/pake-selection/blob/master/README.md#questions-for-round-2).
> 
> Their answers have been provided in the mailing list (see links at https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2).
> 
> The previous overall reviews by Bjoern Tackmann, myself, Russ Housley and Yaron Sheffer are available at https://github.com/cfrg/pake-selection/blob/master/README.md#overall-reviews-by-crypto-review-panel . All other reviews are available here: https://github.com/cfrg/pake-selection/blob/master/README.md#summary-of-reviews
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 13 Feb 2020 12:00:51 +0300

Dear Björn,

Many thanks for your reply and for your confirmation!

>> I’ll most likely get around to it only in March, though.
We need the reviews before March, 10th – is it OK for you?

Regards,
Stanislav

On Wed, 12 Feb 2020 at 23:11, Bjoern Tackmann <[email-masked]>
wrote:

> Dear Stanislav,
>
> sure, I’ll update my review, I’ll also adapt it to some insights I got
> through further discussions with Hugo and Stanislaw Jarecki. I’ll most
> likely get around to it only in March, though.
>
> Cheers,
> Björn
>
>
> > Crypto Review Panel members prepare new overall reviews (for all 4
> remaining PAKEs) taking into account both the reviews obtained on Round 1
> and new information obtained during Round 2.
> >
> > The authors of the protocols have provided their answers to the
> additional questions that were asked after IETF 106 meeting (see
> > The previous overall reviews by Bjoern Tackmann, myself, Russ Housley
> and Yaron Sheffer are available at
> candidates. The reviews should be done before March, 10th.
> >
> > First of all, it will be very important if Bjoern, Russ and Yaron could

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Mon, 17 Feb 2020 08:26:11 +0300

Dear Russ, Bjoern and Julia!

Thanks a lot for agreeing to prepare your reviews for the Round 2 of the
PAKE selection process!

The new answers of the authors have been provided in the mailing list (see
links at
https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2
).
The previous overall reviews by Bjoern Tackmann, myself, Russ Housley and
Yaron Sheffer are available at
https://github.com/cfrg/pake-selection/blob/master/README.md#overall-reviews-by-crypto-review-panel
.
All other reviews are available here:
https://github.com/cfrg/pake-selection/blob/master/README.md#summary-of-reviews

We ask each of you to prepare a review for the *4 remaining protocols
passed to Round 2: CPace, SPAKE2 (balanced) and AuCPace, OPAQUE (augmented)*,
with the main focus on the new information provided in the new answers (
https://github.com/cfrg/pake-selection/blob/master/README.md#answers-on-round-2
).

We ask you to do this before *March, 10th*, so that we have some time
before the meeting to discuss the results with Alexey and Nick.

Thanks a lot again!

Best regards,
Stanislav, on behalf of chairs