Subject: [Crypto-panel] Request for review: draft-irtf-cfrg-pairing-friendly-curves-03

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 21 Apr 2020 15:08:34 +0300

Dear Crypto Panel members,

The authors of the Pairing-Friendly Curves draft have addressed the
concerns raised during the discussion and are ready to move to the next
stage with the draft.

Alexey, Nick and I would like to ask Crypto Review Panel members about the
review(s) of draft-irtf-cfrg-pairing-friendly-curves-03.

This memo introduces pairing-friendly curves used for constructing
pairing-based cryptography. It describes recommended parameters for each
security level and recent implementations of pairing-friendly curves.

Can we have any volunteers, please?..

Best regards,
Stanislav (on behalf of chairs)

---

From: Chloe Martindale <[email-masked]>
Date: Tue, 21 Apr 2020 13:16:05 +0100

I'll take a look this week.

All the best,
Chloe

On Tue, 21 Apr 2020, 13:10 Stanislav V. Smyshlyaev, <[email-masked]>
wrote:

> _______________________________________________
> Crypto-panel mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/crypto-panel
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 21 Apr 2020 15:15:05 +0300

Great, many thanks, Chloe!

Kind regards,
Nick, Alexey, Stanislav

On Tue, 21 Apr 2020 at 15:16, Chloe Martindale <[email-masked]>
wrote:

>> Alexey, Nick and I would like to ask Crypto Review Panel members about
>> the review(s) of draft-irtf-cfrg-pairing-friendly-curves-03.
>>

---

From: Chloe Martindale <[email-masked]>
Date: Tue, 21 Apr 2020 17:10:41 +0100

Just to be sure, can you point me towards the most recent version of the
draft please?

Thanks,
Chloe

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 21 Apr 2020 20:05:22 +0300

Sure - it is
https://tools.ietf.org/html/draft-irtf-cfrg-pairing-friendly-curves-03

Thank you again!

Regards,
Stanislav

---

From: Chloe Martindale <[email-masked]>
Date: Fri, 24 Apr 2020 17:48:49 +0100

Hi all,

review is attached.

All the best,
Chloe

On Tue, 21 Apr 2020 at 18:05, Stanislav V. Smyshlyaev <[email-masked]>
wrote:

>>> On Tue, 21 Apr 2020 at 15:16, Chloe Martindale <
>>> [email-masked]> wrote:
>>>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Sun, 26 Apr 2020 08:29:54 +0300

Dear Chloe,
Many thanks for your review (such a great and a prompt one!).

Dear Yumi, Saito, Tetsutaro, do you plan to update your draft taking into
account Chloe’s review?

Best regards,
Stanislav

пт, 24 апр. 2020 г. в 19:49, Chloe Martindale <[email-masked]>:

>> вт, 21 апр. 2020 г. в 19:10, Chloe Martindale <[email-masked]
>> >:
>>
>>>>>> Alexey, Nick and I would like to ask Crypto Review Panel members
>>>>>> about the review(s) of draft-irtf-cfrg-pairing-friendly-curves-03.
>>>>>>

---

From: SAITO Tsunekazu <[email-masked]>
Date: Mon, 27 Apr 2020 10:08:06 +0900

Dear Chloe, Stanislav,

This is Tsunekazu. 

We plan to update the draft to version 04 soon.

As the contents of the update, we changed the wording of Section 1.3 and security consideration.

Yumi will submit the 4th edition, so please wait a moment.

Best regards,

Tsunekazu

From: Stanislav V. Smyshlyaev <[email-masked]> 
Sent: Sunday, April 26, 2020 2:30 PM
To: Chloe Martindale <[email-masked]>; SAITO Tsunekazu <[email-masked]>; Tetsutaro Kobayashi <[email-masked]>; Yumi Sakemi <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Crypto-panel] Request for review: draft-irtf-cfrg-pairing-friendly-curves-03

Dear Chloe,

Dear Yumi, Saito, Tetsutaro, do you plan to update your draft taking into account Chloe’s review?

Best regards,

Stanislav 

пт, 24 апр. 2020 г. в 19:49, Chloe Martindale <[email-masked] <mailto:[email-masked]> >:

Hi all,

review is attached.

All the best,

Chloe

On Tue, 21 Apr 2020 at 18:05, Stanislav V. Smyshlyaev <[email-masked] <mailto:[email-masked]> > wrote:

Sure - it is 

Thank you again!

Regards,

Stanislav

вт, 21 апр. 2020 г. в 19:10, Chloe Martindale <[email-masked] <mailto:[email-masked]> >:

Just to be sure, can you point me towards the most recent version of the draft please?

Thanks,

Chloe

On Tue, 21 Apr 2020 at 13:17, Stanislav V. Smyshlyaev <[email-masked] <mailto:[email-masked]> > wrote:

Kind regards,

Nick, Alexey, Stanislav

On Tue, 21 Apr 2020 at 15:16, Chloe Martindale <[email-masked] <mailto:[email-masked]> > wrote:

All the best,

Chloe

On Tue, 21 Apr 2020, 13:10 Stanislav V. Smyshlyaev, <[email-masked] <mailto:[email-masked]> > wrote:

The authors of the Pairing-Friendly Curves draft have addressed the concerns raised during the discussion and are ready to move to the next stage with the draft.

Alexey, Nick and I would like to ask Crypto Review Panel members about the review(s) of draft-irtf-cfrg-pairing-friendly-curves-03.

This memo introduces pairing-friendly curves used for constructing pairing-based cryptography. It describes recommended parameters for each security level and recent implementations of pairing-friendly curves.  

 

Best regards,

_______________________________________________
Crypto-panel mailing list
[email-masked] <mailto:[email-masked]> 
https://www.irtf.org/mailman/listinfo/crypto-panel

---

From: Yumi Sakemi <[email-masked]>
Date: Mon, 27 Apr 2020 21:58:04 +0900

Dear Chloe

I appreciate your review.
I'm very glad to receive many constructive comments!
I will discuss about your comments with co-authors and revise our
draft to reflect your comments in our draft.
I think it will be a better draft by reflecting your comments.

As co-author Tsunekazu e-mailed, we're  planning to submit version 04,
because we were independently working on updating of abstract,
introduction (sec. 1.3) and proofreading of English in parallel with
the expert review.
(Version 04 will not be reflected your comments.)

Comments from Chloe will be reflected in the version 05.
We will submit version 05 in mid-May and we will report you when we
submit version 05.

Dear Stanislav

Thank you very much for proceeding to the Expert review.
We received a lot of constructive comments from Chloe, so I think it
is difficult to manage comments by email.
(Because there are over 100 comments from Chloe.)

Therefore, I would like to use the issue management function of GitHub
so that it is easy to check the reflecting status of Chloe's comments.
So, I'd like to use the repository of pairing-friendly curves draft on
CFRG's GitHub
because BLS signature which is similar in terms of IRTF stream is also
registered on the GitHub.
Could you register the repository for the draft of pairing-friendly
curves on the following CFRG's GitHub?

https://github.com/cfrg

Best regards,
Yumi

2020年4月27日(月) 10:09 SAITO Tsunekazu <[email-masked]>:
> On Tue, 21 Apr 2020 at 18:05, Stanislav V. Smyshlyaev <[email-masked]> wrote:
>
> Sure - it is
>
> On Tue, 21 Apr 2020 at 13:17, Stanislav V. Smyshlyaev <[email-masked]> wrote:
>
> On Tue, 21 Apr 2020 at 15:16, Chloe Martindale <[email-masked]> wrote:
>
> On Tue, 21 Apr 2020, 13:10 Stanislav V. Smyshlyaev, <[email-masked]> wrote:
>

-- 
Yumi Sakemi, Ph. D.
Lepidum Co. Ltd.
E-Mail: [email-masked]