Subject: Re: [Crypto-panel] Request for review: draft-irtf-cfrg-vrf-07

From: Leonid Reyzin <[email-masked]>
Date: Mon, 9 Nov 2020 22:38:06 -0500

Hi Chloe et al.,

I took care of most of the comments. The few that I couldn't are discussed
here
https://github.com/cfrg/draft-irtf-cfrg-vrf/blob/main/response-to-crypto-panel-review.md.
The new draft is at https://github.com/cfrg/draft-irtf-cfrg-vrf.

Cheers,

 Leo

On Tue, Oct 27, 2020 at 5:46 PM Leonid Reyzin <[email-masked]> wrote:

> Dear Chloe,
>
> Thank you SO much for this detailed work. I will go through it in the next
> few days and will ask followup questions if I have any.
>
> Best,
>
>  Leo
>
>
> On Mon, Oct 26, 2020 at 3:20 PM Stanislav V. Smyshlyaev <[email-masked]>
> wrote:
>
>> Thanks a lot, Chloe!
>>
>> пн, 26 окт. 2020 г. в 21:23, Chloe Martindale <[email-masked]
>> >:
>>
>>> Hi all,
>>>
>>> apologies again for the delay, my review is now attached. Thanks for
>>> your patience!
>>>
>>> All the best,
>>> Chloe
>>>
>>> On Mon, 14 Sep 2020 at 13:25, Leonid Reyzin <[email-masked]> wrote:
>>>
>>>> Thank you, Chloe! I hope you are feeling better!
>>>>
>>>> Best,
>>>>
>>>>  Leo
>>>>
>>>>
>>>> On Mon, Sep 14, 2020 at 7:36 AM Chloe Martindale <
>>>> [email-masked]> wrote:
>>>>
>>>>> I'm sorry this is on me. I had promised to review it but I've been off
>>>>> for several weeks (and wasn't able to work much before that) for health
>>>>> reasons. I'm back today and naturally have a bit of a backlog but should be
>>>>> able to get to this before the end of the month if that's ok.
>>>>>
>>>>> All the best,
>>>>> Chloe
>>>>>
>>>>> On Tue, 8 Sep 2020 at 14:19, Leonid Reyzin <[email-masked]> wrote:
>>>>>
>>>>>> Hi Everyone,
>>>>>>
>>>>>> Just a ping on this -- the VRF draft has been waiting for the
>>>>>> Crypto Review Panel. I don't know if there's been any progress? Thanks in
>>>>>> advance!
>>>>>>
>>>>>>  Leo
>>>>>>
>>>>>>
>>>>>> On Fri, Jun 19, 2020 at 1:04 PM Chloe Martindale <
>>>>>> [email-masked]> wrote:
>>>>>>
>>>>>>> I can do it, but I won't be able to look at it until 2 weeks from
>>>>>>> now because of deadlines - I hope that's not too late?
>>>>>>>
>>>>>>> All the best,
>>>>>>> Chloe
>>>>>>>
>>>>>>> On Fri, 19 Jun 2020, 16:42 Alexey Melnikov, <
>>>>>>> [email-masked]> wrote:
>>>>>>>
>>>>>>>> Dear Crypto Panel members,
>>>>>>>>
>>>>>>>> Nick, Stanislav and I would like to ask Crypto Review Panel members
>>>>>>>> for
>>>>>>>> a review of
>>>>>>>> <
>>>>>>>> https://datatracker.ietf.org/doc/draft-irtf-cfrg-vrf/?include_text=1>
>>>>>>>>
>>>>>>>> ("Verifiable Random Functions").
>>>>>>>>
>>>>>>>> Chairs are about to start RGLC on the document, so we would like to
>>>>>>>> solicit some reviews before that.
>>>>>>>>
>>>>>>>>
>>>>>>>> One or two reviews would be appreciated.
>>>>>>>>
>>>>>>>>
>>>>>>>> Thank you,
>>>>>>>>
>>>>>>>> Alexey (on behalf of chairs)
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Crypto-panel mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www.irtf.org/mailman/listinfo/crypto-panel
>>>>>>>>
>>>>>>> _______________________________________________
>>> Crypto-panel mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/crypto-panel
>>>
>>

---

From: Chloe Martindale <[email-masked]>
Date: Fri, 13 Nov 2020 10:50:39 +0000

Hi Leo, hi all,

I am happy with the new version and with how my comments were addressed
(including the ones that weren't addressed - I'm happy with the
justifications given).

All the best,
Chloe

On Tue, 10 Nov 2020 at 03:38, Leonid Reyzin <[email-masked]> wrote:

>> Thank you SO much for this detailed work. I will go through it in the
>> next few days and will ask followup questions if I have any.
>>
>> Best,
>>
>>  Leo
>>
>>
>> On Mon, Oct 26, 2020 at 3:20 PM Stanislav V. Smyshlyaev <
>> [email-masked]> wrote:
>>
>>> Thanks a lot, Chloe!
>>>
>>>>>> I'm sorry this is on me. I had promised to review it but I've been
>>>>>> off for several weeks (and wasn't able to work much before that) for health
>>>>>>>>> Nick, Stanislav and I would like to ask Crypto Review Panel
>>>>>>>>> members for
>>>>>>>>> a review of
>>>>>>>>> <