Subject: Re: [dispatch] Revised proposed charter for Combining SIP and XMPP

From: Emil Ivov <[email-masked]>
Date: Wed, 10 Feb 2010 22:33:07 +0100

Hey all,

Just wondering where this charter currently stands. Is there any
decision as to what will be happening with it?

Cheers,
Emil

[email-masked] написа:
> Hello,
> 
> I had an offline email exchange with Roni during which he mentioned
> that he would be fine with the charter text as it currently stands.
> 
> The other concern that was raised by Emil was on using shared
> credentials for SIP and XMPP authentication. My conclusion seemed to
> be that the current charter text would be ok, but we can still
> document such a feature during the protocol specification phase if
> that is deemed useful.
> 
> If my understanding is correct, and unless there are other comments
> to the charter proposal, it is good to go. Please let us know asap if
> there is still something you would like to comment.
> 
> Regards, Simo
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of ext Roni Even Sent:
>> 17 December, 2009 14:58 To: Veikkolainen Simo (Nokia-D/Helsinki);
>> [email-masked] Cc: [email-masked] Subject: Re:
>> [dispatch] Revised proposed charter for Combining SIP and XMPP
>> 
>> Simo, The other user has two endpoints, one is a video conferencing
>> appliance and the other is a PC running XMPP client. The user will
>> register his XMPP and SIP capability using the two endpoints in the
>> infrastructure Roni
>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of
>>> [email-masked] Sent: Thursday, December 17, 2009
>>> 2:34 PM To: [email-masked]; [email-masked] Cc:
>>> [email-masked] Subject: Re: [dispatch] Revised proposed
>>> charter for Combining SIP and XMPP
>>> 
>>> Roni,
>>> 
>>>>> A "dual stack" SIP/XMPP client should be able to talk SIP to
>>>>> a SIP-
>>>> only
>>>>> endpoint and XMPP to an XMPP-only endpoint. What is that you
>>>>> need
>> in
>>>>> addition to this?
>>>> The dual stack client need to know that these two clients are
>>>> the
>> same
>>>> user. For example start a XMPP chat and add the SIP video call.
>>>> This
>>> is
>>>> not advertised by the remote XMPP client but by the
>>>> infrastructure.
>>>> 
>>>> From the other direction (two systems) it will involve starting
>>>> chat from XMPP and adding SIP video to the call by the XMPP
>>>> client for example by telling the other side or the SIP server
>>>> to call the his
>>> SIP
>>>> client on the appliance.
>>>> 
>>> Let me see if I understood you correctly. It sounds you are
>>> looking
>> for
>>> two use cases:
>>> 
>>> 1) to add SIP voice/video or XMPP chat from an integrated
>>> endpoint
>> even
>>> though the other endpoint is SIP-only or XMPP-only
>>> 
>>> 2) to add SIP voice/video or XMPP chat from a XMPP-only or
>>> SIP-only endpoint, respectively.
>>> 
>>> For 2), I don't see how that is possible without changes in the
>>> client side.
>>> 
>>> For 1), you would need to be able, from a "dual stack" endpoint,
>>> to tell the XMPP server to start an XMPP session, or the SIP
>>> server to make a SIP call to the same user you already have a SIP
>>> or XMPP
>> session
>>> with. While probably doable, this is not what we had in mind for
>>> this work.
>>> 
>>> Simo _______________________________________________ dispatch
>>> mailing list [email-masked] 
>>> https://www.ietf.org/mailman/listinfo/dispatch
>> _______________________________________________ dispatch mailing
>> list [email-masked] 
>> https://www.ietf.org/mailman/listinfo/dispatch
> 

-- 
Emil Ivov, Ph.D.                               67000 Strasbourg,
Project Lead                                   France
SIP Communicator
[email-masked]                     PHONE: +33.1.77.62.43.30
http://sip-communicator.org                    FAX:   +33.1.77.62.47.31

---

From: <[email-masked]>
Date: Thu, 11 Feb 2010 14:07:18 +0100

Hi Emil,

We have gotten the charter proposal as far as the RAI ADs, but we haven't gotten an approval yet.

Simo and me are anyway working on a draft (based on our earlier draft) that would crystallize the use cases and requirements, and would fit as the first deliverable according to the charter. Once we get that out, I propose to focus the discussion on that to make sure we agree on that part of the work. 

The technical solution work can definitely progress in parallel, but right now at least Simo and me don't have much to add to what we have already submitted and what was discussed in Hiroshima and on the list. It would be useful to put together a presentation of the different options (the ones outlined in our current draft and those proposed by others) together before Anaheim also to see how easy it will be to find consensus on those. Would someone volunteer to take that task? (If not, Simo and me can take a stab on that too, but I remember a few hands were raised at the BOF :-).

If we manage to get a slot at Anaheim I suppose these would be the things on the agenda as well:
1. Use cases and requirements --> are we happy to adopt a draft as a WG item to work towards the first deliverable
2. Go through the different technical approaches --> can we find consensus and also can we find an editor for the draft or drafts defining the extensions we want to standardize

Regarding the combined client provisioning/configuration issue that you, Emil, brought up: I was thinking that it might be wise to actually write a short draft (a BCP) about the best ways how to arrange the autoconfig of a combined SIP/XMPP client. On SIP side we finally a pretty decent approach with the recent SIP Forum UA-config work (Scott Lawrence, John Elwell et al) and there are ways for XMPP as well, so we could take those as the baseline. Perhaps we could write something about the case that a single service provider offers both SIP and XMPP accounts and what synergies might exist for such a case. Do you Emil think that would be a useful thing to have?

Markus

>[mailto:[email-masked]] On Behalf Of ext Emil Ivov
>Sent: 10 February, 2010 23:33
>To: Veikkolainen Simo (Nokia-D/Helsinki)
>Cc: [email-masked]
>Subject: Re: [dispatch] Revised proposed charter for Combining 
>SIP and XMPP
>
>Hey all,
>
>Just wondering where this charter currently stands. Is there 
>any decision as to what will be happening with it?
>
>Cheers,
>Emil
>
>> If my understanding is correct, and unless there are other 
>comments to 
>> the charter proposal, it is good to go. Please let us know asap if 
>>>> [email-masked] Subject: Re: [dispatch] Revised proposed charter 
>>>> for Combining SIP and XMPP
>>>> 
>>>> Roni,
>>>> 
>>>>>> A "dual stack" SIP/XMPP client should be able to talk SIP to a 
>>>>>> SIP-
>>>>> only
>>>>>> endpoint and XMPP to an XMPP-only endpoint. What is that you need
>>> in
>>>>>> addition to this?
>>>>> The dual stack client need to know that these two clients are the
>>> same
>>>>> chat from XMPP and adding SIP video to the call by the 
>XMPP client 
>>>>> for example by telling the other side or the SIP server 
>to call the 
>>>>> his
>>>> SIP
>>>>> client on the appliance.
>>>>> 
>>>> Let me see if I understood you correctly. It sounds you are looking
>>> for
>>>> two use cases:
>>>> 
>>>> 1) to add SIP voice/video or XMPP chat from an integrated endpoint
>>> even
>>>> For 1), you would need to be able, from a "dual stack" 
>endpoint, to 
>>>> tell the XMPP server to start an XMPP session, or the SIP 
>server to 
>>>> make a SIP call to the same user you already have a SIP or XMPP
>>> session
>>> _______________________________________________ dispatch 
>mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/dispatch
>> 
>
>-- 
>_______________________________________________
>dispatch mailing list
>[email-masked]