Subject: [dispatch] Comment on draft-liess-dispatch-alert-info-urns-00

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Feb 2010 13:13:58 +0100

I was looking for the information on how this changed the Alert-Info header field usage from RFC 3261 and did not find it.

RFC 3261 defines the usage of this header field only for INVITE requests.

While this draft gives examples, and therefore implies it is valid for some responses, it is not clear whether that extension now extends beyond INVITE, is all INVITE responses, or is limited to 180 responses. Could we have some more normative type statements in this regard.

Oh, and I'd actually like to know what the answer is!

regards

Keith

---

From: <[email-masked]>
Date: Fri, 19 Feb 2010 14:56:39 +0100

Hi Keith, 

We are just working on a new version of the draft. There are some
inconsistencies in the 00 version. 
The draft just should define additional identifiers which can be sent in
the Alert-Info header. It does not change the header usage. 

I hope things will be more clear in the new version. E.g. all "busy"-
stuff was deleted. We also distinguish between ring tones and ringback
tones and state that ring tones can be sent only in INVITE , while
ringback tones can be sent only in 180-ringing. 

Kind regards
Laura  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
> Sent: Friday, February 19, 2010 1:14 PM
> To: DISPATCH
> Subject: [dispatch] Comment on draft-liess-dispatch-alert-info-urns-00
> 
> I was looking for the information on how this changed the 
> Alert-Info header field usage from RFC 3261 and did not find it.
> 
> While this draft gives examples, and therefore implies it is 
> valid for some responses, it is not clear whether that 
> extension now extends beyond INVITE, is all INVITE responses, 
> or is limited to 180 responses. Could we have some more 
> normative type statements in this regard.
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Feb 2010 15:06:55 +0100

So the header usage in RFC 3261 is INVITE requests and 180 responses to INVITE requests only. That remains the case? Perhaps a single informative statement regarding the header field usage is unchanged from RFC 3261 might be appropriate, unless that is already covered elsewhere (I have not done a line by line scan).

regards

Keith

> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Friday, February 19, 2010 1:57 PM
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: Re: [dispatch] Comment on 
> draft-liess-dispatch-alert-info-urns-00
> 
> Hi Keith, 
> 
> We are just working on a new version of the draft. There are 
> some inconsistencies in the 00 version. 
> The draft just should define additional identifiers which can 
> be sent in the Alert-Info header. It does not change the 
> header usage. 
> 
> I hope things will be more clear in the new version. E.g. all 
> "busy"- stuff was deleted. We also distinguish between ring 
> tones and ringback tones and state that ring tones can be 
> sent only in INVITE , while ringback tones can be sent only 
> in 180-ringing. 
> 
> Kind regards
> Laura  
> 
> 
> 
> 
> Alert-Info 
> > header field usage from RFC 3261 and did not find it.
> > 
> > While this draft gives examples, and therefore implies it 
> is valid for 
> > some responses, it is not clear whether that extension now extends 
> > beyond INVITE, is all INVITE responses, or is limited to 180 
> > responses. Could we have some more normative type 
> statements in this 
> > regard.
> >

---

From: <[email-masked]>
Date: Fri, 19 Feb 2010 15:30:20 +0100

Keith, 

I think an informative statement regarding the header field usage is
unchanged from RFC 3261 is a good idea. I will look for a place for it. 

I am a little confused by the text " to INVITE requests only." in your
first sentence. What did you mean with it? 

Kind regards
Laura

> From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
> Sent: Friday, February 19, 2010 3:07 PM
> To: Liess, Laura; [email-masked]
> Subject: RE: [dispatch] Comment on 
> So the header usage in RFC 3261 is INVITE requests and 180 
> responses to INVITE requests only. That remains the case? 
> Perhaps a single informative statement regarding the header 
> field usage is unchanged from RFC 3261 might be appropriate, 
> unless that is already covered elsewhere (I have not done a 
> line by line scan).
> 
> regards
> 
> Keith
> 
> 
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Feb 2010 16:05:17 +0100

Maybe I was being too precise but the words "180 responses to INVITE requests" needs to be read as a whole, i.e. it is a 160 response generated as a result of receiving an INVITE request.

Keith

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, February 19, 2010 2:30 PM
> I think an informative statement regarding the header field 
> usage is unchanged from RFC 3261 is a good idea. I will look 
> for a place for it. 
> 
> I am a little confused by the text " to INVITE requests 
> only." in your first sentence. What did you mean with it? 
> 
> Kind regards
> Laura
> 
>  
> 
>  
> 
> responses 
> > to INVITE requests only. That remains the case?
> > Perhaps a single informative statement regarding the header field 
> > usage is unchanged from RFC 3261 might be appropriate, 
> unless that is 
> > already covered elsewhere (I have not done a line by line scan).
> > 
> > regards
> > 
> > Keith
> > 
> > 
> > 
> > > The draft just should define additional identifiers which can be 
> > > sent in the Alert-Info header. It does not change the 
> header usage.
> > > 
> > > "busy"- stuff was deleted. We also distinguish between ring tones 
> > > and ringback tones and state that ring tones can be sent only in 
> > > INVITE , while ringback tones can be sent only in 180-ringing.
> > > 
> > > Kind regards
> > > Laura
> > > 
> > > 
> > > 
> > >

---

From: <[email-masked]>
Date: Fri, 19 Feb 2010 16:16:34 +0100

Fine, thanks.

Laura

> Sent: Friday, February 19, 2010 4:05 PM
> Maybe I was being too precise but the words "180 responses to 
> INVITE requests" needs to be read as a whole, i.e. it is a 
> 160 response generated as a result of receiving an INVITE request.
> 
> Keith
>  
> 
> > > > > RFC 3261 defines the usage of this header field only 
> for INVITE 
> > > > > requests.
> > > > >