Subject: Re: [dispatch] Comments ondraft-rehor-dispatch-session-recording-req-00

From: zhouzhipeng 54906 <[email-masked]>
Date: Wed, 03 Feb 2010 17:51:58 +0800

Dear all,
I have got much valuable information from related emails.
As I cited as following,

> [rj] This can range anywhere from proprietary VoIP media and 
> signaling protocols to things such as SCCP, UNISTIM, H.323, TDM 
> and analog phones. Most such phones are not SIP UAs. Some other 
> entity (such as a SIP-enabled mixer) may provide the RC media 
> forking point functionality in these cases.

there have been many years for the application of recording. 
So, may the author give us a brief summary what have been advanced based on current recording solutions, for example the call center architecture. So we can easily catch the core point of this document.

Another point is: does the diagram need to add the interface between UA to the RS for the search or query functions.

Thanks very much.
Zhipeng

---

From: Leon Portman <[email-masked]>
Date: Thu, 4 Feb 2010 18:05:33 +0200

Zhipeng, Hi

The core point of this document is to define a SIP based protocol that will allow Active VoIP recording, where a some entity from communication system (gateway, phone, media server) will fork media of the call to recording server.

The interface for querying and playback of recorded sessions are currently out of scope of this work because it probably should be a web service or REST interface. However we are definitely considering to work on it as well.

Regards

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhouzhipeng 54906
Sent: Wednesday, February 03, 2010 11:52 AM
To: [email-masked]
Subject: Re: [dispatch] Comments ondraft-rehor-dispatch-session-recording-req-00

Dear all,

Thanks very much.
Zhipeng

_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Lorenzo Miniero <[email-masked]>
Date: Thu, 4 Feb 2010 17:43:48 +0100

Hi Leon and Zhipeng,

just for your knowledge, I remind the ML of the existence of a draft we
wrote a few months ago that is related to session recording and
playback:

http://tools.ietf.org/html/draft-romano-dcon-recording-01

It is not currently based on web services or RESTful interfaces, but it
still is a standard approach, since it makes use of SMIL to synchronize
the recorded streams and play them back to interested users. In case
anyone is interested in working on a document related to this topic just
let us know.

Lorenzo

On Thu, 4 Feb 2010 18:05:33 +0200

-- 
Lorenzo Miniero
Meetecho s.r.l.
http://www.meetecho.com/

---

From: Leon Portman <[email-masked]>
Date: Thu, 4 Feb 2010 18:49:47 +0200

Lorenzo, Hi

It will be very important to continue this work for standardization how recordings will be represented, specially for complex scenarios with multiple medias and segments

Regards

Leon 

-----Original Message-----
From: Lorenzo Miniero [mailto:[email-masked]] 
Sent: Thursday, February 04, 2010 6:44 PM
To: Leon Portman
Cc: zhouzhipeng 54906; [email-masked]
Subject: Re: [dispatch] Comments ondraft-rehor-dispatch-session-recording-req-00

Hi Leon and Zhipeng,

Lorenzo

-- 
Lorenzo Miniero
Meetecho s.r.l.
http://www.meetecho.com/