Subject: [dispatch] Prorgessing draft-avasarala-dispatch-comm-div-notification-02

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 09 Feb 2010 11:16:23 +0200

Hi,

there have been a set of messages on the list providing comments on the
draft below:

http://tools.ietf.org/html/draft-avasarala-dispatch-comm-div-notification-02

As you know, the process for defining SIP event packages is documented here:

http://tools.ietf.org/html/draft-peterson-rai-rfc3427bis-04#section-4.1

Based on the feedback received, the authors need to decide whether they
want to generalize their solution so that is is generally applicable to
the public Internet or if they want to (further) clarify that this
mechanism is intended to work only in IMS networks that provide a CDIV
service.

If the authors choose the latter approach, we (the DISPATCH chairs) will
choose a "Designated Expert" who will check the draft against the 7
points described in the document above.

Cheers,

Gonzalo
DISPATCH co-chair

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 9 Feb 2010 16:05:08 +0100

At the moment, I think those of us looking at this from the 3GPP way of doing things do not see a more general application of this.

I do not have a problem with doing it more generally, but I guess the people who see a clear use case for that need to speak up and identify their use cases. 

Otherwise we end up designing a general event package that no one else ever uses. As opposed to the alternative of clearly stating the restricted use to a particular applicability, approving it, and moving on to something else with our restricted amount of resources.

regards

Keith 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: Tuesday, February 09, 2010 9:16 AM
> To: DISPATCH
> Cc: Mary Barnes
> Subject: [dispatch] Prorgessing 
> draft-avasarala-dispatch-comm-div-notification-02
> 
> Hi,
> 
> there have been a set of messages on the list providing 
> comments on the draft below:
> 
> Based on the feedback received, the authors need to decide 
> whether they want to generalize their solution so that is is 
> generally applicable to the public Internet or if they want 
> to (further) clarify that this mechanism is intended to work 
> only in IMS networks that provide a CDIV service.
> 
> If the authors choose the latter approach, we (the DISPATCH 
> chairs) will choose a "Designated Expert" who will check the 
> draft against the 7 points described in the document above.
> 
> Cheers,
> 
> Gonzalo
> DISPATCH co-chair
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 09 Feb 2010 10:57:12 -0500

I don't have a problem with it being IMS-specific.
I just want it to *say* that it is IMS-specific.

	Thanks,
	Paul

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 9 Feb 2010 17:53:57 +0100

I think that is a given and if that is the way to go, I'm sure we'll all make sure the words on the front cover go that way.

But there seemed to be some prior responses trying to take potential use cases beyond that, and I wanted to make sure that if they existed, they were explicitly declared.

regards

Keith 

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Tuesday, February 09, 2010 3:57 PM
> To: DRAGE, Keith (Keith)
> Cc: Gonzalo Camarillo; DISPATCH; Mary Barnes
> Subject: Re: [dispatch] Prorgessing 
> > At the moment, I think those of us looking at this from the 
> 3GPP way of doing things do not see a more general 
> application of this.
> > 
> > I do not have a problem with doing it more generally, but I 
> guess the people who see a clear use case for that need to 
> speak up and identify their use cases. 
> > 
> > Otherwise we end up designing a general event package that 
> no one else ever uses. As opposed to the alternative of 
> clearly stating the restricted use to a particular 
> applicability, approving it, and moving on to something else 
> with our restricted amount of resources.
> > 
> > regards
> > 
> > Keith
> > 
> >> Based on the feedback received, the authors need to decide whether 
> >> they want to generalize their solution so that is is generally 
> >> applicable to the public Internet or if they want to (further) 
> >> clarify that this mechanism is intended to work only in 
> IMS networks 
> >> that provide a CDIV service.
> >>
> >> chairs) will choose a "Designated Expert" who will check the draft 
> >> against the 7 points described in the document above.
> >>
> >> Cheers,
> >>
> >> Gonzalo
> >> DISPATCH co-chair

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Wed, 10 Feb 2010 01:01:41 +0800

Hi all

Sure. I am updating the I-D with the comments and modifying the
applicability statement to reflect that it is specific to IMS. Will
submit the updated (-03) version of the I-D and then take it forward
with Option-2 as suggested by Camarillo.

Thanks 

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of DRAGE, Keith (Keith)
Sent: Tuesday, February 09, 2010 10:24 PM
To: Paul Kyzivat
Cc: Mary Barnes; DISPATCH
Subject: Re: [dispatch]Prorgessing
draft-avasarala-dispatch-comm-div-notification-02

I think that is a given and if that is the way to go, I'm sure we'll all
make sure the words on the front cover go that way.

But there seemed to be some prior responses trying to take potential use
cases beyond that, and I wanted to make sure that if they existed, they
were explicitly declared.

regards

Keith 

> 3GPP way of doing things do not see a more general application of 
> this.
> > 
> guess the people who see a clear use case for that need to speak up 
> and identify their use cases.
> > 
> no one else ever uses. As opposed to the alternative of clearly 
> stating the restricted use to a particular applicability, approving 
> it, and moving on to something else with our restricted amount of 
> resources.
> > 
> > regards
> > 
> > Keith
> >

---

From: Anders Kristensen <[email-masked]>
Date: Tue, 09 Feb 2010 12:04:13 -0800

IIUC the IMS use case (or one of them) is that users may configure call 
forwarding services and forget that they've done so. The CDIV feature 
then allows them to learn of calls being forwarded and take corrective 
action. This is not at all IMS specific - the same use case can be said 
to exist in non-IMS deployments.

I suspect addressing this problem in a general way is no more work than 
to do it in an IMS specific way but would make for a better standard. 
What's more, if I'm right and this is inherently not an IMS specific 
problem then the solution is likely to be picked up and used in other 
contexts regardless of whatever stern wording is on the front page of 
the RFC.

Thanks,
Anders

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 09 Feb 2010 15:51:18 -0500

Anders,

It was also my assumption going in that this is potentially a problem 
area of general interest.

But the existing solution (as best I understand it) is wed to a 
particular system architecture - not one that we would likely wish to 
see enshrined in a more general standard.

To get beyond that we would need somebody who is interested in doing the 
work to get something more general. I'm not seeing anybody stand up to 
do that. (I know I don't have the time to do it.)

Lacking that, I see no justification to block their getting their event 
package as long as it is suitably scoped.

	Thanks,
	Paul

Anders Kristensen wrote:
>> I think that is a given and if that is the way to go, I'm sure we'll 
>> all make sure the words on the front cover go that way.
>>
>> But there seemed to be some prior responses trying to take potential 
>> use cases beyond that, and I wanted to make sure that if they existed, 
>> they were explicitly declared.
>>
>>
>> regards
>>
>> Keith
>>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 10 Feb 2010 10:33:25 +0200

Hi,

as I stated in my previous email, Paul's description of the situation
below is accurate.

Cheers,

Gonzalo