Subject: [dispatch] FW: New Version Notification for draft-yusef-dispatch-ach-rest-api-01

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Tue, 9 Nov 2010 17:21:17 -0500

Hi,

I have talked to few people attending IETF79 here in Beijing about the draft-yusef-dispatch-ach-rest-api draft.
It seems that some people are still interested in this work and would like to see some progress.

I have submitted a new version of the draft, without changes, just to extend the expiry date.
I would appreciate if the people interested in this work can review the document and provide feedback to the mailing list.

Here is the link to the new version:
http://www.ietf.org/id/draft-yusef-dispatch-ach-rest-api-01.txt

Thanks,
 Rifaat

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, November 09, 2010 3:49 PM
To: Shekh-Yusef, Rifaat (Rifaat)
Cc: [email-masked]
Subject: New Version Notification for draft-yusef-dispatch-ach-rest-api-01 

A new version of I-D, draft-yusef-dispatch-ach-rest-api-01.txt has been successfully submitted by Rifaat Shekh-Yusef and posted to the IETF repository.

Filename:	 draft-yusef-dispatch-ach-rest-api
Revision:	 01
Title:		 ACH RESTful Interface
Creation_date:	 2010-11-10
WG ID:		 Independent Submission
Number_of_pages: 18

Abstract:
This document defines a RESTful interface that allows a RESTful
client to directly affect the Automatic Call Handling (ACH) behavior
at a domain authoritative for a specific SIP address.

The IETF Secretariat.

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 19 Nov 2010 09:25:36 +0100

Rifaat,

As I mentioned to you, I am not prepared to pick up work on ach-analysis again unless there is a substantial body of support from the community - that support certainly was not there when we asked some months ago. Your draft is related, so again I have doubts whether there would be support and implementations, but let's see. A couple of remarks:

1. ACH is defined only for incoming calls, so the outgoing barring resource in your draft seems to be outside the scope of ACH. Moreover, if the typical user of the RESTful interface is the user, how likely is it that the user would be authorized to configure his/her own outgoing call barring? If the user requires the same credentials to configure barring as he/she needs to make a call, it doesn't make sense, although there may be other situations in which it does make sense.

2. Although it makes sense to keep it simple, to cover the 80% of common uses, it should be clear how the mechanism can be extended in a standardized or proprietary manner in future. This leads to questions of IANA registries.

John

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Shekh-Yusef, 
> Rifaat (Rifaat)
> Sent: 09 November 2010 22:21
> To: [email-masked]
> Subject: [dispatch] FW: New Version Notification for 
> draft-yusef-dispatch-ach-rest-api-01
> 
> Hi,
> 
> I have talked to few people attending IETF79 here in Beijing 
> about the draft-yusef-dispatch-ach-rest-api draft.
> I would appreciate if the people interested in this work can 
> review the document and provide feedback to the mailing list.
> 
> A new version of I-D, 
> draft-yusef-dispatch-ach-rest-api-01.txt has been 
> successfully submitted by Rifaat Shekh-Yusef and posted to 
> the IETF repository.
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Sat, 20 Nov 2010 12:34:05 -0500

Hi John,

Thanks for your comments.

This is my last attempt to try to get some support for this work.
If I do not get sufficient support, I will drop it.

Regards,
 Rifaat

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Friday, November 19, 2010 3:26 AM
To: Shekh-Yusef, Rifaat (Rifaat); [email-masked]
Subject: RE: [dispatch] FW: New Version Notification for draft-yusef-dispatch-ach-rest-api-01

Rifaat,

John