Subject: Re: [dispatch] Telepresence charter version 9

From: Frank Fang <[email-masked]>
Date: Wed, 24 Nov 2010 12:06:08 +0800

Hi Allyn,
I have heard there was some changes agreed during offline discussion for
"multiple video streams and single audio steam with multiple channels ".
But I can't find this in the updated Telepresence charter. Any comments on
this?

Regards,
Ping Fang (Frank Fang)

----------------------------------------------------------------------

Message: 1
Date: Tue, 16 Nov 2010 09:03:13 -0800
From: "Allyn Romanow (allyn)" <[email-masked]>
Subject: [dispatch] Telepresence charter version 9
To: "IETF DISPATCH list" <[email-masked]>,	"Peter Saint-Andre
	(psaintan)" <[email-masked]>
Message-ID:
	
<[email-masked]>
Content-Type: text/plain; charset="us-ascii"

Folks,
Here is the charter updated with comments from the Dispatch meeting.
 
----
 
Changes from Version 8
At the Dispatch meeting, Peter Saint-Andre pointed out that we would not
be "changing" IETF protocols, but extending them, as in his note to the
Dispatch list. I had overlooked an instance of  "change" and revised it
here to "extension". Thanks Peter.
 
Also, we heard that MAITAI means something unpleasant in Chinese. If so,
maybe we could do CLUE and move to a Sherlock theme, as someone
suggested??
 
============================
 
MAITAI - Multi-stream Attributes for Improving Telepresence Application
Interoperability
CLUE -- ControLling mUltiple streams for TElepresence
 
In the context of this WG, the term telepresence is used in a general
manner to describe systems that provide high definition, high quality
audio/video enabling a "being-there" experience.  One example is an
immersive telepresence system using specially designed and special
purpose rooms with multiple displays permitting life size image
reproduction using multiple cameras, encoders, decoders, microphones and
loudspeakers.
 
Current telepresence systems are based on open standards such as RTP,
SIP, H.264, the H.323 suite. However, they cannot easily interoperate
with each other without operator assistance and expensive additional
equipment which translates from one vendor to another. A major factor
limiting the interoperability of telepresence systems  is the lack of a
standardized way to describe and negotiate the use of the multiple
streams of audio and video comprising the media flows.
 
The WG will create specifications for SIP-based conferencing systems to
enable communication of  information about media streams so that a
sending system,  receiving system, or intermediate system can make
reasonable decisions about transmitting, selecting, and rendering media
streams. This enables systems to make choices that optimize user
experience.
 
This working group is chartered to specify the following information
about media streams from one entity to another entity: 
 
* Spatial relationships of cameras, displays, microphones, and
loudspeakers - relative to each other and to likely positions of
participants
 
* Viewpoint, field of view/capture for
camera/microphone/display/loudspeaker - so that senders and intermediate
devices can understand how best to compose streams for receivers, and
the receiver will know the characteristics of its received streams
 
* Usage of the stream, for example whether the stream is presentation,
or document 
   camera output
 
* Aspect ratio of cameras and displays 
 
*Which sources a receiver wants to receive.  For example, it might  want
the source for the 
   left camera, or might want the source chosen by VAD (Voice Activity
Detection)
 
Information between sources and sinks about media stream capabilities
will be exchanged. 
 
The working group will define the semantics, syntax, and transport
mechanism for communicating the necessary information. It will consider
whether existing protocols for signaling, messaging and transport are
adequate or need to be extended. Any extensions to IETF protocols will
be done in appropriate WGs, for example extensions to SDP in MMUSIC.
 
The scope of the work includes describing relatively static relations
between entities (participants and devices). It also includes handling
more dynamic relationships, such as specifying the audio and video
streams for defined speakers. Specifying the location of the current
speakers relative to display microphones needs to be provided
dynamically as speakers move.  
 
As part of the receiver telling the sender what it wants dynamically,
explicit receiver notification to the sender of the desired video stream
and video pause will be considered.
 
The scope includes both systems that provide a fully immersive
experience, and systems that interwork with them and therefore need to
understand the same multiple stream semantics.  
 
The focus of this work is on multiple RTP audio and video streams.
Other media types may be considered, however development of
methodologies for them is not within the scope of this work.
 
Interoperation with SIP and related standards for audio and video is
required.  However, backwards compatibility with existing non-standards
compliant telepresence systems is not required.
 
This working group is not currently chartered to work on issues of
continuous conference        control including: far end camera control,
floor control, conference roster. The working group may identify
interoperability obstacles in existing open standards. If so, the WG
will develop requirements to be communicated to other IETF WGs or
Standards Forums, or recharter as appropriate.
 
Reuse of existing protocols and backwards compatibility with
SIP-compliant audio/video endpoints are important factors for the
working group to consider. The work will closely coordinate with the
appropriate areas (e. g., OPS, SEC), and working groups including  AVT,
MMUSIC, MEDIACTRL, XCON, and SIPCORE.
 
 Milestones  
 
July 2011 Submit informational draft to IESG on use cases 
 
July 2011 Submit informational draft to IESG on framework and
requirements
 
Nov 2011 Submit standards track specification(s) to IESG to support
framework and requirements
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://www.ietf.org/mail-archive/web/dispatch/attachments/20101116/3e19409c
/attachment.htm>

------------------------------

_______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

End of dispatch Digest, Vol 20, Issue 39
****************************************

---

From: "Allyn Romanow (allyn)" <[email-masked]>
Date: Tue, 23 Nov 2010 20:24:23 -0800

Hi Frank,

I don't recall that there was an agreement to change the charter text.

As I recall the problem was that the phrase
		The focus of this work is on multiple RTP audio and
video streams

Was understood to mean that it did not include single audio streams with
multiple channels, and that in offline discussion, it was explained that
the meaning of the sentence included single audio channels as well as
multiple audio channels.

It seemed that the misunderstanding resulted from parsing the sentence
as 
  (Multiple RTP audio) and video streams
Rather than 
   Multiple RTP (audio and video) streams

In any case, if there is agreement on the list that the sentence text
should be revised, that's fine.
If this is the case I could suggest
   The focus of this work is on multiple RTP audio and video streams
(including single audio streams with multiple channels).

Though, personally, I believe this is understood in the original
phrasing.

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,
I have heard there was some changes agreed during offline discussion for
"multiple video streams and single audio steam with multiple channels ".
But I can't find this in the updated Telepresence charter. Any comments
on
this?

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,
 
----
 
Changes from Version 8

 

 

 

 

 

 

 
 
 Milestones  

 
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://www.ietf.org/mail-archive/web/dispatch/attachments/20101116/3e19
409c
/attachment.htm>

---

From: Frank Fang <[email-masked]>
Date: Wed, 24 Nov 2010 14:12:09 +0800

Hi Allyn,

Yes, I remember there were different understandings of the phrase. 

And to tell the truth, I can't tell that single audio stream is clearly
included in the original text :)

If it is agreed that single audio stream with multiple channels is also in
scope, it will do no harm we state this clear in the charter. And I like
your change proposal " The focus of this work is on multiple RTP audio and
video streams (including single audio streams with multiple channels)."
except "s" needs to be removed for single video stream.

Thanks,
Frank

-----Original Message-----
From: Allyn Romanow (allyn) [mailto:[email-masked]] 
Sent: Wednesday, November 24, 2010 12:24 PM
To: Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko, Stephen
Subject: RE: [dispatch] Telepresence charter version 9

Hi Frank,

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,
 
----
 
Changes from Version 8

 

 

 

 

 

 

 
 
 Milestones

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 24 Nov 2010 05:23:23 -0800

My understanding of the intent was that multiple video streams is in scope, regardless of how many audio streams there are.  And multiple audio streams is in scope, regardless of how many video streams there are.  So maybe this says it better:

		The focus of this work is on multiple RTP audio and/or video streams

Mark Duckworth

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Allyn Romanow (allyn)
Sent: Tuesday, November 23, 2010 11:24 PM
To: Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko, Stephen
Subject: Re: [dispatch] Telepresence charter version 9

Hi Frank,

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,
 
----
 
Changes from Version 8

 

 

 

 

 

 

 
 
 Milestones

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 24 Nov 2010 08:31:47 -0500

WFM

Peter

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Wed, 24 Nov 2010 08:26:36 -0600

Can still be misread.  Keep it simple:

The focus of this work is on multiple RTP streams (multiple audio or
multiple video).

Exactly how many of each and what each is doing is getting into the work
of the group and probably shouldn't be constrained at this point.

Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Duckworth, Mark
Sent: Wednesday, November 24, 2010 8:23 AM
To: Allyn Romanow (allyn); Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko,Stephen
Subject: Re: [dispatch] Telepresence charter version 9

My understanding of the intent was that multiple video streams is in
scope, regardless of how many audio streams there are.  And multiple
audio streams is in scope, regardless of how many video streams there
are.  So maybe this says it better:

		The focus of this work is on multiple RTP audio and/or
video streams

Mark Duckworth

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Allyn Romanow (allyn)
Sent: Tuesday, November 23, 2010 11:24 PM
To: Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko, Stephen
Subject: Re: [dispatch] Telepresence charter version 9

Hi Frank,

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,
 
----
 
Changes from Version 8

 

 

 

 

 

 

 
 
 Milestones

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 24 Nov 2010 09:30:04 -0500

WFM

Marshall

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 24 Nov 2010 06:59:23 -0800

That looks good too.

Mark

-----Original Message-----
From: Mike Hammer (hmmr) [mailto:[email-masked]] 
Sent: Wednesday, November 24, 2010 9:27 AM
To: Duckworth, Mark; Allyn Romanow (allyn); Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko, Stephen
Subject: RE: [dispatch] Telepresence charter version 9

Mike

-----Original Message-----

Mark Duckworth

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 24 Nov 2010 12:14:36 -0500

WFM

Peter

---

From: Paul Coverdale <[email-masked]>
Date: Wed, 24 Nov 2010 13:24:33 -0500

Yes, the issue raised during off-line discussion in Beijing related to
single audio streams consisting of multiple channels. To be clear in the
charter, I support the proposal below from Allyn:

"The focus of this work is on multiple RTP audio and video streams
(including single audio streams with multiple channels)".

Paul Coverdale

-----Original Message-----
From: Allyn Romanow (allyn) [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 11:24 PM
To: Frank Fang; [email-masked]
Cc: Paul Coverdale; Botzko, Stephen
Subject: RE: [dispatch] Telepresence charter version 9

Hi Frank,

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]] 
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,
 
----
 
Changes from Version 8

 

 

 

 

 

 

 
 
 Milestones

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 24 Nov 2010 13:35:07 -0500

Though I think this is already in scope with the current charter text, I
have no objection to clarifying it.

Steve B.

On Wed, Nov 24, 2010 at 1:24 PM, Paul Coverdale <[email-masked]>wrote:

> 409c<http://www.ietf.org/mail-archive/web/dispatch/attachments/20101116/3e19%0A409c>
> /attachment.htm>
>

---

From: Frank Fang <[email-masked]>
Date: Thu, 25 Nov 2010 09:50:06 +0800

I like the clarification, except that "single audio streams" is supposed to
be "single audio stream".

(It seems that the last email I sent out was neglected by the system J )

Frank Fang

From: Stephen Botzko [mailto:[email-masked]] 
Sent: Thursday, November 25, 2010 2:35 AM
To: Paul Coverdale
Cc: Allyn Romanow (allyn); Frank Fang; [email-masked]
Subject: Re: [dispatch] Telepresence charter version 9

Steve B.

On Wed, Nov 24, 2010 at 1:24 PM, Paul Coverdale <[email-masked]>
wrote:

Paul Coverdale

-----Original Message-----
From: Allyn Romanow (allyn) [mailto:[email-masked]]
Sent: Tuesday, November 23, 2010 11:24 PM
To: Frank Fang; [email-masked]

Hi Frank,

Comments?

Thanks,
Allyn

-----Original Message-----
From: Frank Fang [mailto:[email-masked]]
Sent: Tuesday, November 23, 2010 8:06 PM
To: [email-masked]; Allyn Romanow (allyn)
Cc: 'Paul Coverdale'; 'Botzko, Stephen'
Subject: RE: [dispatch] Telepresence charter version 9

Hi Allyn,

Regards,
Ping Fang (Frank Fang)

Message: 1

Folks,

----

Changes from Version 8

 Milestones

-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://www.ietf.org/mail-archive/web/dispatch/attachments/20101116/3e19
<http://www.ietf.org/mail-archive/web/dispatch/attachments/20101116/3e19%0A4
09c> 
409c
/attachment.htm>