Subject: [dispatch] Telepresence charter version 9

From: "Allyn Romanow (allyn)" <[email-masked]>
Date: Tue, 16 Nov 2010 09:03:13 -0800

Folks,
Here is the charter updated with comments from the Dispatch meeting.
 
----
 
Changes from Version 8
At the Dispatch meeting, Peter Saint-Andre pointed out that we would not
be "changing" IETF protocols, but extending them, as in his note to the
Dispatch list. I had overlooked an instance of  "change" and revised it
here to "extension". Thanks Peter.
 
Also, we heard that MAITAI means something unpleasant in Chinese. If so,
maybe we could do CLUE and move to a Sherlock theme, as someone
suggested??
 
============================
 
MAITAI - Multi-stream Attributes for Improving Telepresence Application
Interoperability
CLUE -- ControLling mUltiple streams for TElepresence
 
In the context of this WG, the term telepresence is used in a general
manner to describe systems that provide high definition, high quality
audio/video enabling a "being-there" experience.  One example is an
immersive telepresence system using specially designed and special
purpose rooms with multiple displays permitting life size image
reproduction using multiple cameras, encoders, decoders, microphones and
loudspeakers.
 
Current telepresence systems are based on open standards such as RTP,
SIP, H.264, the H.323 suite. However, they cannot easily interoperate
with each other without operator assistance and expensive additional
equipment which translates from one vendor to another. A major factor
limiting the interoperability of telepresence systems  is the lack of a
standardized way to describe and negotiate the use of the multiple
streams of audio and video comprising the media flows.
 
The WG will create specifications for SIP-based conferencing systems to
enable communication of  information about media streams so that a
sending system,  receiving system, or intermediate system can make
reasonable decisions about transmitting, selecting, and rendering media
streams. This enables systems to make choices that optimize user
experience.
 
This working group is chartered to specify the following information
about media streams from one entity to another entity: 
 
* Spatial relationships of cameras, displays, microphones, and
loudspeakers - relative to each other and to likely positions of
participants
 
* Viewpoint, field of view/capture for
camera/microphone/display/loudspeaker - so that senders and intermediate
devices can understand how best to compose streams for receivers, and
the receiver will know the characteristics of its received streams
 
* Usage of the stream, for example whether the stream is presentation,
or document 
   camera output
 
* Aspect ratio of cameras and displays 
 
*Which sources a receiver wants to receive.  For example, it might  want
the source for the 
   left camera, or might want the source chosen by VAD (Voice Activity
Detection)
 
Information between sources and sinks about media stream capabilities
will be exchanged. 
 
The working group will define the semantics, syntax, and transport
mechanism for communicating the necessary information. It will consider
whether existing protocols for signaling, messaging and transport are
adequate or need to be extended. Any extensions to IETF protocols will
be done in appropriate WGs, for example extensions to SDP in MMUSIC.
 
The scope of the work includes describing relatively static relations
between entities (participants and devices). It also includes handling
more dynamic relationships, such as specifying the audio and video
streams for defined speakers. Specifying the location of the current
speakers relative to display microphones needs to be provided
dynamically as speakers move.  
 
As part of the receiver telling the sender what it wants dynamically,
explicit receiver notification to the sender of the desired video stream
and video pause will be considered.
 
The scope includes both systems that provide a fully immersive
experience, and systems that interwork with them and therefore need to
understand the same multiple stream semantics.  
 
The focus of this work is on multiple RTP audio and video streams.
Other media types may be considered, however development of
methodologies for them is not within the scope of this work.
 
Interoperation with SIP and related standards for audio and video is
required.  However, backwards compatibility with existing non-standards
compliant telepresence systems is not required.
 
This working group is not currently chartered to work on issues of
continuous conference        control including: far end camera control,
floor control, conference roster. The working group may identify
interoperability obstacles in existing open standards. If so, the WG
will develop requirements to be communicated to other IETF WGs or
Standards Forums, or recharter as appropriate.
 
Reuse of existing protocols and backwards compatibility with
SIP-compliant audio/video endpoints are important factors for the
working group to consider. The work will closely coordinate with the
appropriate areas (e. g., OPS, SEC), and working groups including  AVT,
MMUSIC, MEDIACTRL, XCON, and SIPCORE.
 
 Milestones  
 
July 2011 Submit informational draft to IESG on use cases 
 
July 2011 Submit informational draft to IESG on framework and
requirements
 
Nov 2011 Submit standards track specification(s) to IESG to support
framework and requirements

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 16 Nov 2010 12:04:32 -0500

On Nov 16, 2010, at 12:03 PM, Allyn Romanow (allyn) wrote:

> At the Dispatch meeting, Peter Saint-Andre pointed out that we would not be “changing” IETF protocols, but extending them, as in his note to the Dispatch list. I had overlooked an instance of  “change” and revised it here to “extension”. Thanks Peter.
>  
> Also, we heard that MAITAI means something unpleasant in Chinese. If so, maybe we could do CLUE and move to a Sherlock theme, as someone suggested??
>  

+1 for Clue (or, how about MYCROFT ?).

Marshall

> MAITAI – Multi-stream Attributes for Improving Telepresence Application Interoperability
> In the context of this WG, the term telepresence is used in a general manner to describe systems that provide high definition, high quality audio/video enabling a "being-there" experience.  One example is an immersive telepresence system using specially designed and special purpose rooms with multiple displays permitting life size image reproduction using multiple cameras, encoders, decoders, microphones and loudspeakers.
>  
> Current telepresence systems are based on open standards such as RTP, SIP, H.264, the H.323 suite. However, they cannot easily interoperate with each other without operator assistance and expensive additional equipment which translates from one vendor to another. A major factor limiting the interoperability of telepresence systems  is the lack of a standardized way to describe and negotiate the use of the multiple streams of audio and video comprising the media flows.
>  
> The WG will create specifications for SIP-based conferencing systems to enable communication of  information about media streams so that a sending system,  receiving system, or intermediate system can make reasonable decisions about transmitting, selecting, and rendering media streams. This enables systems to make choices that optimize user experience.
>  
> This working group is chartered to specify the following information about media streams from one entity to another entity:
>  
> * Spatial relationships of cameras, displays, microphones, and loudspeakers – relative to each other and to likely positions of participants
>  
> * Viewpoint, field of view/capture for camera/microphone/display/loudspeaker – so that senders and intermediate devices can understand how best to compose streams for receivers, and the receiver will know the characteristics of its received streams
>  
> * Usage of the stream, for example whether the stream is presentation, or document
>    camera output
>  
> *Which sources a receiver wants to receive.  For example, it might  want the source for the
>    left camera, or might want the source chosen by VAD (Voice Activity Detection)
>  
> Information between sources and sinks about media stream capabilities will be exchanged. 
>  
> The working group will define the semantics, syntax, and transport mechanism for communicating the necessary information. It will consider whether existing protocols for signaling, messaging and transport are adequate or need to be extended. Any extensions to IETF protocols will be done in appropriate WGs, for example extensions to SDP in MMUSIC.
>  
> The scope of the work includes describing relatively static relations between entities (participants and devices). It also includes handling more dynamic relationships, such as specifying the audio and video streams for defined speakers. Specifying the location of the current speakers relative to display microphones needs to be provided dynamically as speakers move. 
>  
> As part of the receiver telling the sender what it wants dynamically, explicit receiver notification to the sender of the desired video stream and video pause will be considered.
>  
> The scope includes both systems that provide a fully immersive experience, and systems that interwork with them and therefore need to understand the same multiple stream semantics.  
>  
> The focus of this work is on multiple RTP audio and video streams.  Other media types may be considered, however development of methodologies for them is not within the scope of this work.
>  
> Interoperation with SIP and related standards for audio and video is required.  However, backwards compatibility with existing non-standards compliant telepresence systems is not required.
>  
> This working group is not currently chartered to work on issues of continuous conference        control including: far end camera control, floor control, conference roster. The working group may identify interoperability obstacles in existing open standards. If so, the WG will develop requirements to be communicated to other IETF WGs or Standards Forums, or recharter as appropriate.
>  
> Reuse of existing protocols and backwards compatibility with SIP-compliant audio/video endpoints are important factors for the working group to consider. The work will closely coordinate with the appropriate areas (e. g., OPS, SEC), and working groups including  AVT, MMUSIC, MEDIACTRL, XCON, and SIPCORE.
>  
>  Milestones  
>  
> July 2011 Submit informational draft to IESG on framework and requirements
>  
> Nov 2011 Submit standards track specification(s) to IESG to support framework and requirements
>  
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch