Subject: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

From: "GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" <[email-masked]>
Date: Mon, 13 Dec 2010 16:39:16 +0100

Hi everybody,

Here is the charter proposal for Q4S ( Quality for service) WG. This WG will include the achieved works with  "Q-HTTP"

Thanks for your comments

Description of Working group
============================

   Problem Statement:

   The QoS over Internet is a hot issue today. Current QoS handling
   mechanisms used in  modern network transport layers (MPLS, RSVP,
   Diffserv,Traffic Engineering) do not provide  themselves a
   QoS-on-demand end-to-end solution and existing adaptative
   solutions based on In-band Control protocols (such as RTCP)
   are very difficult to combine with any other protocols for which
   they have not been designed for.

   Four Network Parameters comprises the QoS at application level:
   Bandwidth, packet-loss, latency and Jitter.

   Interactive-video applications define flows in both directions.
   Different applications require different constraints (in terms of
   latency, jitter, packet loss) in one or both directions and
   different responsiveness. The proposed solution must be an
   effective out-of-band application level protocol capable of
   reacting when any of these constraints are violated. Such protocol
   must trigger adaptive solutions and/or QoS network profile changes.

   Currently content providers are only able to provide services based
   on adaptative methods or last-mille deployments which prefer
   dedicated network resources (vs. Internet), and therefore, restricts
   the subscriber population and increases the costs.

   Objetives:

   The goal of this working group is to define a
   QoS application-level  standard protocol optimized for its use over
   the internet that may be widely implemented and easily managed
   by application developers and service providers.

   The core technical considerations for such protocol include, but
   are not necessarily limited to, the following:

   1. Protocol design to be used in interactive applications (including
      virtualized videogames,and interative-video applications)

   2. Ensuring interoperability with all existing transport protocols

   3. Optimizing for low bit rates (typlically below 2.4 kbps)

   4. To ensure a feasible practical implementation based on
      policy servers and interoperability between service providers

   Deliverables:

   1. Specification of protocol that meets the requirements in the
      form of an Internet-Draft that defines the negotiation of QoS
      parameters, the measurement process and alert mechanisms.

   2. Dimensioning rules and performance analysis

   3. A set of technical requirements for a practical
      implementation which may include adaptative solutions and/or
      QoS profile modification.

Goals and Milestiones
=====================

 Nov 2010    Submit Internet-Draft as a proposed standard for QoS
             application-level protocol

             Proposed charter for Q4S WG

             Informational document with rules for dimensioning
             and performance analysis

             Specification of architecture document for implementation

- Jose Javier

---

From: Janet P Gunn <[email-masked]>
Date: Thu, 16 Dec 2010 17:25:51 -0500

I am a little bit confused by the combination  of 
        1. Protocol design to be used in interactive applications 
(including
      virtualized videogames,and interative-video applications)
  and
    3. Optimizing for low bit rates (typlically below 2.4 kbps)

I do not know many video games that work effectively at 2.4 kbps.

Am I missing something?

Janet

From:
"GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" 
<[email-masked]>
To:
"[email-masked]'" <[email-masked]>
Cc:
"[email-masked]" <[email-masked]>, "CUBILLO PASTOR, CLARA 
\(CLARA\)" <[email-masked]>, "ORTIGA   HERRERA, 
GUADALUPE \(GUADALUPE\)" <[email-masked]>, 
"[email-masked]" <[email-masked]>, "HERRANZ PABLO,    SONIA 
\(SONIA\)" <[email-masked]>, "[email-masked]" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
"[email-masked]" <[email-masked]>, "DIAZ        VIZCAINO, LUIS MIGUEL 
\(LUIS MIGUEL\)" <[email-masked]>
Date:
12/13/2010 10:56 AM
Subject:
[dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

Hi everybody, 
 
Here is the charter proposal for Q4S ( Quality for service) WG. This WG 
will include the achieved works with  "Q-HTTP"
 
Thanks for your comments

   Problem Statement:

 

   Objetives:

 

 

   Deliverables:

 

Goals and Milestiones
=====================

 

 

- Jose Javier

 _______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: "GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" <[email-masked]>
Date: Fri, 17 Dec 2010 08:34:08 +0100

Hi Janet,

This new protocol nature for doing it is out-of-band. It means that it will run
in parallel with the protocol in charge of transport application data .
For example this new protocol could be used in parallel with FTP, HTTP , RTC or whatever.

The new protocol measures the quality ( latency, jitter, packetloss, bandwidth) at the
beggining and if the minimum quality is reached, the application can start asuring
a good experience. During the application timelife, the new protocol measures
continuously the latency, jitter an packetloss and alerts if one or some of these
parameters are below certain threshold ( which depends on the application nature).

Therefore, we propose a protocol compatible with all existing transport ones, to provide a
reliable mechanism for adaptative and QoS profile optimization.

The new protocol uses low resources. Depending on the resources being used, the
responsiveness is different. For example, it can be useful to have a better  responsiveness
 in downlink than uplink, depends on each application. However, in any case is a good point
to consume a low bit rate for this purpose, though there is a trade-off between responsiveness and
used bit-rate

- jose javier

________________________________
De: Janet P Gunn [mailto:[email-masked]]
Enviado el: jueves, 16 de diciembre de 2010 23:26
Para: GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)
CC: [email-masked]; CUBILLO PASTOR, CLARA (CLARA); [email-masked]'; [email-masked]; [email-masked]; ORTIGA HERRERA, GUADALUPE (GUADALUPE); [email-masked]; [email-masked]; DIAZ VIZCAINO, LUIS MIGUEL (LUIS MIGUEL); [email-masked]; HERRANZ PABLO, SONIA (SONIA)
Asunto: Re: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

Am I missing something?

Janet

From:   "GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" <[email-masked]>
To:     "[email-masked]'" <[email-masked]>
Cc:     "[email-masked]" <[email-masked]>, "CUBILLO PASTOR,        CLARA \(CLARA\)" <[email-masked]>, "ORTIGA        HERRERA,        GUADALUPE \(GUADALUPE\)" <[email-masked]>, "[email-masked]" <[email-masked]>, "HERRANZ PABLO,        SONIA \(SONIA\)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "DIAZ        VIZCAINO, LUIS MIGUEL \(LUIS MIGUEL\)" <[email-masked]>
Date:   12/13/2010 10:56 AM
Subject:        [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

________________________________

Hi everybody,

Thanks for your comments

   Problem Statement:

   Objetives:

   Deliverables:

Goals and Milestiones
=====================

- Jose Javier

---

From: "DIAZ VIZCAINO, LUIS MIGUEL (LUIS MIGUEL)" <[email-masked]>
Date: Fri, 17 Dec 2010 09:13:57 +0100

Maybe we should re-pharse that again :). We refer to Q4S protocol itself consuming low bit-rate, not the applications themselves :D

    Saludos,
         Luismi

Am I missing something?

Janet

Hi everybody,

Thanks for your comments

   Problem Statement:

   Objetives:

   Deliverables:

Goals and Milestiones
=====================

- Jose Javier

---

From: Peter Musgrave <[email-masked]>
Date: Fri, 17 Dec 2010 06:57:11 -0500

Hi Jose, 

Can you comment on the relationship of this work to the rtcweb drafts currently in dispatch? Those seems to me a method to use existing protocols to solve very similar issues. 

I am also unsure of what defining an application level standard protocol really means. Is this changes to http? Something that runs beside http? Instead of? Over?

Thanks, 

Peter Musgrave

---

From: Janet P Gunn <[email-masked]>
Date: Fri, 17 Dec 2010 14:16:39 -0500

OK, so that was what I was missing.

Maybe rephrasing it would help.

Janet

This is a PRIVATE message. If you are not the intended recipient, please 
delete without copying and kindly advise us by e-mail of the mistake in 
delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to 
any order or other contract unless pursuant to explicit written agreement 
or government initiative expressly permitting the use of e-mail for such 
purpose.

From:
"GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" 
<[email-masked]>
To:
Janet P Gunn/USA/CSC@CSC
Cc:
"[email-masked]" <[email-masked]>, "CUBILLO PASTOR, CLARA 
(CLARA)" <[email-masked]>, "[email-masked]'" 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
"ORTIGA HERRERA, GUADALUPE (GUADALUPE)" 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, "[email-masked]" <[email-masked]>, "DIAZ VIZCAINO, 
LUIS MIGUEL (LUIS MIGUEL)" <[email-masked]>, 
"[email-masked]" <[email-masked]>, "HERRANZ PABLO, SONIA 
(SONIA)" <[email-masked]>
Date:
12/17/2010 02:34 AM
Subject:
RE: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

Hi Janet,
 
This new protocol nature for doing it is out-of-band. It means that it 
will run 
in parallel with the protocol in charge of transport application data . 
For example this new protocol could be used in parallel with FTP, HTTP , 
RTC or whatever.
 
The new protocol measures the quality ( latency, jitter, packetloss, 
bandwidth) at the 
beggining and if the minimum quality is reached, the application can start 
asuring 
a good experience. During the application timelife, the new protocol 
measures 
continuously the latency, jitter an packetloss and alerts if one or some 
of these 
parameters are below certain threshold ( which depends on the application 
nature).
 
Therefore, we propose a protocol compatible with all existing transport 
ones, to provide a 
reliable mechanism for adaptative and QoS profile optimization.
 
The new protocol uses low resources. Depending on the resources being 
used, the 
responsiveness is different. For example, it can be useful to have a 
better  responsiveness
 in downlink than uplink, depends on each application. However, in any 
case is a good point 
to consume a low bit rate for this purpose, though there is a trade-off 
between responsiveness and 
used bit-rate
 
- jose javier

De: Janet P Gunn [mailto:[email-masked]] 
Enviado el: jueves, 16 de diciembre de 2010 23:26
Para: GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)
CC: [email-masked]; CUBILLO PASTOR, CLARA (CLARA); 
[email-masked]'; [email-masked]; [email-masked]; ORTIGA 
HERRERA, GUADALUPE (GUADALUPE); [email-masked]; [email-masked]; DIAZ 
VIZCAINO, LUIS MIGUEL (LUIS MIGUEL); [email-masked]; HERRANZ PABLO, 
SONIA (SONIA)
Asunto: Re: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) 
Version 1

Am I missing something? 

Janet

From: 

Hi everybody, 

Thanks for your comments 

   Problem Statement: 

  

   Objetives: 

  

  

   Deliverables: 

  

Goals and Milestiones 
===================== 

  

  

- Jose Javier

---

From: "GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" <[email-masked]>
Date: Sat, 18 Dec 2010 12:44:52 +0100

Hi Peter , all

relation with rtcweb
===============
rtcweb try to identify and find a consensus on a  set of components to communicate universally for real-time communications. Inside this approach, Q4S protocol could be part of this set of agreed protocols. The intention of rtcweb is to standarize as much as possible, without leaving these set of protocols or functionalities in the scope of web applications or plug-ins for browsers. We believe that a standarized protocol for Quality measurements and alerts would be interesting for all internet community because if we compare a Q4S standard protocol  with propietary solutions, we found that the range of benefited applications and the number of possible implementations are higher with a standardized solution.
In addition a multi-ISP solution could be reached using a standard protocol, in which each peer of communication belongs to a different ISP and possibilities based on Q4S protocol are available for QoS profile managemen.

relation with http
=====================
The measurement and/or alert in realtime functions would be  covered by the Q4S wg, in particular the Q - HTTP protocol ( which may be renamed to Q4S or other name).
This protocol (formerly named Q-HTTP) uses HTTP syntax, and uses specific URI for easy integration in www. However can be used out of www context.  In fact,  the protocol is not an http extension.  It is an out-of-band protocol to measure and alert participants of a communication based in any protocol ( http could be the protocol to transmit application data and Q-HTTP the protocol to monitor the quality end2end).  The protocol can be used in conjuntion with any other protocol used for application data transport (HTTP, FTP, RTP, whatever) . In fact, Q-HTTP is not used  to  transpor t  data, but for measurement the latency, jitter, packetloss end2end and alert if some thresholds are being violated for trigger adaptative solutions or changes in QoS profile.

The concrete adatative solution or how the QoS profile is changed is out of scope of the protocol. The protocol only monitor and send an alert, that is useful to know when these types of actions should be taken

- jose javier

________________________________
De: Peter Musgrave [mailto:[email-masked]]
Enviado el: viernes, 17 de diciembre de 2010 12:57
Para: GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)
CC: [email-masked]'; [email-masked]; CUBILLO PASTOR, CLARA (CLARA); ORTIGA HERRERA, GUADALUPE (GUADALUPE); [email-masked]; HERRANZ PABLO, SONIA (SONIA); [email-masked]; [email-masked]; [email-masked]; DIAZ VIZCAINO, LUIS MIGUEL (LUIS MIGUEL)
Asunto: Re: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

Hi Jose,

Thanks,

Peter Musgrave

Hi everybody,

Thanks for your comments

   Problem Statement:

   Objetives:

   Deliverables:

Goals and Milestiones
=====================

- Jose Javier

_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 20 Dec 2010 14:36:24 +0100

On 12/13/10 16:39, GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER) wrote:
> Hi everybody,
> Here is the charter proposal for Q4S ( Quality for service) WG. This 
> WG will include the achieved works with  "Q-HTTP"
Forgive me if this has been asked before....

does this approach (out-of-band measurements on a different set of 
ports/protocols than in fact used by the application) assume that the 
network is not doing deep packet inspection or differential treatment of 
services?

Is there an interaction with DSCP packet marking - could the measurement 
setup specify DSCP codepoints to be set on packets (and, knowing that 
these are changed en route, report on the DSCP codepoints of incoming 
packets)?

In both points, it would be nice if the charter said whether it was in 
or out of scope.

                       Harald

---

From: "GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)" <[email-masked]>
Date: Mon, 20 Dec 2010 17:48:46 +0100

Hi Harald,

The approach does no assume the details of the particular implementation. The protocol sends ALERT when any constraint is being violated, and these ALERTs can be monitored using DPI and change DSCP on the fly. However, the protocol does not assume it. The protocol only allow participants to know the quality measurements and to be aware of the alerts. After an alert is received , a lot of implementations are possible . Following are some examples:

   - use DPI and change DSCP packet marking  ( network aware of this protocol) and/or other type of QoS actions over network elements like changes on traffic mode at acces nodes or Path computation element function invocation.
   - invoke a supra entity  (policy service) in charge of modify quality profiles on ISPs
   - invoke a policy server which belongs to an ISP and ask for changes on QoS profles
   - react with adaptative mechanisms ( like reduce bit-rate or functionalities of the application)
   - simultaneously apply adaptative solution and QoS profile change through DPI, policy servers or whatever.

Therefore the answer to your question is that the Q4S does not assume that. We will say it explicitly in the charter

thanks!

- jose javier

________________________________
De: Harald Alvestrand [mailto:[email-masked]]
Enviado el: lunes, 20 de diciembre de 2010 14:36
Para: GARCIA ARANDA, JOSE JAVIER (JOSE JAVIER)
CC: [email-masked]'; [email-masked]; CUBILLO PASTOR, CLARA (CLARA); ORTIGA HERRERA, GUADALUPE (GUADALUPE); [email-masked]; HERRANZ PABLO, SONIA (SONIA); [email-masked]; [email-masked]; [email-masked]; DIAZ VIZCAINO, LUIS MIGUEL (LUIS MIGUEL)
Asunto: Re: [dispatch] Charter proposal for Q4S WG ( formerly Q-HTTP) Version 1

Hi everybody,

does this approach (out-of-band measurements on a different set of ports/protocols than in fact used by the application) assume that the network is not doing deep packet inspection or differential treatment of services?

Is there an interaction with DSCP packet marking - could the measurement setup specify DSCP codepoints to be set on packets (and, knowing that these are changed en route, report on the DSCP codepoints of incoming packets)?

In both points, it would be nice if the charter said whether it was in or out of scope.

                      Harald

Thanks for your comments

   Problem Statement:

   Objetives:

   Deliverables:

Goals and Milestiones
=====================

- Jose Javier