Subject: [dispatch] Proposed charter for extended date format

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 19 Feb 2021 15:20:08 +1100

I've asked the chairs for space on the next dispatch agenda to talk about dispatch for

https://datatracker.ietf.org/doc/draft-ryzokuken-datetime-extended/

The authors have taken on board the idea that we should extract the "obsolete RFC3339" and either remove it entirely, or separate it into a document which does nothing but update RFC3339 with support for a wider range of year values.  There will be an updated version of this draft soon.

The dispatch chairs also asked me for some proposed charter text if we were to spin up a working group for this topic.  Here's that text.

Cheers,

Bron.

Serialising Extended Data About Times and Events (SEDATE)
----

RFC3339 defines a format that can reliably express an instant in time, either in UTC or in a local time along with the offset against UTC, however datetime data often has additional context, such as the timezone or calendar system that was in use when that instant was recorded. Particularly when using times for interval, recurrence, or offset calculations, it's necessary to know the context in which the timepoint exists.

It is valuable to have a serialisation format which retains this context and can reliably round-trip the additional context to systems which understand it, via intermediate systems which only need to know about the instant in time.

The TC39 working group at ECMA have developed a format which is a good basis for this work.

It is anticipated that this document would be a companion to RFC3339 rather than a replacement, embedding an un-altered RFC3339 instant along with the contextual data.

It is also within scope for this group to consider a minor update to RFC3339 to allow larger than 4 digit signed years, to enable representing times further into the past and future.

Once this work is done it is anticipated that this working group will be short-lived, and once the one or two documents are published the working group will close down.

Milestones:
* April 2021: Adopt draft describing a serialisation format for extended datetimes.
* July 2021: Submit the serialisation document to the IESG.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 20 Feb 2021 23:14:46 +0100

> The TC39 working group at ECMA have developed a format which is a good basis for this work.

I assume you are talking about:

https://tc39.es/proposal-temporal/docs/iso-string-ext.html

What is the stage of this proposal?

(Re the draft: It is weird to end on a leap second table that stops in 1998.  Not many have happened since, but the omission is jarring.  Also, ISO 8601 has evolved since 1988, now as a two-part standard etc.  Even the IETF has done some work, e.g., see RFC 7164.)

Grüße, Carsten