Subject: Re: [dispatch] SMTP Code for Undesirable Messages

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 12 Jan 2022 07:43:41 -0800

On Fri, Dec 17, 2021 at 9:05 AM Brotman, Alex <Alex_Brotman=
[email-masked]> wrote:

> I've been wondering if it may be beneficial for a mailbox provider to be
> able to signal back to the sender that the message is being accepted, but
> is undesirable based on some criteria.  The idea would be that a provider
> may evaluate some characteristics of the message, and before issuing a "250
> Ok" have already determined the message would be routed to the spam
> folder.  Something as simple as:
>
> 255 Ok - Routing to spam folder
>
> This would likely need some "Security Considerations" section about how
> informing a malicious entity may be undesirable.  I'm willing to write this
> up as a proposed draft, though I'm not entirely sure where to direct that
> draft.  Thank you for any advice you could provide.
>

Two things, one substantive and one procedural:

(1) On procedure: This might be better raised on either the SMTP mailing
list or the ART mailing list.  DISPATCH is mostly for talking about live or
proposed work items, like when there's a draft ready to bring to the table
for disposition.

(2) On substance: Why not register an enhanced status code for this instead
of a new SMTP reply code?  See
https://www.iana.org/assignments/smtp-enhanced-status-codes/smtp-enhanced-status-codes.xhtml
and the RFC it references.

-MSK

---

From: "Brotman, Alex" <[email-masked]>
Date: Thu, 13 Jan 2022 15:06:19 +0000

1.  I’d asked someone who spends more time working within the IETF, and dispatch was their suggestion.  I’m happy to take it anywhere else that is suggested.
  2.  I’m not opposed to both.  I suspect there will be a fair bit of discussion about the general idea of the proposal, and this had already crossed my mind.  I would imagine there are some MTAs that may not understand enhanced codes, though that may mean they wouldn’t know how to deal with any new response codes at all.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

From: Murray S. Kucherawy <[email-masked]>
Sent: Wednesday, January 12, 2022 10:44 AM
To: Brotman, Alex <[email-masked]>
Cc: [email-masked]
Subject: Re: [dispatch] SMTP Code for Undesirable Messages

On Fri, Dec 17, 2021 at 9:05 AM Brotman, Alex <Alex_Brotman=[email-masked]<mailto:[email-masked]>> wrote:
I've been wondering if it may be beneficial for a mailbox provider to be able to signal back to the sender that the message is being accepted, but is undesirable based on some criteria.  The idea would be that a provider may evaluate some characteristics of the message, and before issuing a "250 Ok" have already determined the message would be routed to the spam folder.  Something as simple as:

This would likely need some "Security Considerations" section about how informing a malicious entity may be undesirable.  I'm willing to write this up as a proposed draft, though I'm not entirely sure where to direct that draft.  Thank you for any advice you could provide.

Two things, one substantive and one procedural:
(1) On procedure: This might be better raised on either the SMTP mailing list or the ART mailing list.  DISPATCH is mostly for talking about live or proposed work items, like when there's a draft ready to bring to the table for disposition.

(2) On substance: Why not register an enhanced status code for this instead of a new SMTP reply code?  See https://www.iana.org/assignments/smtp-enhanced-status-codes/smtp-enhanced-status-codes.xhtml<https://urldefense.com/v3/__https:/www.iana.org/assignments/smtp-enhanced-status-codes/smtp-enhanced-status-codes.xhtml__;!!CQl3mcHX2A!QZTAt9Rk-meQu68EGjOK04SCXItePuipk4VkJXnY06PoqLxHr3flYy6-PsUqvno_cjMc$> and the RFC it references.

-MSK