Subject: [eppext] EPP Extension Registration Requests from DK-Hostmaster

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 9 Sep 2015 11:01:46 +0000

Yesterday I received 10 requests from IANA to review EPP extensions submitted by DK-Hostmaster. I'll forward each of them to this list momentarily. I've reviewed all of them and I'm going to suggest that they be considered as one request since each describes an element that is part of the same schema and the same specification.

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 9 Sep 2015 11:20:12 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Wednesday, September 09, 2015 7:02 AM
> To: [email-masked]
> Subject: [eppext] EPP Extension Registration Requests from DK-
> Hostmaster
> 
> Yesterday I received 10 requests from IANA to review EPP extensions
> submitted by DK-Hostmaster. I'll forward each of them to this list
> momentarily. I've reviewed all of them and I'm going to suggest that
> they be considered as one request since each describes an element that
> is part of the same schema and the same specification.

More detail:

The specification for each of the registration requests can be found here:

https://github.com/DK-Hostmaster/epp-service-specification

The current version of the schema can be found here:

https://github.com/DK-Hostmaster/epp-xsd-files/blob/master/dkhm-1.4.xsd

Each of the registration requests refers to an element that is defined in this schema:

<element name="userType" type="dkhm:userType" /> 
<element name="EAN" type="dkhm:EAN" /> 
<element name="CVR" type="dkhm:CVR" /> 
<element name="pnumber" type="dkhm:pnumber" /> 
<element name="contact" type="dkhm:contact" /> 
<element name="trackingNo" type="dkhm:trackingNo" /> 
<element name="domainAdvisory" type="dkhm:domainAdvisory" /> 
<element name="orderconfirmationToken" type="dkhm:orderconfirmationToken" /> 
<element name="domain_confirmed" type="dkhm:domain_confirmed" /> 
<element name="contact_validated" type="dkhm:contact_validated" /> 
<element name="registrant_validated" type="dkhm:registrant_validated" />

Each of these elements ultimately refers to an XML schema simpleType that includes a restriction for a base of type token. Based on my reading of the specification I believe the last three elements could be more efficiently represented as booleans, but what's there certainly works.

As I said in my first message in this thread I'd like to recommend to IANA that they process these requests as a single addition to the registry since each request describes an XML element that is part of the same schema and namespace. Could the other DEs please share your thoughts?

Scott

---

From: Ning Kong <[email-masked]>
Date: Tue, 15 Sep 2015 12:09:32 +0800

Hi folks,

I have completed my review of EPP Extension Registration Requests from DK-Hostmaster, and I have the following comments to share,
The <dkhm:CVR> and <dkhm:pnumber> are two elements related to VAT number. It seems that VAT number is a common need in a few registries, as the specification of .se also has VATNo EPP extension. 

Followings are the discussion posts related with VAT,
http://www.ietf.org/mail-archive/web/eppext/current/msg00557.html 
http://www.ietf.org/mail-archive/web/eppext/current/msg00558.html 
http://www.ietf.org/mail-archive/web/eppext/current/msg00560.html 

Since we already had some discussions on this issue, maybe continuing this work is valuable and necessary. IMO, it maybe make sense that we could define an EPP extension on VAT to fullfill most of the registries' requirements.

Cheers,
Ning

> 在 2015年9月9日，19:20，Hollenbeck, Scott <[email-masked]> 写道：
> 
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: Roger D Carney <[email-masked]>
Date: Mon, 21 Sep 2015 21:14:05 +0000

Good Afternoon,

I have completed my review of these extensions as DE and I have no significant comments. 

Minor comments:  
Generally speaking it would seem to be more readable if "like" examples used the same example data (e.g. create request uses dk-hostmaster-test-906.dk as the domain name but the create response uses domain1.dk)

It appears that many of the examples have not been updated to the latest version of the dkhm XSD (several references to 1.2 and 1.3)

Thanks
Roger

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck, Scott
Sent: Wednesday, September 09, 2015 6:02 AM
To: [email-masked]
Subject: [eppext] EPP Extension Registration Requests from DK-Hostmaster

Scott