Subject: [Gendispatch] New version of draft-kuehlewind-update-tag (-03) available

From: Suresh Krishnan <[email-masked]>
Date: Sun, 8 Nov 2020 23:02:53 -0500

Hi all,
  We have submitted a new version of our update tags draft and it is available at

https://www.ietf.org/archive/id/draft-kuehlewind-update-tag-03.txt <https://www.ietf.org/archive/id/draft-kuehlewind-update-tag-03.txt>

It contains changes to cover the feedback we have received on the earlier versions. We would greatly appreciate further comments on this new version of the draft. We are also working in parallel to come up with a quantitative assessment of the use of the update tag as some of the WG participants have requested. If we complete that in the next week or so, we would love to present the results at the gendispatch meeting.

Thanks
Mirja & Suresh

---

From: Joseph Touch <[email-masked]>
Date: Sun, 8 Nov 2020 21:05:19 -0800

> On Nov 8, 2020, at 8:02 PM, Suresh Krishnan <[email-masked]> wrote:
> 
> We are also working in parallel to come up with a quantitative assessment of the use of the update tag as some of the WG participants have requested.

 It seems odd that it’s taken 8 months and we still don’t have either an example where this level of nuance is needed nor the assessment above.

But until both are forthcoming, it seems premature to consider this further.

Joe

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 9 Nov 2020 08:49:33 -0500

Hi Joe,

> On Nov 9, 2020, at 12:05 AM, Joseph Touch <[email-masked]> wrote:
> 
> 
> 
>> On Nov 8, 2020, at 8:02 PM, Suresh Krishnan <[email-masked] <mailto:[email-masked]>> wrote:
>> 

Yes. It is very time consuming to go through 1000 RFCs to figure this out (which is what we are doing). Which is why we have not asked for adoption yet until that is done and discussed.

Thanks
Suresh

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 10 Nov 2020 09:04:08 +1300

Hi Suresh,

I'm still very supportive of this change. I'm not against getting some data,
but in my mind there is no doubt that this is a qualitative improvement,
regardless of what fraction of RFCs it affects.

One comment on the proposal:

> 4.1.  Discontinuation of the Use of Updates/Updated by
...
>    However, the Updates/Updated by tag pair will remain in existing
>    documents and there is no plans to change these metadata in order to
>    apply the new tags instead.  Any such change would require
>    changing/updating/amending the RFC carrying the "Updates" tag...

To be clear, "Updated by" (like "Obsoleted by") *never* appears in an RFC,
but only in their metadata. So we *do* already update the metadata of
an RFC when a new RFC updates (or obsoletes) it. Under the new plan,
we will amend the metadata when a new RFC amends, extends, "also sees"
or obsoletes it.

That being so, is there a good reason why we should not amend the
metadata of existing RFC pairs, without amending their text?

To be clear, I mean that we could make this change in the metadata
without changing either RFC:

OLD:

7050 Discovery of the IPv6 Prefix Used for IPv6 Address Synthesis. T.
     Savolainen, J. Korhonen, D. Wing. November 2013. (Format: TXT, HTML)
     (Updated by RFC8880) (Status: PROPOSED STANDARD) (DOI:
     10.17487/RFC7050) 

8880 Special Use Domain Name 'ipv4only.arpa'. S. Cheshire, D. Schinazi.
     August 2020. (Format: HTML, TXT, PDF, XML) (Updates RFC7050)
     (Status: PROPOSED STANDARD) (DOI: 10.17487/RFC8880) 

NEW:

7050 Discovery of the IPv6 Prefix Used for IPv6 Address Synthesis. T.
     Savolainen, J. Korhonen, D. Wing. November 2013. (Format: TXT, HTML)
     (Extended by RFC8880) (Status: PROPOSED STANDARD) (DOI:
     10.17487/RFC7050) 

8880 Special Use Domain Name 'ipv4only.arpa'. S. Cheshire, D. Schinazi.
     August 2020. (Format: HTML, TXT, PDF, XML) (Extends RFC7050)
     (Status: PROPOSED STANDARD) (DOI: 10.17487/RFC8880)

I think this would be useful. Whether it is worth the effort is a
separate question.

Regards
   Brian

On 09-Nov-20 17:02, Suresh Krishnan wrote:
> https://www.ietf.org/archive/id/draft-kuehlewind-update-tag-03.txt
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 10 Nov 2020 13:05:13 +0100

Hi Brian,

Thanks for your feedback!

The problem with your proposal below is that it is often not completely obvious which new tag should be used to replace is. And even though, there are a whole bunch of RFCs where it is obvious, I also wouldn’t want to change those without involving the authors/working group. So that’s after all quite a bit of effort and not sure if that’s worth it.

Mirja

> On 9. Nov 2020, at 21:04, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi Suresh,
> 
> -- 
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Nov 2020 08:41:48 +1300

> The problem with your proposal below is that it is often not completely obvious which new tag should be used to replace is. And even though, there are a whole bunch of RFCs where it is obvious, I a…

I agree about the effort needed to do this systematically. However, perhaps we could make it clear that such changes to metadata are allowed, in cases where there are good reasons to do it.

   Brian