Subject: [Ietf-and-github] Markdown add-on for Google Docs

From: Bret Jordan <[email-masked]>
Date: Mon, 30 Sep 2019 14:50:14 -0600

All,

I know many of you will not use this, but for those that like to write in markdown but use Google Docs to do so, I wrote an add-on [1] and published it in the G Suite Marketplace [2] to help make a few things a bit easier. 

Right now this add-on will enable you to add heading numbers and the markdown hash character to all of the document headings down to 6 levels deeps.  It will also generate a markdown table of contents (TOC) in your document (at the cursor location). So now the document can use the native or styled headings to make the document easier and prettier to read, but then still use markdown.  

The way I use this is:

1) Create a Google Doc for the work and share with people that are contributors / editors 
2) We write all of the content in markdown and make use of the comment / suggest features that are part of Google Docs.
3) Periodically I will update all of the headings and heading numbers and regenerate the TOC
4) At this point I publish a copy to GitHub. You can do this be exporting as plain-text or copy and paste-as-plain-text in your document that is in your Git repo.

Over time I may add additional features depending on what I find I need, or what others suggest. 

[1] - https://github.com/jordan2175/gdoc-markdown-tools <https://github.com/jordan2175/gdoc-markdown-tools>  
[2] - https://gsuite.google.com/marketplace/app/markdown_tools/788541604518 <https://gsuite.google.com/marketplace/app/markdown_tools/788541604518>

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

---

From: Warren Kumari <[email-masked]>
Date: Mon, 30 Sep 2019 17:08:33 -0400

> I know many of you will not use this, but for those that like to write in markdown but use Google Docs to do so, I wrote an add-on [1] and published it in the G Suite Marketplace [2] to help make a…

Thank you!

When installing this it says: "By clicking Continue, you acknowledge
that your information will be used in accordance with the [terms of
service] and [privacy policy] of this application." -- both links
simply go to the GitHub page. From a very quick skim of the code it
seems that all processing is done on the client side / nothing is sent
to you / outside servers, but I wanted to check. It might be worth
updating the GitHub to mention this if so...

Thanks again,
W

> [1] - https://github.com/jordan2175/gdoc-markdown-tools
> [2] - https://gsuite.google.com/marketplace/app/markdown_tools/788541604518
>
>
> Thanks,
> Bret
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Bret Jordan <[email-masked]>
Date: Mon, 30 Sep 2019 15:59:26 -0600

Yes, this all runs client side.  No information is collected by the add-on or shared by the add-on.  It all runs in your browser.   

I added a statement to the README for privacy to hopefully make this clear.  

Thanks,
Bret

> On Sep 30, 2019, at 3:08 PM, Warren Kumari <[email-masked]> wrote:
>

---

From: Warren Kumari <[email-masked]>
Date: Mon, 30 Sep 2019 18:07:12 -0400

Great, thanks!
W