Subject: [Ietf-and-github] Éric Vyncke's Abstain on draft-ietf-git-using-github-05: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Tue, 10 Mar 2020 04:02:01 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-git-using-github-05: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-git-using-github/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I abstain with the meaning of "I oppose this document but understand that
others differ and am not going to stand in the way of the others." per
https://www.ietf.org/standards/process/iesg-ballots/ as the main issue (see
below) cannot easily be fixed. I have also a couple of COMMENTs and I would
appreciate an answer to those COMMENTs even if you can freely ignore my main
ABSTAIN issue

Is there a reason why "GitHub" is used rather than simply "Git" or similar
system ? At least, it is explicit to be the commercial web site "github.com".
Alternatives such as GitLab and BitBucket are only briefly mentioned.

Section 1.3 has an amazing-to-my-eyes sentences "This document concentrates
primarily on GitHub as it has a large and active community of contributors.  As
a result, some content might not be applicable to other similar services.". In
my opinion, if the same reasoning was applied to other topics, the Internet
will become centralized into popular applications without innovation.

The document itself is clear, easy to read, and sensible except for the
overlapping content with the companion document.

Finally, the reason for my ABSTAIN ballot is that I cannot accept that an IETF
document in 2020 proposes to use an IPv4-only commercial web site (see also the
IAB statement https://www.iab.org/2016/11/07/iab-statement-on-ipv6 ). Let's eat
our own dog food. Why not having a git repo on the IETF servers?

-éric

PS: as a side note, I use daily the "git" tools sometimes for private use on
github.com but for professional use on a corporate-run git server.

--- Start of COMMENT ---

General comment: it appears that the two 'git' documents have very similar
content. Was it considered to better split them or merge them?

Section 3.2: a private repository is not free AFAIK with github.com. Which
party will pay for those repos ?

--- End of COMMENT ---

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 10 Mar 2020 23:02:41 +1100

Hi Éric,

I understand the reasons for your abstention.  I hope that these responses help, even if I'm guessing that they won't address your concerns.

> Alternatives such as GitLab and BitBucket are only briefly mentioned.

Because that is what people are using.  And we've seen significant payback from that.  Both in terms of using common - and therefore well-maintained - tools and in terms of accessing an existing community of contributors.

I personally do this in full appreciation for the drawbacks, both in terms of centralization and technology.  For the former, git is good about that, and we've a strategy (in -configuration primarily) for mitigating risks associated with centralization.  As for IPv6, I'm not prepared to stand on principle in this case, but respect the choice of others to do so.

FWIW, the alternatives are pretty good, and most have all of the same capabilities (some are even better in some ways).  Working groups probably won't suffer too badly for a choice of an alternative service.  But for me access to a wider community of contributors is - unfortunately - a determining factor.

> content. Was it considered to better split them or merge them?

This was debated at some length in the working group.  This one will end up having BCP status.  I suspect that the other will have less long-term utility as it is more tactical.
 
> party will pay for those repos ?

Private repositories are offered for free, with some limitations.  https://github.blog/2019-01-07-new-year-new-github/

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 10 Mar 2020 12:33:57 +0000

Hello Martin,

Thank you for respectfully understand my respectful disagreement with the document.

I understand the fine line to be drawn between the two documents. Not easy in general.

Finally, there is a limit of 3 contributors for a private repo, so, this will not fly in most cases.

Regards

-éric

-----Original Message-----
From: Martin Thomson <[email-masked]>
Date: Tuesday, 10 March 2020 at 13:03
To: Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Ietf-and-github] Éric Vyncke's Abstain on draft-ietf-git-using-github-05: (with COMMENT)

    Hi Éric,

---

From: Rob Sayre <[email-masked]>
Date: Wed, 11 Mar 2020 22:15:59 +1000

> Alternatives such as GitLab and BitBucket are only briefly mentioned.

The document is not about "Git" because the interesting parts are the web
services built around that version control system (issues, PRs, interactive
diffs, etc). There are competing services, but it would be difficult to
talk about them as a group without requiring them to be undifferentiated.

> will become centralized into popular applications without innovation.

IETF tools for producing documents are pretty specialized. I don't think
they've ever escaped on to the general Internet, except in cases where
other SDOs copy them.

thanks,
Rob