Subject: [Ietf-and-github] Mirja Kühlewind's Discuss on draft-ietf-git-github-wg-configuration-06: (with DISCUSS and COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Tue, 10 Mar 2020 03:30:37 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-git-github-wg-configuration-06: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

To be honest I don't fully understand the point of this document. It seem like
this document is supposed to be the basis for more discussion, however, I
thought that's what we have the wg for. So when and how do we come to a final
decision if we want to implement the proposed changes? And what would we do in
that case - take this document and republish? Why can't we make the decision
first and then publish something? In short, I think it would be important that
the document also describes what the next steps are and the triggers to move on!

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Other questions/comments:

1) Sec 2.3:
"There should likely be an API to specify that there were personnel changes."
Inline with the comment in the shepherd write-up, I find this sentence really
unclear. I'm not even sure where the API should be (datatracker or GitHub) and
what is should do?

2) Sec 2.5:
"Creating a new repository for an individual draft"
This section indicated that also individual drafts could be maintained within
the official wg organization. I'm not sure if that is practical or desirable:
Which individual docs should the chairs allow repos for and which not? There
can be quite a lot of draft in some groups.

3) Also sec 2.5:
"   As an incremental step, this document proposes that there be a
   facility in the Datatracker interface to allow an administrator of an
   ietf-wg-<wgname> organization to request the creation of a new
   repository within that organization for a single document."
For -00 version you usually want to have a repo before you submit it to the
datatracker. So a button on the datatracker page of the draft does not seems
too useful...

4) Sec 2.6:
"At the time of this writing this feature was under development."
Wasn't there always/for a long time already a feature where you can add link to
external pages?

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 10 Mar 2020 08:34:16 -0400

Hi Mirja,

> On Mar 10, 2020, at 6:30 AM, Mirja Kühlewind via Datatracker <[email-masked]> wrote:
> 
> decision if we want to implement the proposed changes?

This document specifies the administrative processes and conventions we will use. Further discussion of the changes (other than minor tweaks here and there) is not expected.

Best,
Alissa 

> And what would we do in

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 10 Mar 2020 13:51:31 +0100

Hi Alissa,

This is not what the document says here (and also in the abstract):

"   The document is meant to spur discussion in the IETF community.  If
   there proves to be rough consensus in the community in support of the
   proposals in this document, the functional requirements would need to
   be discussed with the IETF Tools Team and the IETF Secretariat, who
   would need to support various pieces of what is proposed herein.”

Or should this have been removed? 

Is the intention to let the secretariat provide these function on publication? If so, we should probably request changes to the tool team before publication…?

Maybe it is more appropriate to not discuss the tooling issue and concrete datatracker change in the RFC-to-be but only document the process as to be performed by the chairs and secretariat?

Mirja

> On 10. Mar 2020, at 13:34, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Mirja,
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 10 Mar 2020 08:55:07 -0400

> On Mar 10, 2020, at 8:51 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Alissa,
> 

Yes, sorry for not catching that. I think we can just remove this.

> Is the intention to let the secretariat provide these function on publication? If so, we should probably request changes to the tool team before publication…?

Yep, the tools team is already working on this and the secretariat is aware.

Thanks,
Alissa

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 10 Mar 2020 14:00:57 +0100

Okay, thanks for clarifying this. However this status and intention is not well reflected in the current text in the document and I think a revision is needed to avoid confusion. It's not only the paragraph below but also other parts, especially where it talks about options to ingrate in the datatracker.

Also if this document is meant document the practice as to be applied, it should also be BCP and use normatively language. But then probably most of the text in draft-ietf-git-using-github in section 2 (and some of section 3) could be moved into this document because otherwise we will end up having this specified normatively twice.

Mirja

> On 10. Mar 2020, at 13:55, Alissa Cooper <[email-masked]> wrote:
> 
> 
>

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 11 Mar 2020 20:36:18 +0000

Catching up on the rest of Mirja's comments (not already discussed on this thread)

We will change "API" to "ability in the Datatracker".

>>> can be quite a lot of draft in some groups.

Some chairs have indicated it is desirable, so the WG thought it should be possible.

>>> datatracker. So a button on the datatracker page of the draft does not seems

Document authors can tell the WG chairs that they intend to create a new WG draft. If that happens, the WG chair creates the repo with either the intended draft name or something semantically relevant, and tells the document authors before they turn in the -00. (I think this has already happened in some WGs...)

>>> Wasn't there always/for a long time already a feature where you can add link to

This is currently true for chairs for their WGs, but not for authors in their document page.

--Paul Hoffman

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 12 Mar 2020 08:37:17 -0400

Hi Mirja,

> On Mar 10, 2020, at 9:00 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 

Paul has made these changes: https://github.com/ietf-gitwg/draft-ietf-git-github-wg-configuration/pull/16/files

> Also if this document is meant document the practice as to be applied, it should also be BCP and use normatively language. But then probably most of the text in draft-ietf-git-using-github in secti…

The sentiment on draft-ietf-git-using-github seems to be leaning towards informational, so I think it’s better to keep both of them informational.

Alissa

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Mar 2020 13:47:51 +0100

Hi Alissa, hi Paul

> On 12. Mar 2020, at 13:37, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Mirja,
> 

Thanks for this change but I think there would be more. First I suggest to also remove the pointer in the abstract for list discussion (but I guess that could also be done by the RFC editor but as you do edits anyway). But then there are also more things that could be clarified, e.g.sentences like

"This document proposes that there be a facility in the IETF Datatracker… "

Sentences like this makes it difficult to understand what this document actually only “proposes” and what’s the process that is specified that will be applied in future. As I said earlier, tying this documents and its procedures too close to what is offered in the datatracker makes it unclear. Maybe you can sepcify the processes (normatively) first without relating it to any interface or function in the datatracker and then later have a section to described that would be needed in the datatracker to support this process (maybe even in the appendix) or even better wait until the datatracker changes are implemented and then publish this document (because that will age much better).

> The sentiment on draft-ietf-git-using-github seems to be leaning towards informational, so I think it’s better to keep both of them informational.

draft-ietf-git-using-github is BCP. And it has a lot of normative text in it (mainly section 2 and some parts in 3 as well) that is fully redundant with content of this draft.

Mirja

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Mar 2020 14:49:29 +0100

Hi Paul,

See inline.

> On 11. Mar 2020, at 21:36, Paul Hoffman <[email-masked]> wrote:
> 
> We will change "API" to "ability in the Datatracker”.

I’m still not sure what exactly is needed here? Can you maybe explain what the idea is?

> Some chairs have indicated it is desirable, so the WG thought it should be possible.

Yes, I think this is a discussion for the other git draft.

> Document authors can tell the WG chairs that they intend to create a new WG draft. If that happens, the WG chair creates the repo with either the intended draft name or something semantically relevant, and tells the document authors before they turn in the -00. (I think this has already happened in some WGs…)

That's fine. But the cited text talks about a datatracker interface for that. Not sure if that is the right approach.

> This is currently true for chairs for their WGs, but not for authors in their document page.

It was not clear to me that this was intended on the document level. I think that should be clarified. How would that look like? Authors can add a GitHub repo name or just any URL? Not sure if authors should do that or only chairs on a per-document basis; might be different for individual drafts and wg documents.

Thanks!
Mirja

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 12 Mar 2020 15:29:32 +0100

Hi,

Please allow me to insert a comment.

Other questions/comments:
>>>>> 
>>>>> 1) Sec 2.3: "There should likely be an API to specify that
>>>>> there were personnel changes." Inline with the comment in the
>>>>> shepherd write-up, I find this sentence really unclear. I'm
>>>>> not even sure where the API should be (datatracker or GitHub)
>>>>> and what is should do?
>> 

I wonder the same thing, and I would like to know?

 From my side, as an user of github and xml2rfc.tools.ietf.org I often
need less independent disconnected tools, or more interconnected tools
that present a unique entry point to me.

I would have liked, for example, a button called 'Compile' and a button
called 'Submit to IETF' on the github GUI for an xml source.  That could
be achieved if there were a tight interface (an API maybe) between
github.com and xml2rfc.tools.ietf.org.

If we talk about a github.tools.ietf.org website, then there would still
be a need of an interface between github and xml2rfc, and it might be
easier to realize than if it were on github.com.

In that latter case, if that interface is on IPv6, then it would be fine.

But these are my thoughts.  I do wonder about the answer to the question
you raised.

Alex
> 
>> 
>>>>> 
>>>>> 2) Sec 2.5: "Creating a new repository for an individual
>>>>> draft" This section indicated that also individual drafts
>>>>> could be maintained within the official wg organization. I'm
>>>>> not sure if that is practical or desirable: Which individual
>>>>> docs should the chairs allow repos for and which not? There 
>>>>> 3) Also sec 2.5: "   As an incremental step, this document
>>>>> proposes that there be a facility in the Datatracker
>>>>> interface to allow an administrator of an ietf-wg-<wgname>
>>>>> organization to request the creation of a new repository
>>>>> within that organization for a single document." For -00
>>>>> version you usually want to have a repo before you submit it
>>>>> to the datatracker. So a button on the datatracker page of
>>>>> the draft does not seems too useful...
>> 
>> Document authors can tell the WG chairs that they intend to create
>> a new WG draft. If that happens, the WG chair creates the repo with
>> either the intended draft name or something semantically relevant,
>> and tells the document authors before they turn in the -00. (I
>> think this has already happened in some WGs…)
> 
> That's fine. But the cited text talks about a datatracker interface
> for that. Not sure if that is the right approach.
> 
>> 
>>>>> 
>>>>> 4) Sec 2.6: "At the time of this writing this feature was
>>>>> under development." Wasn't there always/for a long time
>>>>> already a feature where you can add link to external pages?
>> 
> It was not clear to me that this was intended on the document level.
> I think that should be clarified. How would that look like? Authors
> can add a GitHub repo name or just any URL? Not sure if authors
> should do that or only chairs on a per-document basis; might be
> different for individual drafts and wg documents.
> 
> Thanks! Mirja
> 
> 
> 
>> 
>> --Paul Hoffman
> 
> _______________________________________________ Ietf-and-github
> mailing list [email-masked] 
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: Barry Leiba <[email-masked]>
Date: Fri, 20 Mar 2020 10:56:35 -0400

Where are we on this DISCUSS?

Barry

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 20 Mar 2020 16:56:00 +0100

I thought Alissa said that they want to update but not before after the IETF-107 week…

> On 20. Mar 2020, at 15:56, Barry Leiba <[email-masked]> wrote:
>

---

From: Barry Leiba <[email-masked]>
Date: Fri, 20 Mar 2020 12:20:42 -0400

Ack; thanks.

b