Subject: [Ledger] Blog post explaining "What is Interledger?"

From: Evan Schwartz <[email-masked]>
Date: Wed, 3 Oct 2018 08:32:01 -0400

A number of people commented that we need more documents that give a simple overview of what Interledger is. Vanessa Pestritto and I put together this post to explain a bit about the network and some of the key features of the protocol:

Interledger (https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543): (https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543) How to Interconnect All Blockchains and Value Networks (https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543)
If you could help share it around, it would be much appreciated!
Comments and questions are welcome, as always. This should also be one of many posts detailing various parts of the Interledger vision/tech/impact (so you should also feel free to write up your perspective on it)!
Evan

---

From: David Nicol <[email-masked]>
Date: Wed, 10 Oct 2018 13:24:19 -0500

Good introduction! I'm writing to propose a copy-edit.

Only the receiver could generate the correct proof, which is a simple
preimage of a hash.

"simple preimage of a hash" is jargon and in this introductory document may
easily get misconstrued as obfuscatory mumbo-jumbo.

I recommend either dropping the clause or replacing it with a full-on,
repeatable, hand-wave indirection such as

Only the receiver can generate the correct proof, using established
cryptographic principles.

On Wed, Oct 3, 2018 at 7:34 AM Evan Schwartz <[email-masked]> wrote:

> A number of people commented that we need more documents that give a
> simple overview of what Interledger is. Vanessa Pestritto and I put
> together this post to explain a bit about the network and some of the key
> features of the protocol:
>
> Interledger
> <https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543>
> :
> <https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543>
> How to Interconnect All Blockchains and Value Networks
> <https://medium.com/xpring/interledger-how-to-interconnect-all-blockchains-and-value-networks-74f432e64543>
>
> Comments and questions are welcome, as always. This should also be one of
> many posts detailing various parts of the Interledger vision/tech/impact
> (so you should also feel free to write up your perspective on it)!
>
> Evan
>

-- 
"I don't know about that, as it is outside of my area of expertise." --
competent specialized practitioners, all the time

---

From: David Nicol <[email-masked]>
Date: Wed, 10 Oct 2018 13:47:09 -0500

After reviewing the current protocol a spot,

executionCondition UInt256 SHA-256 hash digest of the fulfillment that will
execute the transfer of value represented by this packet. Connectors MUST
NOT modify this field. The receiver must be able to fulfill this condition
to receive the money.

maybe "Only the receiver can demonstrate knowledge of the secret,
previously shared with the sender, that allows all stages of the
transaction to complete."

I didn't notice while reading the article that it says anywhere that the
receiver has to somehow share a per-transaction secret with the sender,
before the sender invokes ILP.

---

From: David Nicol <[email-masked]>
Date: Wed, 10 Oct 2018 20:17:09 -0500

that it works with shared secrets instead of asymmetric crypto was news to
me.

On Wed, Oct 10, 2018 at 2:13 PM Giovanni P <[email-masked]> wrote:

> I think everybody knows what a hash is, but "preimage" is a little
> more advanced/obscure.
>
> "established cryptographic principles" is much more mumbo-jumbo than
> saying "hash".
>
> If the idea is to gather interest among developers and insiders it
> makes more sense to say more about how it works than to just drop
> magical words.
>
> Actually, I think even normal people are sick of hearing magical
> words: "oh, this works and does amazing stuff because cryptography!",
> there are thousands of claims like that everywhere and most are false,
> so actually saying Interledger is simple, it's not magic, you can
> understand it, it just happens to be clever with simple principles --
> that can have a lot of appeal.
>
> On 10/10/18, David Nicol <[email-masked]> wrote:

---

From: David Nicol <[email-masked]>
Date: Thu, 18 Oct 2018 10:13:09 -0500

how about calling the preimage a "per-transaction password" and say
"one-way hash function" to avoid confusion with signatures?

---

From: Evan Schwartz <[email-masked]>
Date: Tue, 30 Oct 2018 12:29:18 -0400

I see pros and cons to both ways of describing the hash and preimage. I'm always unsure with these pieces what level of technical detail to include or what level of knowledge to assume.

Re: sharing secrets. The hash and preimage are effectively ways to authenticate the ILP packet and response and make sure it got to the right recipient. Originally, we thought that the sender and receiver would exchange the condition out of band for each packet, but that doesn't work well with the streaming payments or packetized value model. Exchanging a shared secret up front allows you to authenticate any number of subsequent packets.
STREAM assumes you start with a shared symmetric key but it doesn't specify how you get that. In practice, most higher-level protocols will use public key cryptography to generate that shared secret, whether that means going through the internet and TLS (like SPSP does) or doing the key exchange through ILP.
On Oct 18 2018, at 11:13 am, David Nicol <[email-masked]> wrote:
>
>
>
> how about calling the preimage a "per-transaction password" and say "one-way hash function" to avoid confusion with signatures?
>
> >
> > On Wed, Oct 10, 2018 at 2:13 PM Giovanni P <[email-masked] (mailto:[email-masked])> wrote:
> "I don't know about that, as it is outside of my area of expertise." -- competent specialized practitioners, all the time
>
>
>
>