Subject: Re: [Ledger] Researching to leverage Hashed-Timelock Agreements (HTLAs) paradigm for establishing atomicity between different DLT networks for asset swaps with full decentralization

From: Evan Schwartz <[email-masked]>
Date: Wed, 7 Nov 2018 13:58:27 -0500

Hi Nathan,

Do you need that whole transaction to happen atomically or for the balances to just end up that way? Also, do you need every party to maintain their own view of the state of the balances, or is there a single central party that could track them?
On Nov 7 2018, at 9:03 am, Nathan Aw <[email-masked]> wrote:
>
> Hi Evan,
>
> I came up with a gridlock diagram/scenario to illustrate what I wish to hope to solve (or perhaps build) with interledger. Please refer to the gridlock diagram below. Since interledger is the routing layer/network, the gridlock mechanism is something that will be extremely relevant. This mechanism will be a game-changer -- any thoughts/inputs, please?
>
>
>
> Regards,
>
> Nathan Aw
> https://www.linkedin.com/in/awnathan/
> https://datatracker.ietf.org/meeting/103/materials/slides-103-dinrg-decentralized-identity-00
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> On Sun, Oct 14, 2018 at 12:22 AM Evan Schwartz <[email-masked] (mailto:[email-masked])> wrote:
> > The same construction can be used no matter what the underlying assets are. They can be cryptocurrencies, fiat currencies, shares of stock or other divisible assets.
> >
> > If you want to use this method for a swap you can send a "payment" from one of your accounts to another.
> > On Sat, Oct 13, 2018, 8:27 AM Nathan Aw <[email-masked] (mailto:[email-masked])> wrote:
> > > Hi all,
> > >
> > > Second try. Thank you.
> > >
> > > I am a blockchain engineer based out of Singapore working at a leading bank in ASEAN.
> > >
> > > I am looking to leverage the Hashed-Timelock Agreements (HTLAs) paradigm for establishing atomicity between different DLT networks for asset swaps to achieve cross border payments with partial to full decentralization in mind.
> > >
> > > With the goal in mind, I like to understand technically how can this paradigm be applied to achieve payment vs payment (pvp) with semi-trusted nodes such as clearinghouses, banks and individual players? Applying the same concept of a crypto swap between ETH and BTC, the same can be applied between SGD and HKD?
> > >
> > > Also, I hope to understand the models around how liquidity can be maintained between these nodes?
> > >
> > > Regards,
> > >
> > > Nathan Aw
> > > https://sg.linkedin.com/in/awnathan
> > >
> > >
> > > https://erc725alliance.org/
> > >
> > >
> > >
> > > On Sat, Oct 13, 2018 at 12:39 AM Nathan Aw <[email-masked] (mailto:[email-masked])> wrote:
> > > > Hi all,
> > > >
> > > > I am a blockchain engineer based out of Singapore working at a leading bank in ASEAN.
> > > >
> > > > I am looking to leverage the Hashed-Timelock Agreements (HTLAs) paradigm for establishing atomicity between different DLT networks for asset swaps to achieve cross border payments with partial to full decentralization in mind.
> > > >
> > > > With the goal in mind, I like to understand technically how can this paradigm be applied to achieve payment vs payment (pvp) with semi-trusted nodes such as clearinghouses, banks and individual players? Applying the same concept of a crypto swap between ETH and BTC, the same can be applied between SGD and HKD?
> > > >
> > > > Also, I hope to understand the models around how liquidity can be maintained between these nodes?
> > > >
> > > > Thank you!
> > > >
> > > > Regards,
> > > >
> > > > Nathan Aw
> > > > https://sg.linkedin.com/in/awnathan
> > > >
> > > > https://erc725alliance.org/
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > >
> > >
> > >
> > >
> >
> >
> >
> >
>
>
>

---

From: David Nicol <[email-masked]>
Date: Wed, 7 Nov 2018 13:08:11 -0600

this may or may not assist, but I see multi-party transactions as something
that should be set up by defining a light-weight entity to represent the
transaction, which receives all the inputs (including proofs of completion,
for contract payment proxy kinds of applications) and then disburses the
inputs after it has everything. In the event that you don't want your funds
tied up in multiple pending smart-contract objects that aren't going to get
disbursed until well into the future, well that's where banking as such
comes into play, isn't it.

-- 
"I don't know about that, as it is outside of my area of expertise." --
competent specialized practitioners, all the time