Subject: [Ledger] Errors in the document https://interledger.org/rfcs/0030-notes-on-oer-encoding/#what-is-oercanonical-oer

From: "Bruno Konik" <[email-masked]>
Date: Tue, 7 May 2019 16:19:27 +0200

Hello,

I would like to make remarks about this doc
(https://interledger.org/rfcs/0030-notes-on-oer-encoding/#what-is-oercanonic
al-oer).

There are errors of how integers are encoded in COER in the examples :

In Fixed-length signed integers chapter :

Type

Bytes

Decoded value

Int8

00

0

Int8

7F

127

Int8

80

-1 
IT IS "-128" !

Int8

FF

-128
IT IS "-1" !

Int16

7FFF

32767

Int16

FC00

-1024

Int16

CFC7

-12345

Int32

0C00F5C9

201389513

Int32

F204BA10

-234571248

Int64

7FFFFFFF FFFFFFFF

9223372036854775807

Int64

EF68FE12 0BC51AD7

-8027945689248242392
IT IS "-1195426347606533417L" ! The encoding of "-8027945689248242392" is
909701ED F43AE528  

I hope that my email will reach someone who can handle the above remark.
Thank you very much for taking it in consideration.

Best Regards,

Bruno KONIK
 <http://www.unigone.com/> 

4 route de la Noue

91 190 Gif sur Yvette

+33(0)160127764 / +33(0)169419619

http://www.unigone.com <http://www.unigone.com/>

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Thu, 9 May 2019 11:19:35 +0200

Hi Bruno,

Thanks for this. I am looking into the corrections and will revert.

Adrian

On Tue, 7 May 2019 at 16:24, Bruno Konik <[email-masked]> wrote:

> Hello,
>
>
>
> I would like to make remarks about this doc (
> https://interledger.org/rfcs/0030-notes-on-oer-encoding/#what-is-oercanonical-oer
> ).
>
>
>
> *Type*
> *Bytes*
> *Decoded value*
> *IT IS “-128” !*
> *IT IS “-1” !*
> *IT IS* “-*1195426347606533417L” ! The encoding of “*-8027945689248242392”
> *is 909701ED F43AE528*
>
>
>
> *Bruno KONIK* <http://www.unigone.com/>
>
> 4 route de la Noue
>
> 91 190 Gif sur Yvette
>
> http://www.unigone.com
> _______________________________________________
> Ledger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledger
>