Subject: Re: [lisp] (#11) Do we still have a reason to ignore non-zero UDP checksums?

From: [email-masked] (Noel Chiappa)
Date: Tue, 25 Aug 2009 12:50:40 -0400 (EDT)

> From: Marshall Eubanks <[email-masked]>

    >> Darrel is unaware of NATs that replace 0 UDP checksums with invalid
    >> UDP checksums

In other words, 'Darrel does not know of any NATs which replace 0 UDP
checksums with invalid UDP checksums'.

    > This is clearly not a protocol compliant behavior. ...
    > (1) Decide that it is not that important for LISP to work across those
    > buggy NAT boxes
    > As for what to do with incorrect buggy NAT checksums

_As far as we know_, there are no buggy NAT checksums.

	Noel

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 25 Aug 2009 13:00:45 -0400

> _As far as we know_, there are no buggy NAT checksums.

Yes, I caught that from the recent discussion (and, obviously, that's  
a Really Good Thing). My point was,
_even if some are found_, they shouldn't drive the protocol work.

Regards
Marshall