Subject: Re: [lisp] Mobile LISP

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 19 Aug 2009 17:36:52 +0200

John Zwiebel a écrit :
> 
> On Jul 24, 2009, at 12:50 AM, Flinck, Hannu (NSN - FI/Espoo) wrote:
> 
>> 
>> I was wondering if you considered just having a mobile ip homeagent
>> 
>> 
>> within a LISP site.
>> 
> 
> Then it would be the same a the current mobile IP.  No gain.

Sorry, late reply.  After reading the LISP and LISP-MN drafts I can't
say that a pure LISP Mobile Node has any advantage over Mobile IP.

I can understand the ossified Internet shortcomings that LISP addresses
but I don't see the Mobile IP shortcomings that LISP-MN addresses.

Worse, LISP-MN seems to always employ encapsulation and triangular
routing, whereas Mobile IPv6 has some ways out of it.

About the initial suggestion of H. Flinck - putting a HA in a LISP site 
- I think this case is described in the LISP draft-03 section 10.3, 
where is dscribed the use of Mobile IP[v6] simultaneously with LISP ITR 
and ETR.  The section is not clear completely, I could remark on it 
separately.

Alex

> 
> 
> ------------------------------------------------------------------------
> 
> 
> _______________________________________________ lisp mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/lisp

---

From: "John Zwiebel (jzwiebel)" <[email-masked]>
Date: Wed, 19 Aug 2009 21:00:30 -0700

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]]
Sent: Wed 8/19/2009 8:36 AM
To: John Zwiebel (jzwiebel)
Cc: Flinck, Hannu (NSN - FI/Espoo); [email-masked]
Subject: Re: [lisp] Mobile LISP
 
John Zwiebel a écrit :

<z> Your "seems to" is mistaken.
<z> The call set up may require triangular routing
<z> but once each MN has the local RLOC, all 
<z> communication is direct between MNs

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 20 Aug 2009 10:30:12 +0200

> <z> communication is direct between MNs

John - but once the local RLOC is selected, thus allowing for direct 
communication, there is always LISP encapsulation, right?

Alex

---

From: "John Zwiebel (jzwiebel)" <[email-masked]>
Date: Thu, 20 Aug 2009 14:53:25 -0700

Alex

<z> yes