Subject: Re: [lisp] LISP (re-)Charter discussion

From: Luigi Iannone <[email-masked]>
Date: Tue, 1 Nov 2011 09:42:57 +0100

Hi,

On Nov 1, 2011, at 00:57 , Jari Arkko wrote:

> Yakov,
> 
>> Furthermore, as John Scudder asked in his e-mail on 9/28, "the base
>> spec calls out a number of areas that require more experimentation.
>> A simple grep will find these. These experiments and what has been
>> learned from them should be documented.  The same applies if other
>> specs have similar caveats (I just haven't looked for them)."
>> The charter needs to explicitly include in the Goals and Milestones
>> the document(s) that cover this.
>> 
> 
> I would love to see documents in the charter that describe experiences from simulation/implementation/measurement/real-world use, and shed light on these issues.
> 

There are a bunch of research papers out there that are interesting for the WG. Would it make sense to create kind of an informational document with pointers to the papers and a summary of the main results?

Or you are suggesting a different document for each open issue?

Luigi

> Jari
> 
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: John Scudder <[email-masked]>
Date: Fri, 4 Nov 2011 13:24:57 -0700

Terry,

The end of the charter says:

On Oct 19, 2011, at 7:23 PM, Terry Manderson wrote:

> It is expected that the results of specifying, implementing, and testing
> LISP will be fed to the general efforts at the IETF and IRTF (e.g., the
> Routing Research Group) that attempts to understand which type of a
> solution is optimal. 

...

> In addition, as these issues are understood, the
> working group will analyze and document the implications of LISP on
> Internet traffic, applications, routers, and security. This analysis
> will explain what role LISP can play in scalable routing. The analysis
> should also look at scalability and levels of state required for
> encapsulation, decapsulation, liveness, and so on as well as the
> manageability and operability of LISP.

These seem to suggest two or more additional milestones, along the general lines of

- Summarize results of specifying, implementing, and testing LISP and forward to IESG and/or IRTF.

and

- Analyze and document the implications of LISP on etc etc and explain blah blah.  Forward to IESG for publication.

(This partly echoes Yakov's earlier comment.)

Regards,

--John

---

From: John Scudder <[email-masked]>
Date: Fri, 4 Nov 2011 13:25:00 -0700

> Or you are suggesting a different document for each open issue?

(I can't speak for Jari of course, but...)

I'm not fussed about how many documents are produced.  What I do think is desirable is to close the open issues in some way.  This could be in an omnibus document that cites other papers as you describe, or separately.  The main thing would be to allow the reader to relate a given "needs experimentation" placeholder to the experimental results and conclusion.  I think this can be phrased broadly enough in the list of milestones that it doesn't tie the hands of the chairs in deciding what documents to produce.

I also expect that as issues are resolved, it would make sense to update the base spec wherever there's now a "needs experimentation" placeholder.  In fact, that could be an explicit goal and milestone of its own.  

--John

---

From: Terry Manderson <[email-masked]>
Date: Sun, 6 Nov 2011 17:50:49 -0800

Thanks John,

I'll include that milestone.

Cheers
Terry