Subject: [lisp] Fwd: decentralization of Internet (was Re: Bruce Schneier's Proposal to dedicate November meeting to saving the Internet from the NSA

From: Roger Jørgensen <[email-masked]>
Date: Sat, 7 Sep 2013 12:30:20 +0200

forward from a discussion on ietf@

---------- Forwarded message ----------
From: Roger Jørgensen <[email-masked]>
Date: Sat, Sep 7, 2013 at 12:30 PM
Subject: Re: decentralization of Internet (was Re: Bruce Schneier's
Proposal to dedicate November meeting to saving the Internet from the
NSA
To: Noel Chiappa <[email-masked]>, IETF Discussion <[email-masked]>

On Sat, Sep 7, 2013 at 5:05 AM, Noel Chiappa <[email-masked]> wrote:
>     > From: Scott Brim <[email-masked]>
>
>     > The encapsulation is not much of an obstacle to packet examination.
>
> There was actually a proposal a couple of weeks back in the WG to encrypt all
> traffic on the inter-xTR stage.
>
> The win in doing it in the xTRs, of course, is that you don't have to go
> change all the hosts, application by application: _all_ traffic, of any kind,
> from that site to any/all other sites which are encryption-enabled, will get
> a certain degree of confidentiality.
>
> Does this count as something the IETF can do reasonably quickly that will
> help somewhat? :-)

One easy fix then would be to have a MUST encrypt traffic between
xTRs, and that the encryption used MUST be strong. Are LISP@WG up for
the challenge? :-)

The userbase and deployment are relative small atm so it's doable to
get fast deployment to.

--

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

-- 

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: [email-masked] (Noel Chiappa)
Date: Sat, 7 Sep 2013 08:36:16 -0400 (EDT)

> From: =?ISO-8859-1?Q?Roger_J=F8rgensen?= <[email-masked]>

    > The userbase and deployment are relative small atm so it's doable to

Alas, now that I think about the practicalities.... I don't think the average
router has enough spare computing power to completely encrypt all the traffic.

Whether or not encrypting just the source+dest addresses, and the sort+dest
port (conviently next to each other in one block) is enough to do much good,
and if the average router has enough spare crunch to do even that, is a good
question.

	Noel

---

From: [email-masked] (Noel Chiappa)
Date: Sun, 8 Sep 2013 09:58:04 -0400 (EDT)

> Isn't the payload the important part to protect?

Ecrypting only the headers was a suggestion for the case where the routers
don't have enough spare crunch to encrypt the entire payload of every packet.

Whether that would do anything useful, or whether analysis of the payload
could bypass that, making that limited step useless, I don't know.

	Noel

---

From: [email-masked] (Noel Chiappa)
Date: Sun, 8 Sep 2013 16:20:14 -0400 (EDT)

> From: Edward Lopez <[email-masked]>

    > I agree that asymmetric encryption may be more desirable in theory, but
    > in practice symmetric encryption supports much higher performance loads

Use asymmetric encryption to exchance symmetric keys, switch to a new
symmetric key every X hours, and throw away the old one. (You don't want to
use one key for too much traffic, anyway.)

	Noel