Subject: Re: [lisp] WG Last Call on draft-lisp-introduction-07

From: Ronald Bonica <[email-masked]>
Date: Fri, 7 Nov 2014 20:13:14 +0000

Folks,

Version 07 of this draft is vastly improved over Version 03. Thanks for this good work!

However, Version 07 of this document ignored much of the input offered on version 05.  Therefore, it is not ready for submission to the IESG.

The following are areas that still remain to be addressed:

Section 1:

-          Although Section 1 talks around the issue, it does not explicitly state the degree to which LISP decouples locator semantics from identifier semantics. This could probably be remedied with a short bullet list. The list should include statements like the following:

o   RLOCs have meaning only in the underlay network

o   EIDs have meaning only in the overlay network, unless they are leaked into the underlay network

o   The LISP edge (xTR) maps EIDs to RLOCS

o   Within the underlay network, RLOCs have both locator and identifier semantics

o   An EID within a LISP site carries both identifier and locator semantics to other nodes within that site

o   An EID within a LISP site carries identifier and limited locator semantics to nodes at other LISP sites (i.e., enough locator information to tell that the EID is external to the site)

o   The relationship described above is not unique. L3VPN relationships maintain the same relationship between IPv4VPN addresses and IP addresses
Section 3.1:

-          Section 3.1 fails to mention that LISP does not maintain isolation between the forwarding and control planes. (That is, in LISP, forwarding plane activity routinely causes activity on the control plane). This omission is serious in itself. However, Section 3.1 amplifies the seriousness of this claim by stating that LISP decouples the forwarding and control planes.

-          Section 3.1 fails to mention LISP's most salient characteristics. These are:

o   That the ITR maintains only a subset of the mapping table

o   That the ITR does not maintain a "default mapping" (i.e., a mapping to a hub that would forward all otherwise unmapped traffic)

o   That the ITR pulls routes. This is to be contrasted with a push model (e.g. BGP without ORF) and a push-pull model (BGP with ORF)

Section 4.1
The benefit of maintaining only a subset of the mapping table is that you conserve memory on the XTR. However, this benefit is tempered. When a XTR requests a mapping for an EID, it must receive the most specific mapping for that EID plus all mappings that are covered by that mapping.

A consequence of not maintaining a default route is that an ITR will drop the first few packets destined to a prefix.

Also as a consequence of the pull model, LISP requires additional protocol support to solve the problem of mapping staleness. In order to address this problem, the ITR refreshes routes periodically. However, there is a tradeoff. If the xtr refreshes routes too frequently, it burdens the control plane. If it does not refresh routes frequently enough, forwarding suffers. In order to solve this problem, the LISP forwarding plane provides feedback to the control plane. Processing this feedback consumes computational resources. It also presents security issues that may prevent the feedback mechanism from being deployed on the global Internet.

Section 4.2:
A consequence of the pull model is that LISP requires additional protocol support to solve the problem of ETR liveness. This protocol support can take the form of feedback from the forwarding plane or ETR probing. For security reasons, forwarding plane feedback mechanisms must be disabled when LISP is deployed on the global Internet. Therefore, LISP becomes increasingly dependent upon ETR probing, which may not scale well

Section 3.5:

-          Section 3.5 should mention how PITRs will impact the size of global routing tables during the LISP transition period, particularly of EIDs cannot be aggregated before advertisement by the PITR

Section 7:

-          Section 7 should probably be the security considerations section.

Section 8.2 and 8.3:

-          LISP supports IPv6 transitions and VPN not because of the architectural characteristics that are unique to LISP, but because of the architectural characteristics that it shares with many other solutions. While it may support IPv6 transitions and VPN, it may not do so as well as existing solutions.

-
                                                                                             Ron

From: lisp [mailto:[email-masked]] On Behalf Of Luigi Iannone
Sent: Saturday, October 25, 2014 8:04 AM
To: LISP mailing list list
Cc: Damien Saucez
Subject: [lisp] WG Last Call on draft-lisp-introduction-07

All,

A lot of work has been done lately on draft-ietf-lisp-introduction-07 and the authors requested a work group last call.

This email starts a WG last call, to end November 14th, 2014.

You will find the document here:
http://tools.ietf.org/html/draft-ietf-lisp-introduction-07

Please review this WG document.  Let the working group know if you agree that it is ready for handing to the AD, or if you see issues with it.
If you see issues, please be as specific as possible about the problems, and if possible suggest text to resolve them.

Joel & Luigi

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 7 Nov 2014 17:05:39 -0800

> o   The relationship described above is not unique. L3VPN relationships maintain the same relationship between IPv4VPN addresses and IP addresses

Ron, this is going to confuse matters more than help. Especially in an introduction document. Plus, the statements you make can be very argumentative and quite possibly not true.

> -          Section 3.1 fails to mention LISP’s most salient characteristics. These are:

The document says there is an on-demand cache.

> o   That the ITR does not maintain a “default mapping” (i.e., a mapping to a hub that would forward all otherwise unmapped traffic)

Yes, it can. So you don't want to mislead anyone. What is returned (or configured) can be any length prefix from /0 to /n.

> o   That the ITR pulls routes. This is to be contrasted with a push model (e.g. BGP without ORF) and a push-pull model (BGP with ORF)

Why does it have to be contrasted?

> Section 4.1
> The benefit of maintaining only a subset of the mapping table is that you conserve memory on the XTR. However, this benefit is tempered. When a XTR requests a mapping for an EID, it must receive the most specific mapping

You should not judge the benefit.

> for that EID plus all mappings that are covered by that mapping.

We should say a longest match lookup is done, but again, that is detail that may raise more questions than help.

> A consequence of not maintaining a default route is that an ITR will drop the first few packets destined to a prefix.

But it can store a default route and many implementations do so.

> Also as a consequence of the pull model, LISP requires additional protocol support to solve the problem of mapping staleness. In order to address this problem, the ITR refreshes routes periodically…

You are starting to get defensive in your comments. This is not suppose to be "this is an intro to LISP and watch out how it can hurt you".  ;-)  Airplanes a very useful machines and they can hurt you too.  ;-)

Implementations can do all the things you say "LISP cannot do".

> A consequence of the pull model is that LISP requires additional protocol support to solve the problem of ETR liveness. This protocol support can take the form of feedback from the forwarding plane…

It is not additional, it is part of the control-plane. Have no idea what you are getting at. And please justify why this comment is helpful for an intro document?

> -          Section 3.5 should mention how PITRs will impact the size of global routing tables during the LISP transition period, particularly of EIDs cannot be aggregated before advertisement by th…

No, there is a cost for any benefit. And it may not impact it as much as I think you think it does.

> -          LISP supports IPv6 transitions and VPN not because of the architectural characteristics that are unique to LISP, but because of the architectural characteristics that it shares with many…

Other solutions cannot support these features and give you multi-homing, load-balancing, multicast, and traffic engineering at the same time.

Dino

---

From: Ross Callon <[email-masked]>
Date: Fri, 14 Nov 2014 05:07:13 +0000

This (both -07 and -08) is much improved from the previous versions.  I just have two questions regarding what is not there.

Previous versions of the LISP introduction had a section on "xTR Mapping Cache Performance". This section (in the older documents) was largely based on studies that made unrealistic assumptions about the granularity of the mapping table entries. Thus it seems reasonable to have dropped the section. However, with a cache based system, isn't cache performance in fact quite important? Is this something that would go into a different document, and if so which one?

Also, I didn't see a discussion of OAM. This also seems like something that is quite important. Is this again something that would go into a different document?

Thanks, Ross

All,

Joel & Luigi

---

From: Damien Saucez <[email-masked]>
Date: Thu, 13 Nov 2014 19:16:33 -1000

Hello

On 13 Nov 2014, at 19:07, Ross Callon <[email-masked]> wrote:

> Previous versions of the LISP introduction had a section on "xTR Mapping Cache Performance". This section (in the older documents) was largely based on studies that made unrealistic assumptions about the granularity of the mapping table entries. Thus it seems reasonable to have dropped the section. However, with a cache based system, isn’t cache performance in fact quite important? Is this something that would go into a different document, and if so which one?

We decide to put all the “subjective” parts in impact document.  By subjective I
mean the things that are not directly related to the protocol but more to how
it is used.  Impact is in the charter so we see intro as a description of the
protocol and impact as what could happen if LISP were used.
>  
> Also, I didn’t see a discussion of OAM. This also seems like something that is quite important. Is this again something that would go into a different document?
>  

Impact. We would be more than happy to have feedback from people 
about the different impact but what we are looking is impact based on
facts, not expectations. 

Damien Saucez

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 14 Nov 2014 18:53:50 -1000

Hi All,

as already announced today we close the WG Last Call on the LISP Introduction document.

During this extended period of last call the document has been updated twice (now -09)  to address the last few remaining issues.

It is clear from the support in the mailing list and the discussion yesterday during the meeting that there is WG consensus to move the document forward.

The writeup will follow very soon.

Joel & Luigi

> On 25 Oct 2014, at 02:03, Luigi Iannone <[email-masked]> wrote:
> 
> All,
> 
> http://tools.ietf.org/html/draft-ietf-lisp-introduction-07 <http://tools.ietf.org/html/draft-ietf-lisp-introduction-07>
>