Subject: [lisp] Question from the mic

From: Dino Farinacci <[email-masked]>
Date: Fri, 22 Jul 2016 02:31:31 -0700

Renwei, to answer your question at the mic. You can find both LISP to non-LISP interworking and the deployment RFC below, RFC6832 and RFC7215, respectively.

Dino

---

From: Richard Li <[email-masked]>
Date: Mon, 25 Jul 2016 15:06:48 +0000

Hi Dino,

All those RFCs are dealing with general cases. But this is something I am particularly interested in:

Assume an UE is "dual-stacked": 4G/LTE and LISP. The UE is initially served by a PGW, which is on a non-LISP site. Now the UE moves from the non-LISP site to a LISP site with itself being treated as EID. In this case, I would like to know how LISP supports, if it does, the mobility to keep session continuity?

Thanks,

Renwei

From: Dino Farinacci [mailto:[email-masked]]
Sent: Friday, July 22, 2016 11:32 AM
To: Richard Li
Cc: LISP mailing list list
Subject: Question from the mic

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 25 Jul 2016 10:21:27 -0700

> All those RFCs are dealing with general cases. But this is something I am particularly interested in:

Right, agree.

> Assume an UE is “dual-stacked”: 4G/LTE and LISP. The UE is initially served by a PGW, which is on a non-LISP site. Now the UE moves from the non-LISP site to a LISP site with itself being treated as EID. In this case, I would like to know how LISP supports, if it does, the mobility to keep session continuity?

Right, good question. So let me explain.

The UE would be implementing draft-meyer-lisp-mn. The PGW would be a PxTR as described in RFC6832.

(1) The PGW would inject routes into the BGP core routing system for the EID prefixes allocated to the UEs. That allows non-EIDs to send packets to the PGW so, in turn, they can LISP encapsulated to the UE.

(2) As the UE moves and obtains new RLOCs, the PGW will update it’s map-cache to LISP encapsulate to the new RLOC(s) for the UE.

(3) For the UE sending packets, it is pretty trivial, it can have a default map-cache entry pointing to the PGW’s RLOC address. So the PGW can decapsulate LISP encapsulated packets and forward them to the non-EID. The UE could also have a bit more specific (but still coarse) map-cache entries to laod spread all the UEs across different PGWs. And each map-cache entry could also have multiple RLOCs so load-splitting can happen from an UE across multiple PGWs in the same region.

If you don’t want the UE to run LISP, then we implement draft-portholes-lisp-eid-mobility, as I described in my EID mobility presentation during the working group. Where the EID is still assigned to the UE and the RLOC and LISP xTR functionality can be either in the eNodeB or SGW.

Hope this helps,
Dino