Subject: [lisp] Lisp for 5G

From: Sharon <[email-masked]>
Date: Sat, 27 Aug 2016 08:34:04 -0400

I know folks have been working on lisp for mobile wireless access.

If in 5G (mobility/handover) are indeed factored out of ( AAA/Charging) |->  into pure IP overlay edge networking ..

Did anyone look at a weighted/probability based ID-Location schema where ITR chooses ETR by applying a "fuzzy" selection logic for moving identities? (movable && moving things)

*edge to mean provider edge PE/XTR:
RAN <> XTR <> underlay <> XTR <> Internet

"Pro-choice" ETR balanced selection is already providing better capacity-utilization within a service providers. This can be an extension.
Interesting to know what's been done already..

--szb

---

From: Dino Farinacci <[email-masked]>
Date: Sat, 27 Aug 2016 12:34:03 -0400

> Did anyone look at a weighted/probability based ID-Location schema where ITR chooses ETR by applying a "fuzzy" selection logic for moving identities? (movable && moving things)

In draft-meyer-lisp-mn we created a requirement and spec'ed out the M-bit in the Map-Register message. 

The intent was to allow an ITR or PITR to know that an ETR was acting in behalf of an EID that moved often. Thereby allowing the ITR/PITR to flush its cache often as an alternative to waiting for SMR messages from the ETR or Map-Notify messages from map-servers. 

Do you think this mechanism is sufficient for your requirement?

And yes, the priority and weights can be manipulated so the encapsulator has choice to choose another ETR. 

Dino

---

From: Sharon <[email-masked]>
Date: Sat, 27 Aug 2016 18:56:33 -0400

Maybe we should go in a draft through all the mechanisms, multi home, bits, Smr ..
specifically in the context of handover 
Perhaps a heads up message from the mobile device  is needed before fully  moving from ETR to ETR ...

--szb

> On Aug 27, 2016, at 12:34 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 28 Aug 2016 06:11:38 -0700

> Perhaps a heads up message from the mobile device  is needed before fully  moving from ETR to ETR …

Some of this is already in the draft-portoles-lisp-eid-mobility draft. Please have a look at it and give us detailed comments about what you see is missing. And we will add.

Maybe this is a good time to ask the working group to have a detailed look at draft-portoles-lisp-eid-mobility since other working groups are looking at LISP to solve the mobility problem (as well as SDOs like 3GPP and ETSI).

So comments are welcome!!!

Dino

---

From: Sharon <[email-masked]>
Date: Sun, 28 Aug 2016 09:16:08 -0400

Will take a look.
Thanks!

--szb