Subject: Re: [lisp] [Ideas] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

From: Richard Li <[email-masked]>
Date: Wed, 28 Sep 2016 21:11:34 +0000

Hi Dino and Padma,

With great interest, I have read draft-padma-ideas-problem-statement-00.txt.

Since some efforts have been made, at least partially, in LISP, why do we still want to work on it? Appreciated if you could explain it a little bit.

Thanks,

Richard

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 28 Sep 2016 15:21:19 -0700

> Since some efforts have been made, at least partially, in LISP, why do we still want to work on it? Appreciated if you could explain it a little bit.

LISP is a solution. The draft is a requirements document. We need to generate requirements to decide if the LISP solution meets them.

It might sound backwards, but that is how it works out chronologically.

Dino

---

From: Padmadevi Pillay Esnault <[email-masked]>
Date: Wed, 28 Sep 2016 23:51:21 +0000

Hi Richard
  
Thank you for your comment.
  
The ideas problem statement is introducing a new Network Mapping Systems (NMS) in order to have an efficient interoperable solution between ID based protocols. 

The LISP mapping system's main functionality is to provide the mapping of ID/LOC in LISP.
However, the NMS goal is to have a common control plane for multiple data-planes rather than one mapping system or scheme per protocol.

We also are building the NMS to cater for a wide variety of fixed and mobility cases including IoT, IP mobility and mobility over heterogeneous access networks. The Network mapping systems may also have different scopes (local, regional or global) and be private or public as well.

The expectations is that the NMS will be a powerful extensible infrastructure usable by all and not restricted to specific use cases.

Padma   

-----Original Message-----
From: Ideas [mailto:[email-masked]] On Behalf Of Dino Farinacci
Sent: Wednesday, September 28, 2016 3:21 PM
To: Richard Li
Cc: [email-masked]; [email-masked]
Subject: Re: [Ideas] [lisp] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

Dino

_______________________________________________
Ideas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ideas

---

From: Lin Han <[email-masked]>
Date: Thu, 29 Sep 2016 17:49:09 +0000

Hi, Padma

This sounds interesting, are you saying that the mapping system will finally support the interworking between different Loc/id protocols, such as LISP and HIP and others?
Also, could you elaborate the "common control plane". This impressed me it will be a super-controller, isn't it?

Thanks

Lin

-----Original Message-----
From: Ideas [mailto:[email-masked]] On Behalf Of Padmadevi Pillay Esnault
Sent: Wednesday, September 28, 2016 4:51 PM
To: Dino Farinacci; Richard Li
Cc: [email-masked]; [email-masked]; Padmadevi Pillay Esnault
Subject: Re: [Ideas] [lisp] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

Hi Richard

Padma   

-----Original Message-----
From: Ideas [mailto:[email-masked]] On Behalf Of Dino Farinacci
Sent: Wednesday, September 28, 2016 3:21 PM
To: Richard Li
Cc: [email-masked]; [email-masked]
Subject: Re: [Ideas] [lisp] Mapping System Requirements and draft-padma-ideas-problem-statement-00.txt

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 29 Sep 2016 11:21:16 -0700

> Also, could you elaborate the "common control plane". This impressed me it will be a super-controller, isn't it?

I don’t see any reason why a HIP host cannot send LISP Map-Requests and Map-Registers to a LISP mapping system. It could do it for any EID type, even though a HIT is a perfectly fine EID key to use.

Dino