Subject: [lisp] I-D Action: draft-ietf-lisp-gpe-09.txt

From: [email-masked]
Date: Fri, 25 Oct 2019 09:54:11 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Locator/ID Separation Protocol WG of the IETF.

        Title           : LISP Generic Protocol Extension
        Authors         : Fabio Maino
                          Jennifer Lemon
                          Puneet Agarwal
                          Darrel Lewis
                          Michael Smith
	Filename        : draft-ietf-lisp-gpe-09.txt
	Pages           : 16
	Date            : 2019-10-25

Abstract:
   This document describes extentions to the Locator/ID Separation
   Protocol (LISP) Data-Plane, via changes to the LISP header, to
   support multi-protocol encapsulation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lisp-gpe/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lisp-gpe-09
https://datatracker.ietf.org/doc/html/draft-ietf-lisp-gpe-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-gpe-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Fri, 25 Oct 2019 17:32:47 +0000

This is an updated version of LISP-GPE that is meat to address the open discuss and harmonize the content with 6830bis and 6833bis. Attached is a diff with version -06 that is the one to which most of the discuss comments refer to. 

The main changes are: 
- the introduction of the concept of shim header that explicitly describe how LISP-GPE can be used to add data plane functions to LISP
- removed the allocation of code points for extensions that are still drafts (GBP and IOAM)
- we have tried to address the  TSV-ART discuss by introducing a new section 4  (Implementation and Deployment Considerations) that follows what done by RFC 8086 (GRE in UDP) to refer to RFC8085 guidelines. The applicability statement refers to the LISP scope of applicability defined in 6830bis. 
- changes in section 3 and 7 should help address the secdir discuss. 

Thanks,
Fabio

On 10/25/19, 9:55 AM, "lisp on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    _______________________________________________
    lisp mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lisp