Subject: [lisp] I-D Action: draft-ietf-lisp-gpe-15.txt

From: [email-masked]
Date: Sun, 31 May 2020 22:41:15 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Locator/ID Separation Protocol WG of the IETF.

        Title           : LISP Generic Protocol Extension
        Authors         : Fabio Maino
                          Jennifer Lemon
                          Puneet Agarwal
                          Darrel Lewis
                          Michael Smith
	Filename        : draft-ietf-lisp-gpe-15.txt
	Pages           : 15
	Date            : 2020-05-31

Abstract:
   This document describes extentions to the Locator/ID Separation
   Protocol (LISP) Data-Plane, via changes to the LISP header, to
   support multi-protocol encapsulation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lisp-gpe/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lisp-gpe-15
https://datatracker.ietf.org/doc/html/draft-ietf-lisp-gpe-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-gpe-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 1 Jun 2020 07:47:25 +0200

Thank you for updating the document.

I have a quick question.

Looking at the next protocol values we now see:

 0x7E to 0x7F:  Experimentation and testing	
 0x80 to 0xFD:  Unassigned (shim headers)	
 0xFE to 0xFF:  Experimentation and testing

Can you provide a rationale why not having just one bigger experimentation and testing range instead of two with an unassigned range in the middle?

Thanks

Ciao

L.

> On 1 Jun 2020, at 07:41, [email-masked] wrote:
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Mon, 1 Jun 2020 05:48:20 +0000

This version should address the latest comments from Mirja. It also includes Next Protocol codepoints for experimentation and testing, as was previously mentioned in the mailing list. 

Diff attached.

Thanks,
Fabio

On 5/31/20, 10:41 PM, "lisp on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Abstract:

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Mon, 1 Jun 2020 05:53:13 +0000

Ciao Luigi, 
The reason is to allow to experiment with shim headers and non-shim headers at the same time. As you may remember shim headers have a more fixed encodng and must be located before non-shim headers. 

Thanks,
Fabio

On 5/31/20, 10:47 PM, "Luigi Iannone" <[email-masked]> wrote:

    I have a quick question.

    Thanks

    Ciao

    L.