Subject: [lisp] Fwd: New Version Notification for draft-farinacci-lisp-simple-nat-00.txt

From: Dino Farinacci <[email-masked]>
Date: Tue, 19 May 2020 07:55:42 -0700

It is now posted. 

Cheers,
Dino

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-farinacci-lisp-simple-nat-00.txt
> Date: May 19, 2020 at 7:53:10 AM PDT
> To: "Dino Farinacci" <[email-masked]>
> 
> 
> A new version of I-D, draft-farinacci-lisp-simple-nat-00.txt
> has been successfully submitted by Dino Farinacci and posted to the
> IETF repository.
> 
> Name:		draft-farinacci-lisp-simple-nat
> Revision:	00
> Title:		A Simple LISP NAT-Traversal Implementation
> Document date:	2020-05-18
> Group:		Individual Submission
> Pages:		15
> URL:            https://www.ietf.org/internet-drafts/draft-farinacci-lisp-simple-nat-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-farinacci-lisp-simple-nat/
> Htmlized:       https://tools.ietf.org/html/draft-farinacci-lisp-simple-nat-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-farinacci-lisp-simple-nat
> 
> 
> Abstract:
>   This informational draft documents the lispers.net LISP NAT-Traversal
>   implementation.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 19 May 2020 11:15:01 -0400

Dino, trying to make sure I am reading this right.

How does the Map Server decide which set of answers to give?  It 
magically knows which requesters are RTRs?  It compares the requester 
with the registered entries?

And am I reading it right that this draft assigns special meaning 
(sometimes? always?) to priority 254?

Yours,
Joel

On 5/19/2020 10:55 AM, Dino Farinacci wrote:
> It is now posted.
> 
> Cheers,
> Dino
> 
>> Begin forwarded message:
>>
>> *From: [email-masked] <mailto:[email-masked]>
>> *Subject: **New Version Notification for 
>> draft-farinacci-lisp-simple-nat-00.txt*
>> *Date: *May 19, 2020 at 7:53:10 AM PDT
>> *To: *"Dino Farinacci" <[email-masked] <mailto:[email-masked]>>
>>
>>
>> Name:draft-farinacci-lisp-simple-nat
>> Revision:00
>> Title:A Simple LISP NAT-Traversal Implementation
>> Document date:2020-05-18
>> Group:Individual Submission
>> Pages:15
>> URL: 
>> https://www.ietf.org/internet-drafts/draft-farinacci-lisp-simple-nat-00.txt
>> Htmlized: 
>> https://datatracker.ietf.org/doc/html/draft-farinacci-lisp-simple-nat
>>
>>
>> Abstract:
>>   This informational draft documents the lispers.net 
>> <http://lispers.net> LISP NAT-Traversal
>>   implementation.
>>
>>
>>
>>
>> until the htmlized version and diff are available at tools.ietf.org 
>> <http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>>
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 19 May 2020 08:23:49 -0700

> Dino, trying to make sure I am reading this right.

Thanks for having a look at it so quickly Joel.

> How does the Map Server decide which set of answers to give?  It magically knows which requesters are RTRs?  It compares the requester with the registered entries?

Yes. If the requester is in the list of RTRs identified by unicast priority 254, then it returns Global RLOCs. If the requester is not in the list, then the list of unicast priority 254 RLOCs are returned.

> And am I reading it right that this draft assigns special meaning (sometimes? always?) to priority 254?

Yes.

Dino