Subject: Re: [lisp] I-D Action: draft-ietf-lisp-gpe-15.txt

From: Luigi Iannone <[email-masked]>
Date: Tue, 2 Jun 2020 09:11:40 +0200

> On 1 Jun 2020, at 07:53, Fabio Maino (fmaino) <[email-masked]> wrote:
> 
> Ciao Luigi, 
> The reason is to allow to experiment with shim headers and non-shim headers at the same time. As you may remember shim headers have a more fixed encodng and must be located before non-shim headers.

That is OK for me. 

But my question is why this:

> 0x7E to 0x7F:  Experimentation and testing	
>     0x80 to 0xFD:  Unassigned (shim headers)	
>     0xFE to 0xFF:  Experimentation and testing

Instead of this (range has been adapted):

0x7E to 0xFB:  Unassigned (shim headers)	
0xFC to 0xFF:  Experimentation and testing

??

Certainly I am missing something ;-)

Ciao

L.

> 
> Thanks,
> Fabio
> 
> 
> 
> On 5/31/20, 10:47 PM, "Luigi Iannone" <[email-masked]> wrote:
> 
>    Thank you for updating the document.
> 
>    I have a quick question.
> 
>    Looking at the next protocol values we now see:
> 
>     0x7E to 0x7F:  Experimentation and testing	
>     0x80 to 0xFD:  Unassigned (shim headers)	
>     0xFE to 0xFF:  Experimentation and testing
> 
>    Can you provide a rationale why not having just one bigger experimentation and testing range instead of two with an unassigned range in the middle?
> 
>    Thanks
> 
>    Ciao
> 
>    L.
> 
> 
> 
>> On 1 Jun 2020, at 07:41, [email-masked] wrote:
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Locator/ID Separation Protocol WG of the IETF.
>> 
>>       Title           : LISP Generic Protocol Extension
>>       Authors         : Fabio Maino
>>                         Jennifer Lemon
>>                         Puneet Agarwal
>>                         Darrel Lewis
>>                         Michael Smith
>> 	Filename        : draft-ietf-lisp-gpe-15.txt
>> 	Pages           : 15
>> 	Date            : 2020-05-31
>> 
>> Abstract:
>>  This document describes extentions to the Locator/ID Separation
>>  Protocol (LISP) Data-Plane, via changes to the LISP header, to
>>  support multi-protocol encapsulation.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-lisp-gpe/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-lisp-gpe-15
>> https://datatracker.ietf.org/doc/html/draft-ietf-lisp-gpe-15
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-gpe-15
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> 
>> _______________________________________________
>> lisp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lisp
> 
>

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Tue, 2 Jun 2020 17:34:36 +0000

Ciso Luigi, please see below...

    That is OK for me. 

    > 0x7E to 0x7F:  Experimentation and testing	

FM> The two above are for experimentation of NON shim headers

>FM These two are for experimentation of shim headers. 

Shim headers are placed (and processed) first, so we want to give the freedom to experiment with both. 

For example, one would want to experiment with a shim header (identified by 0xFE) that carries some special metadata for IPv4 payloads, while someone else would want to experiment with IPv8 payloads (identified with 0x7E). A third person might want to experiment, at the same time, with a shim header that carries special metadata for IPv8. 

Fabio

    ??

    Ciao

    L.

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 3 Jun 2020 07:38:54 +0200

Hi Fabio,

thanks for the clarification. I think that I finally got it:

0x7E to 0x7F is for just experimentation.

 0xFE to 0xFF is for shim headers experimentation 

My confusion came from the fact that is not clearly stated.

Can we modify the text as:

0x7E to 0x7F:  Experimentation and testing	
0x80 to 0xFD:  Unassigned (shim headers)	
0xFE to 0xFF:  Experimentation and testing (shim headers)

So that the difference  is clearly stated.

Ciao

L.

> On 2 Jun 2020, at 19:34, Fabio Maino (fmaino) <[email-masked]> wrote:
> 
> On 6/2/20, 12:11 AM, "Luigi Iannone" <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 3 Jun 2020 07:44:51 +0200

Hello again,

if you agree to change the text as for may previous email table in section 6 IANA Considerations must be updated as well.

Ciao

L.

> On 3 Jun 2020, at 07:38, Luigi Iannone <[email-masked]> wrote:
> 
> Hi Fabio,
> 
>> On 2 Jun 2020, at 19:34, Fabio Maino (fmaino) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> On 1 Jun 2020, at 07:53, Fabio Maino (fmaino) <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Ciao Luigi, 
>>> On 5/31/20, 10:47 PM, "Luigi Iannone" <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> On 1 Jun 2020, at 07:41, [email-masked] <mailto:[email-masked]> wrote:
>>>> 
>>>> 
>>>> https://datatracker.ietf.org/doc/draft-ietf-lisp-gpe/ <https://datatracker.ietf.org/doc/draft-ietf-lisp-gpe/>
>>>>

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Wed, 3 Jun 2020 16:43:35 +0000

Sounds good Luigi.

I’ll publish an updated version that reflects your suggestions later today.

Fabio

From: Luigi Iannone <[email-masked]>
Date: Tuesday, June 2, 2020 at 10:45 PM
To: Fabio Maino <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [lisp] I-D Action: draft-ietf-lisp-gpe-15.txt
Resent-From: <[email-masked]>
Resent-To: Fabio Maino <[email-masked]>, <[email-masked]>, <[email-masked]>, Darrel Lewis <[email-masked]>, <[email-masked]>
Resent-Date: Tuesday, June 2, 2020 at 10:44 PM

Hello again,

Ciao

L.

On 3 Jun 2020, at 07:38, Luigi Iannone <[email-masked]<mailto:[email-masked]>> wrote:

Hi Fabio,

Ciao

L.

On 2 Jun 2020, at 19:34, Fabio Maino (fmaino) <[email-masked]<mailto:[email-masked]>> wrote:

On 6/2/20, 12:11 AM, "Luigi Iannone" <[email-masked]<mailto:[email-masked]>> wrote:

On 1 Jun 2020, at 07:53, Fabio Maino (fmaino) <[email-masked]<mailto:[email-masked]>> wrote:

Ciao Luigi,

   That is OK for me.

Fabio

   ??

   Ciao

   L.

Thanks,
Fabio

On 5/31/20, 10:47 PM, "Luigi Iannone" <[email-masked]<mailto:[email-masked]>> wrote:

  I have a quick question.

  Thanks

  Ciao

  L.

On 1 Jun 2020, at 07:41, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

---

From: "Fabio Maino (fmaino)" <[email-masked]>
Date: Wed, 3 Jun 2020 17:00:17 +0000

Done!

Fabio

From: Fabio Maino <[email-masked]>
Date: Wednesday, June 3, 2020 at 9:43 AM
To: Luigi Iannone <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [lisp] I-D Action: draft-ietf-lisp-gpe-15.txt

Sounds good Luigi.

Fabio

Hello again,

Ciao

L.

Hi Fabio,

Ciao

L.

Ciao Luigi,

   That is OK for me.

Fabio

   ??

   Ciao

   L.

Thanks,
Fabio

  I have a quick question.

  Thanks

  Ciao

  L.

Abstract:

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 3 Jun 2020 20:35:46 +0200

Perfect :-)

Thanks Fabio

L.

> On 3 Jun 2020, at 19:00, Fabio Maino (fmaino) <[email-masked]> wrote:
> 
> Done!
>  
> Fabio
>  
>> On 3 Jun 2020, at 07:38, Luigi Iannone <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> Hi Fabio,
>>  
>>>>> https://tools.ietf.org/html/draft-ietf-lisp-gpe-15 <https://tools.ietf.org/html/draft-ietf-lisp-gpe-15>