Subject: [Mobike] Issue: Simultaneous movements (#2)

From: Jari Arkko <[email-masked]>
Date: Mon, 21 Jun 2004 21:42:19 +0300

This is about the level of support for simultaneous
movements by the communicating parties.

There seems to be a number of different cases here:

(a) Two mobile nodes getting a new address at the
     same time, and then being unable to tell each
     other where they are. This problem is called the
     rendevouz problem, and is traditionally solved
     using home agents (Mobile IPv6) or forwarding
     agents (Host Identity Protocol). Essentially,
     solving this problem requires the existence of
     a stable infrastructure node somewhere.

     Example: roaming laptop to another roaming laptop,
     no SGW involved.

(b) Simultanous changes to addresses such that at
     least one of the new addresses was known by
     both peers before the change occurred. The
     primary problem in case (a) was not knowing
     the new addresses beforehand.

     Example 1: two SGWs failover to another path.
     Example 2: roaming laptop gets a new address
     at the same time as its SGW's primary interface
     goes down.

(c) No simultaneous changes at all.

[Our charter prohibits the creation of a fully
fledged mobility protocol, so it seems that we
should avoid introducing new network nodes to
solve the rendevouz problem. Therefore, case (b)
seems like a good candidate for us. This would
still allow two SGWs to failover from one common
interface to another. And of course, if someone
wants to set up their IPsec tunnels so that everything
always goes through one stable anchorpoint in the
network, they can do so.]

_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Dondeti, Lakshminath" <[email-masked]>
Date: Mon, 21 Jun 2004 14:50:14 -0400

(b) sounds like a reasonable choice.

Lakshminath

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 22 Jun 2004 12:33:15 +0300

> (b) sounds like a reasonable choice.

I agree... 

-- 
[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Thu, 24 Jun 2004 19:19:01 +0200

In your previous mail you wrote:

   
   
=> this is a well known problem with a well known solution
clearly outside the charter.

   
=> in fact this is the same problem than (a) but in a multi-homing
context (in place of a mobility one). (a) solution works of course
but a simple policy (just try all the other peer addresses you know)
too. So I agree to keep (b) but I'd like to put the requirement
over policies, not mechanisms (as soon as they provide the other
peer address list of course).

Regards

[email-masked]

PS: the simple policy is simple to describe but not so simple to use
because of the source (i.e., own peer address) selection...
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike