Subject: RE: [Mobike] New issue 16: No packets from other end?

From: <[email-masked]>
Date: Fri, 13 Aug 2004 10:39:43 -0400

I needed some clarifications from MOBIKE veterans, before expressing 
an opinion:

What is the "other end" here? The mobile host? or the multihoming
SGW?

Who initiates the MOBIKE protocol? I would guess:
	(1) a mobile host after the move, needs to notify the remote SGW of
	    its new address.
	(2) a multihoming SGW, upon detecting that one of its interfaces
	    (which was used to contact the mobile host) is down and it needs 
	    to notify the mobile host of its new interface address to be used.

Are there any other scenarios of how MOBIKE can be initiated? When would
we use the information that there is "lack of packets from the other end",
to initiate the MOBIKE protocol?

Thanks,
Atul

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of ext 
> Sent: Thursday, August 12, 2004 9:01 AM
> To: [email-masked]
> Subject: [Mobike] New issue 16: No packets from other end?
> 
> 
> I've created a new issue in the issue list:
> 
>    "Can the protocol recover from situations where the only 
>    sign of problems is lack of packets from the other end?"
> 
>    (http://www.vpnc.org/ietf-mobike/issues.html)
> 
> Many people at the WG meeting expressed opinions that this 
> should be handled somehow (in addition to handling e.g. 
> link-down triggers from layer 2, or something similar).
> 
> So far, I do not remember anyone saying that the protocol
> does not need to handle this situation. But comments
> are welcome.
> 
> Best regards,
> Pasi
> _______________________________________________
> Mobike mailing list
> [email-masked]
> https://www.machshav.com/mailman/listinfo.cgi/mobike
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Sun, 15 Aug 2004 20:25:00 +0200

In your previous mail you wrote:

   What is the "other end" here?

=> you are at one side, the other end is the other.

   The mobile host? or the multihoming SGW?

=> you are narrowing the scope of MOBIKE without good reasons.
MOBIKE supports one or both ends mobile and/or multi-homed.

   Are there any other scenarios of how MOBIKE can be initiated?

=> many, for instance two multi-homed hosts, two multi-homed SGWs,
a mobile SGW, a multi-homed host, etc.

   When would
   
=> IMHO this is not in the scope of the MOBIKE protocol so I can't give
an answer. But if this end knows alternate peer addresses of the other end,
obviously to try them seems a good idea...

Regards

[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike