Subject: [Mobike] Comments on draft-eronen-mobike-mopo-00.txt

From: Jari Arkko <[email-masked]>
Date: Sun, 01 Aug 2004 10:52:57 +0300

Pasi,

I liked your draft! I think your approach of having
a set of separate features - independently usable even
in a non-mobile situation - is a good one. I also liked
the NAT prevention feature a lot! The path testing
approach you have is also good, I think.

A couple of comments:

o Section 1.2. If I am not mistaken, one of the features
   that you are also not doing is the movement of IPsec
   SAs one by one. You move them all at once, right?

o Section 7.3: I'm not sure I understand exactly
   what "when the window size allows" implies. Can we
   get into an eternal wait if there's something else
   going on at the same time as we move?

o Section 8.1: Couldn't you condense the first two bullets
   by saying that if the responder is not behind a NAT
   and is non-mobile, then the initiator can be multihomed,
   mobile and behind any type of a NAT? If this is the case,
   then I believe there's sufficient functionality.

o We need more details to what happens when you receive
   a NAT_PREVENTION payload and there has been an address
   change in transit.

Editorial:

o Section 6: s/not addresses/not all addresses/

--Jari

_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "Dondeti, Lakshminath" <[email-masked]>
Date: Sun, 01 Aug 2004 16:36:33 -0400

>    going on at the same time as we move?
This may be stating the obvious, but, for instance, if there is an 
outstanding rekey message for which a response has not been received, 
and if the peer moves, an RR request could not be sent, right?  
(assuming window size =1, but we can construct a scenario for window 
size > 1).  So, "RR required for any further operation" policy 
would/might not quite work.  (I need to double check the rekeying 
rules).  Delayed RR would work however, because the rekey process could 
be completed before verifying RR (the rekey reply message would have to 
be accepted whether it comes from the old or the new address).

cheers,
Lakshminath