Subject: [Mobike] issue 6: scope of SA changes

From: Tero Kivinen <[email-masked]>
Date: Mon, 1 Nov 2004 13:27:47 +0200

Jari Arkko writes:
> 1. Would it be useful to treat different flows or applications
>     in a different manner with regards to their multihoming
>     behaviour? For instance, keep one flow always in GPRS
>     but allow another flow to use LAN where available.
> 
>     Yes, optional  [X]

I think it is usefull feature on some scenarios, but it is not needed
at all by others, so it needs to be optional. 

> 2. Would you like to provide this functionality through
> 
>     Separate IKE SAs and their independent addresses     [X]

Separate IKE SA would be fine, i.e. I do not think this so important
issue that we need to add fine granularity to the SA movement. 
-- 
[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: "James Kempf" <[email-masked]>
Date: Mon, 1 Nov 2004 08:42:05 -0800

I'm not in favor of providing flow handover in MOBIKE at this time.  I think
there are some tricky issues here involving congestion and routing in access
networks that need more study. In addtion, there has been some discussion of
doing flow handover in MIP, and I think it might make some sense to consider
both these cases together. Perhaps at some point a BOF on flow handover
might be appropriate.

            jak

----- Original Message ----- 
From: "Jari Arkko" <[email-masked]>
To: "MOBIKE Mailing List" <[email-masked]>
Sent: Sunday, October 31, 2004 10:07 AM
Subject: [Mobike] issue 6: scope of SA changes

>
> Lets have a consensus call on this. From the list
> discussion so far I don't see enough people commenting
> on this that would enable us to make decision. For
> a more accurate decision, I have broken the issue down
> into three questions.
>
>     Yes, mandatory [ ]
>     Yes, optional  [ ]
>     No             [ ]
>     Separate IPsec SAs and their independent addresses   [ ]
>     Separate IKE SAs and their independent addresses     [ ]
>
> 3. If you prefer the use of IPsec SAs for this purpose,
>     would you like
>
>     always manage each SA separately           [ ]
>     provide a default where all SAs are moved  [ ]
>
> Send your answers by Wednesday, Nov 3rd, 2004. The rationale
> behind your answers will help others form their opinions, so
> please state also why you are answering in a particular way.
>
> --Jari
>

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Sat, 2 Oct 2004 19:47:18 -0700

>     Yes, optional  [ X]
>     Separate IKE SAs and their independent addresses     [X ]
> 
I don't understand completely (all the consequences) as to what it means to
keep some IPsec SAs at the old address while the IKE SA moves to
the new address. So, i would like to keep it simple for now.

-mohan

---

From: Jari Arkko <[email-masked]>
Date: Mon, 08 Nov 2004 21:54:08 +0200

I think we have consensus on this.

Some of us see a possible need for an optional
mechanism that is capable of treating some flows
in different manner than others. But it appears
that IKE SA based mechanisms are sufficient, i.e.,
no need to build specific IPsec SA treatment into
the protocol.

Pasi, you can update the issue list regarding #6.

--Jari

---

From: Francis Dupont <[email-masked]>
Date: Tue, 09 Nov 2004 22:51:12 +0100

In your previous mail you wrote:

   Lets have a consensus call on this.

=> consensus on a mailing list takes time...

   From the list

       Yes, mandatory [X]
       Yes, optional  [ ]
       No             [ ]
   
=> note this is exactly the way SCTP works.

       Separate IPsec SAs and their independent addresses   [X]
       Separate IKE SAs and their independent addresses     [ ]
   
=> one IKE SA to manage the whole thing is the simplest (so the best)
solution.

       always manage each SA separately           [ ]
       provide a default where all SAs are moved  [X]
   
   Send your answers by Wednesday, Nov 3rd, 2004.

=> not everybody is at 100% on this job, please give reasonable
dead-lines (i.e., don't follow another WG pretty bad example :-).

   The rationale
   
=> there is something forgotten: what to do with the SPD?
If only SAD is updated, at the next re-keying the new SA pair
will use the old addresses... In the mobility case one can even
argue some SPD entries without corresponding SAs should be updated
too!

Regards

[email-masked]
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Tue, 09 Nov 2004 23:02:14 +0100

=> no, you don't or you have a strange idea of what is a consensus...
(at least not mine :-)

=> I disagree, in fact expressed opinions at your exception are
all about the mobile context, not the multi-homing or the SCTP contexts.

Regards