Subject: VS: [Mobike] issue 6: scope of SA changes

From: <[email-masked]>
Date: Mon, 1 Nov 2004 18:18:46 +0200

I would like to understand this little bit better before answering.
 
If we have this fine granularity and we do not want to move some 
streaming data from WLAN to GPRS, what would happen to these
SA's that are used to protect the streaming data during the handover? 
If they stay as they were, does the streaming server send the data all 
the time to this "lost connection", or do we some how delete the 
"WLAN SA's" that are not moved to GPRS? 
What happens to application level connection? Is it just going to die
because there is no acknowledgements coming in?
 
Or should we move all SA's to GPRS and then let the application kill
the unwanted stream? 
 
Mika

	-----Alkuperäinen viesti----- 
	Lähettäjä: [email-masked] puolesta: ext Tero Kivinen 
	Lähetetty: ma 1.11.2004 3:27 
	Vastaanottaja: [email-masked] 
	Kopio: MOBIKE Mailing List 
	Aihe: [Mobike] issue 6: scope of SA changes

	Jari Arkko writes:
	> 1. Would it be useful to treat different flows or applications
	>     in a different manner with regards to their multihoming
	>     behaviour? For instance, keep one flow always in GPRS
	>     but allow another flow to use LAN where available.
	>
	>     Yes, optional  [X]
	
	I think it is usefull feature on some scenarios, but it is not needed
	at all by others, so it needs to be optional.
	
	> 2. Would you like to provide this functionality through
	>
	>     Separate IKE SAs and their independent addresses     [X]
	
	Separate IKE SA would be fine, i.e. I do not think this so important
	issue that we need to add fine granularity to the SA movement.
	--
	[email-masked]
	_______________________________________________
	Mobike mailing list
	[email-masked]
	https://www.machshav.com/mailman/listinfo.cgi/mobike

_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Jari Arkko <[email-masked]>
Date: Mon, 01 Nov 2004 22:00:49 +0200

Hi Mika,

> Or should we move all SA's to GPRS and then let the application kill

There's probably a few different cases. If we are talking about
mobility, then it seems that you have to move everything with
you to the new address in any case. (Unless you want to do
something like the zero address set for some of the SAs --
this might make sense if you have high-bandwidth traffic
that you don't want to come and fill you GPRS buffers.
But my head hurts if I try to think about this combination
of features...)

Another situation is multihoming. You could have stream 1
that you always keep in GPRS and stream 2 that you move
to the WLAN whenever its available. If you go out of
WLAN coverage, you don't kill stream 2, you just move
it back to GPRS.

--Jari