Subject: RE: [Mobike] When to do Return Routability Checks

From: Tschofenig Hannes <[email-masked]>
Date: Thu, 9 Dec 2004 13:58:43 +0100

hi again, 

this answer is again cryptic. 

where would you like to see more flexibility? 

>to wait the 
> RR check result is fine only when the previous peer address 
> is still usable.

would you like to add some else cases? 

ciao
hannes

> -----Original Message-----
> From: Francis Dupont [mailto:[email-masked]] 
> Sent: Donnerstag, 09. Dezember 2004 13:53
> To: [email-masked]
> Cc: Tschofenig Hannes; [email-masked]
> Subject: Re: [Mobike] When to do Return Routability Checks 
> 
>  In your previous mail you wrote:
> 
>    Yes. For the do it all, I think the answer depends on 
> configured policy,
>    with default being yes. For the when part, I think it 
> should be done
>    prior to moving the SA and the data stream towards that address.
>    
> => we need more flexibility about moving the SA: to wait the 
> RR check result is fine only when the previous peer address 
> is still usable.
> 
> Regards
> 
> [email-masked]
> 
_______________________________________________
Mobike mailing list
[email-masked]
https://www.machshav.com/mailman/listinfo.cgi/mobike

---

From: Francis Dupont <[email-masked]>
Date: Fri, 10 Dec 2004 11:05:10 +0100

> RR check result is fine only when the previous peer address 

=> there are two cases when we move from peer address A to peer address B:
 - peer address A is still usable: the IKE SA should be updated
   only after the end of the RR check
 - peer address A is no more usable (the usual case with mobility):
   the IKE SA (but not IPsec SAs) should be updated at the reception
   of the update request
Two details:
 - there is scenario where ASAP update is mandatory: imagine an window
   of one message is used and there is a pending request to send: if
   it is sent to the peer address A and this address no more works
   the exchange will never finish.
 - now how to know when an address is no more usable: with my address
   management framework the initiator wll simply remove it from the set.

Thanks