Subject: [MSEC] MIKEY SRTP policy: secure negotiation of RTP with MIKEY?

From: Euchner Martin ICN M SR 3 <[email-masked]>
Date: Thu, 11 Jul 2002 11:34:05 +0200

Dear all,

MIKEY allows securely negotiating SRTP capabilities (algorithms, modes,
security services) using the SRTP policy.

How can MIKEY securely negotiate that RTP instead of SRTP be used? This
would allow a secure fall-back to RTP at least.

By disabling any SRTP security features (NULL) in section 6.10.1 ?

With kind regards

Martin Euchner.
-----------------------------------------------------------------------
| Dipl.-Inf.                     Rapporteur Q.G/SG16
| Martin Euchner                 Phone: +49 89 722 55790
| Siemens AG.....................Fax  : +49 89 722 47713
| ICN M SR 3                     mailto:[email-masked]
|                                mailto:[email-masked]
| Hofmannstr. 51                 Intranet:
http://intranet.icn.siemens.de/marketing/cs27/topics/security/
| D-81359 Muenchen               Internet: http://www.siemens.de/
| __________________
| Germany     
-----------------------------------------------------------------------

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Fredrik Lindholm (EAB)" <[email-masked]>
Date: Thu, 11 Jul 2002 11:48:43 +0200

Hi Martin!

In IKE, do you negotiate IP instead of IPsec if the responder 
do not support security? I don't think this make sense. If 
the guy doesn't support security, then you may go out (in 
the case of SIP) with a new Invite setting up RTP instead of 
SRTP only if your local policy allows you to. Recall also that SRTP 
and "normal" RTP are different profiles (see also my previous 
comment at the mmusic list http://www1.ietf.org/mail-archive/working-groups/mmusic/current/msg00596.html). 

BR,
Fredrik

---

From: "Fredrik Lindholm (EAB)" <[email-masked]>
Date: Thu, 11 Jul 2002 14:14:43 +0200

> 
> Hello Fredrick,
> 
> considering an environment with an endpoint supporting MIKEY 
> but not SRTP
> (yet), the method you described would work in general where 
> the responder
> rejects and another negotiation attempt be made, but this 
> clearly introduces
> another roundtrip. This is bad for a real-time environment 
> where the prime
> goal is to minimize roundtrips as in MIKEY.

I think the goal should be to be able to setup a secure session 
in one round-trip during ordinary circumstances. I see no reason 
why to try to optimize it for extraordinary circumstances. Anyway, 
I see more security problems with having a quick fallback and 
personally I would never advice anyone to use a quick fallback 
mode. IMHO, the user trying to setup the secure session should 
always be notified and given the possibility to choose how to 
proceed. BTW, in the scenario above, SIP (or RTSP) would fail 
when the SAVP profile (when used) is detected as not supported 
(and that has nothing to do with MIKEY). 

> 
> I agree that SRTP and RTP are different profiles. Does this 
> mean that MIKEY
> is not applicable to the RTP profile? (not that I want to 
> distribute keys
> for RTP, that does not make sense at all, but to have a 
> secured profile
> negotiation).

MIKEY does not support RTP. 

Fredrik

>  -----Original Message-----
> From: 	Fredrik Lindholm (EAB) 
[mailto:[email-masked]] 
Sent:	Thursday, July 11, 2002 11:49 AM
To:	Euchner Martin  ICN M SR 3; [email-masked]
Cc:	[email-masked]'; Elisabetta Carrara (EAB); Karl Norrman
(EAB)
Subject:	RE: MIKEY SRTP policy: secure negotiation of RTP with MIKEY?

Hi Martin!

In IKE, do you negotiate IP instead of IPsec if the responder 
do not support security? I don't think this make sense. If 
the guy doesn't support security, then you may go out (in 
the case of SIP) with a new Invite setting up RTP instead of 
SRTP only if your local policy allows you to. Recall also that SRTP 
and "normal" RTP are different profiles (see also my previous 
comment at the mmusic list
http://www1.ietf.org/mail-archive/working-groups/mmusic/current/msg00596.htm
l). 

BR,
Fredrik

---

From: Euchner Martin ICN M SR 3 <[email-masked]>
Date: Thu, 11 Jul 2002 12:44:40 +0200

Hello Fredrick,

considering an environment with an endpoint supporting MIKEY but not SRTP
(yet), the method you described would work in general where the responder
rejects and another negotiation attempt be made, but this clearly introduces
another roundtrip. This is bad for a real-time environment where the prime
goal is to minimize roundtrips as in MIKEY.

I agree that SRTP and RTP are different profiles. Does this mean that MIKEY
is not applicable to the RTP profile? (not that I want to distribute keys
for RTP, that does not make sense at all, but to have a secured profile
negotiation).

With kind regards

Martin Euchner.

 -----Original Message-----
From: 	Fredrik Lindholm (EAB) [mailto:[email-masked]] 
Sent:	Thursday, July 11, 2002 11:49 AM
To:	Euchner Martin  ICN M SR 3; [email-masked]
Cc:	[email-masked]'; Elisabetta Carrara (EAB); Karl Norrman
(EAB)

Hi Martin!

BR,
Fredrik