Subject: RE: [MSEC] What is the relation between IKE and MIKEY?

From: "Fredrik Lindholm (EAB)" <[email-masked]>
Date: Mon, 24 Feb 2003 09:13:32 +0100

Hi,
(see comments inline)

> From: Deuk-Whee Kwak [mailto:[email-masked]]
> Sent: den 23 februari 2003 10:56
> To: [email-masked]
> Subject: [MSEC] What is the relation between IKE and MIKEY?
> 
> 
> Hi
> What is the relation between IKE and MIKEY?
> As far as I understand, IKE is mainly used for network-level 
> peer-to-peer key exchange protocol, and MIKEY is mainly used 
> for application-level multicast key exchange protocol. 

MIKEY was designed to be a "low latency" group key distribution 
protocol that could work in e.g., small size interactive groups. 
This put completely different requirements on MIKEY compared 
to IKE (e.g., the one round-trip requirement, the group key 
distribution functionality requirement etc). 

> Then, is it impossible to use IKE for application-level 
> multicast key exchange protocol?

Correct (there exist no functionality in IKE to distribute a group key
for a multicast groups). 

Best,
Fredrik

> Thanks
> 
> _______________________________________________
> msec mailing list
> [email-masked]
> http://www.pairlist.net/mailman/listinfo/msec
> 

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: Lakshminath Dondeti <[email-masked]>
Date: Mon, 24 Feb 2003 10:03:49 -0500

GDOI (similar to IKE) and GSAKMP may be of interest to you.

cheers,
Lakshminath