Subject: [MSEC] [Fwd: LAST CALL: ESP and AH ESN drafts]

From: Brian Weis <[email-masked]>
Date: Wed, 28 May 2003 11:37:21 -0700

Note that the new ESP and AH drafts are now officially in last call.
These drafts contain a number of changes from RFCs 2402/2406 that make
them more useful when used to protect IP multicast packets. If anyone
has any additional issues, now is the time to speak!

From my memory, there was only one change in these latest versions that
affects the multicast case. That was the removal of the "protocol" from
the SPI lookup for multicast packets. (I.e., from {destination, SPI,
protocol} to {destination, SPI} for any source multicast groups). 

The effect of this change seems minor. It slightly increases the
possibility of ambiguous SPI lookups. This should only happen if two key
servers are not choosing SPIs in a coordinated fashion for the same
destination. (E.g., if two applications were using the same destination
address.) But it is still a problem whether or not the protocol field
remains in the SPI lookup, so it does not seem worth arguing about.

Other than that, I personally didn't have any concerns with the drafts.

Brian
-- 
Brian Weis
Strategic Cryptographic Development, ITD, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]

Subject: LAST CALL: ESP and AH ESN drafts
From: Barbara Fraser <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Mon, 26 May 2003 18:45:48 -0700

This is a working group last call for comments on the following drafts, for 
progression to Proposed Standard:

draft-ietf-ipsec-esp-v3-05.txt
draft-ietf-ipsec-rfc2402bis-03.txt
draft-ietf-ipsec-esn-addendum-01.txt

These drafts have not received a great amount of attention so Ted and I 
would like to urge everyone to take a good look at them. We are extending 
the working group last call to 3 weeks to give folks adequate time to 
comment. This last call will expire on June 16.

thanks,
Barb and Ted

---

From: Lakshminath Dondeti <[email-masked]>
Date: Wed, 28 May 2003 14:47:12 -0400

I guess we still need an MESP I-D!  I was hoping that there would be one 
ESP RFC that will work for both multicast and unicast.

regards,
Lakshminath

Brian Weis wrote:
> ------------------------------------------------------------------------
> 
> Subject:
> This is a working group last call for comments on the following drafts, 
> for progression to Proposed Standard:
> 
> would like to urge everyone to take a good look at them. We are 
> extending the working group last call to 3 weeks to give folks adequate 
> time to comment. This last call will expire on June 16. 
> 
> thanks,
> Barb and Ted

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: Mark Baugher <[email-masked]>
Date: Wed, 28 May 2003 12:55:03 -0700

Neither do I.

Mark
At 11:37 AM 5/28/2003 -0700, Brian Weis wrote:
>Email: [email-masked]: <[email-masked]>
>Received: from sj-core-4.cisco.com (sj-core-4.cisco.com [171.68.223.138])
>         by mira-sjc5-b.cisco.com (Mirapoint Messaging Server MOS 3.3.3-GR)
>         with ESMTP id AHM25452;
>         Tue, 27 May 2003 06:29:02 -0700 (PDT)
>Received: from sj-msg-av-2.cisco.com (sj-msg-av-2.cisco.com [171.70.145.31])
>         by sj-core-4.cisco.com (8.12.6/8.12.6) with ESMTP id h4RDVTNb006377;
>         Tue, 27 May 2003 06:31:29 -0700 (PDT)
>Received: from proxy3.cisco.com (proxy3.cisco.com [128.107.241.181])
>         by sj-msg-av-2.cisco.com (8.12.2/8.12.2) with ESMTP id 
> h4RDUx19003511;
>         Tue, 27 May 2003 06:31:00 -0700 (PDT)
>Received: from lists.tislabs.com (portal.gw.tislabs.com [192.94.214.101])
>         by proxy3.cisco.com (8.12.8p1/8.11.2) with ESMTP id h4RDW2Wd011253;
>         Tue, 27 May 2003 06:32:02 -0700 (PDT)
>Received: by lists.tislabs.com (8.9.1/8.9.1) id JAA05996
>         Tue, 27 May 2003 09:20:40 -0400 (EDT)
>Message-Id: <[email-masked]>
>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Version 4.3.2
>Mime-Version: 1.0
>Content-Type: multipart/alternative;
>         boundary="=====================_364919486==_.ALT"
>Sender: [email-masked]
>Precedence: bulk
>X-Mozilla-Status2: 00000000
>

---

From: Brian Weis <[email-masked]>
Date: Wed, 28 May 2003 14:21:35 -0700

Hi Lakshminath,

> ESP RFC that will work for both multicast and unicast.

We still need a document like MESP to be able to describe how to do
source origin authentication, replay protection for multi-sender SAs,
and other such topics that are germane only to the multicast usage. The
good news is that MESP can be ESP with some additional semantics, rather
than a new protocol altogether. The latest version of MESP reflects this
goal.

Brian