Subject: [MSEC] Re: "split" parameter for FEC order in MIKEY

From: "Fredrik Lindholm" <[email-masked]>
Date: Fri, 13 Jun 2003 01:17:29 +0200

Hi Mark,

as this was taken from one of the previous versions of SRTP, I hoped you
could have explained that to me ;-)    I will look into this when I'm back
at office, and maybe update this to match with the latest version of SRTP.
Thanks for pointing it out.

Fredrik

----- Original Message ----- 
From: "Mark Baugher" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 12, 2003 7:16 AM
Subject: "split" parameter for FEC order in MIKEY

> Hello Fredrik
>    Would you or one of the other MIKEY authors explain to me what "split"
> means for fec order on p. 36 of
> http://www.ietf.org/internet-drafts/draft-ietf-msec-mikey-06.txt.  I don't
> understand why we would encrypt, compute the fec stream packet, and then
> authenticate the original packet.  I assume that this scheme works with
> http://www.ietf.org/rfc/rfc2733.txt.
>
> thanks, Mark
>

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: "Elisabetta Carrara (EAB)" <[email-masked]>
Date: Fri, 13 Jun 2003 11:14:45 +0200

Hi
yes, the "split" value in the FEC order is from a previous version 
(I think v3) of SRTP. And it is correct that the RFC for FEC is 2733.

In that version of SRTP, we had a longer section on the FEC interaction 
than in the current version. The old text, if I remember correctly, said 
that the split (i.e., encr-fec-auth, at sender side) would be the optimal 
order, however we did not choose it as default in SRTP for the complications 
due to the splitting of the security processing. 
That old text was reflection of a discussion we had at that time 
on the avt mailing list, you can find it in the archive.

In the current version of SRTP, we only define the default order, and say 
that any other order has to be signalled (by key mgnt).
So, MIKEY should carry the values for the signalling. The only risk
to have it there is that maybe the processing has to be defined (we 
did not look at it, so we don't know). 
But we keep this in mind for the next revision of MIKEY.

Cheers
/E  

> -----Original Message-----
> From: Fredrik Lindholm (EAB) 
> Sent: den 13 juni 2003 01:17
> To: Mark Baugher
> Cc: [email-masked]
> Subject: [MSEC] Re: "split" parameter for FEC order in MIKEY
> 
> 
> 
> Hi Mark,
>