Subject: [MSEC] GSAKMP issue 07: Leave Group semantics unspecified

From: George Gross <[email-masked]>
Date: Fri, 8 Aug 2003 15:30:18 -0400 (EDT)

GSAKMP issue 07

Section and relevant text passage:

section 4.3.1 Member Joins/Leaves

Comment/issue description:

Hmmm.... it appears that a Group Member can never leave the group. I'm
reminded of the 60's era TV spy show "The Prisoner" :o)

Both the voluntary leave and member eviction cases need to be dealt with...

Suggested issue resolution:

Is this text cast this way because the mandatory to implement GTEK Rekey method does not
support forward secrecy? Even if that is the case, since optional LKH (or other vendor specific)
rekey has to be supported, then it seems reasonable to require that the GSAKMP protocol
should have a "Leave Group Request" message exchange. The state diagram in section 7 should add
transitions for this set of cases.

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: Ken Calvert <[email-masked]>
Date: Fri, 8 Aug 2003 22:42:20 -0400 (EDT)

> Is this text cast this way because the mandatory to
> implement GTEK Rekey method does not support forward
> secrecy? Even if that is the case, since optional LKH (or
> other vendor specific) rekey has to be supported, then it
> seems reasonable to require that the GSAKMP protocol
> should have a "Leave Group Request" message exchange. The
> state diagram in section 7 should add transitions for this
> set of cases.

More general comment:

I've never really understood the connection between
voluntary member departure and forward secrecy.  If the
member's authorization status hasn't changed from the policy
point of view, why should GCKS care whether the member is
still listening?

I guess there might be resources (e.g. logical tree
positions)  the member holds that the GCKS might want to
reclaim?  But the tradeoffs are not clear, and it is
certainly not clear to me that a "leave group request"
exchange is warranted.

Policy change is a different.  I can see the case for an
"eviction notification" more clearly...

KC

---

From: "The Purple Streak, Hilarie Orman" <[email-masked]>
Date: Fri, 8 Aug 2003 23:58:26 -0600

I agree that voluntary leave does not require forward secrecy, but I suppose
a member might ask for a rekey upon leaving so that she would not be accused
later of having listened.

Hilarie