Subject: Re: [MSEC] GSAKMP issue 19: Notify payload type trigger conditions

From: Uri Meth <[email-masked]>
Date: Fri, 3 Oct 2003 13:39:10 -0400

Yes, this table needs an explanation for each type in it.  This will be
added in the next rev of the spec (sort of what IKEv2 did for a lot of
its values in tables).

Boy, I sure have a lot of writeups to get out there :-o)

Have a great weekend everybody.  See you next week.

UM

On Fri, Aug 08, 2003 at 03:43:24PM -0400, George Gross wrote:
> 
> GSAKMP issue 19
> 
> Section and relevant text passage:
> 
> 6.9 Notify Payload table 17
> 
> Comment/issue description:
> 
> Some of the payload types do not have obvious
> trigger conditions. these are:
> 
> 	- Situation-not-supported (where is the situation specified?)
> 	- Invalid-version (as mentioned in other issues)
> 	- Invalid-Sequence-ID (given packets can delivery out of order)
> 	- Invalid-ID-Information (which ID?)
> 	- Notify-GSA-Lifetime (is this to say the group needs to self-destruct?)
> 	- Unable-to-take-requested-role (for which message would a node do this?)
> 
> Suggested issue resolution:
> 
> Add descriptive text at this point in the spec, or else at the point
> where the Notify could be generated by verification processing.
> 
> 
> 
> _______________________________________________
> msec mailing list
> [email-masked]
> http://www.pairlist.net/mailman/listinfo/msec

-- 
Uri Meth                            (410) 872 - 1515 x233 (voice)
SPARTA, Inc.                        (410) 872 - 8079      (fax)
7075 Samuel Morse Drive             [email-masked]
Columbia, MD 21046

_______________________________________________
msec mailing list
[email-masked]
http://www.pairlist.net/mailman/listinfo/msec

---

From: George Gross <[email-masked]>
Date: Sun, 5 Oct 2003 17:45:30 -0400 (EDT)

Hi Uri,

> added in the next rev of the spec (sort of what IKEv2 did for a lot of

thx, that will help this section alot.

> Boy, I sure have a lot of writeups to get out there :-o)

if it is any consolation for all the revision effort, I think the
resulting draft will be miles closer to what will work for future
implementors and IESG review.

thanks for moving forward on these issues!

br,
	George

> Have a great weekend everybody.  See you next week.

P.S. thx, it was great weekend, too bad it was sooo short... ;o)